summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-04-24 17:21:07 -0400
committerAaron Bauman <bman@gentoo.org>2018-04-24 17:21:07 -0400
commit3ef2060ce07014795e8d488564729e1796bcf084 (patch)
tree99b05245d9a1793a665180210d9db994edf3b29d
parentsys-apps/sandbox-2.13: arm64 stable (bug #651336) (diff)
downloadgentoo-3ef2060ce07014795e8d488564729e1796bcf084.tar.gz
gentoo-3ef2060ce07014795e8d488564729e1796bcf084.tar.bz2
gentoo-3ef2060ce07014795e8d488564729e1796bcf084.zip
net-mail/dbmail: add LibreSSL support
Closes: https://bugs.gentoo.org/613272 Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--net-mail/dbmail/dbmail-3.2.3-r1.ebuild9
-rw-r--r--net-mail/dbmail/dbmail-3.2.3-r2.ebuild7
2 files changed, 11 insertions, 5 deletions
diff --git a/net-mail/dbmail/dbmail-3.2.3-r1.ebuild b/net-mail/dbmail/dbmail-3.2.3-r1.ebuild
index 61bff9022a7b..9ac49a99e820 100644
--- a/net-mail/dbmail/dbmail-3.2.3-r1.ebuild
+++ b/net-mail/dbmail/dbmail-3.2.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ SRC_URI="http://www.dbmail.org/download/$(get_version_component_range 1-2)/${P}.
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="ldap sieve ssl static"
+IUSE="ldap libressl sieve ssl static"
DEPEND="dev-db/libzdb
sieve? ( >=mail-filter/libsieve-2.2.1 )
@@ -24,7 +24,10 @@ DEPEND="dev-db/libzdb
dev-libs/gmime:2.6
>=dev-libs/glib-2.16
dev-libs/libevent
- ssl? ( dev-libs/openssl )"
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
RDEPEND="${DEPEND}"
DOCS="AUTHORS README.md INSTALL THANKS UPGRADING"
diff --git a/net-mail/dbmail/dbmail-3.2.3-r2.ebuild b/net-mail/dbmail/dbmail-3.2.3-r2.ebuild
index 6d19833506fc..2875f819a206 100644
--- a/net-mail/dbmail/dbmail-3.2.3-r2.ebuild
+++ b/net-mail/dbmail/dbmail-3.2.3-r2.ebuild
@@ -12,7 +12,7 @@ SRC_URI="http://www.dbmail.org/download/$(get_version_component_range 1-2)/${P}.
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="ldap sieve ssl static"
+IUSE="ldap libressl sieve ssl static"
DEPEND="dev-db/libzdb
sieve? ( >=mail-filter/libsieve-2.2.1 )
@@ -24,7 +24,10 @@ DEPEND="dev-db/libzdb
dev-libs/gmime:2.6
>=dev-libs/glib-2.16
dev-libs/libevent
- ssl? ( dev-libs/openssl )"
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
RDEPEND="${DEPEND}"
pkg_setup() {