summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 18:11:33 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:49 +0200
commit3fb2c6ebd1326bcba355d0e4d3c164d0af6cd1fa (patch)
treec926a57f2af53746802e2f2559ed2ada6224b623
parentdev-ml/spawn: initial import (diff)
downloadgentoo-3fb2c6ebd1326bcba355d0e4d3c164d0af6cd1fa.tar.gz
gentoo-3fb2c6ebd1326bcba355d0e4d3c164d0af6cd1fa.tar.bz2
gentoo-3fb2c6ebd1326bcba355d0e4d3c164d0af6cd1fa.zip
dev-ml/ppx_optional: initial import
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-ml/ppx_optional/Manifest1
-rw-r--r--dev-ml/ppx_optional/metadata.xml8
-rw-r--r--dev-ml/ppx_optional/ppx_optional-0.9.0.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/ppx_optional/Manifest b/dev-ml/ppx_optional/Manifest
new file mode 100644
index 000000000000..1bd4bc45073b
--- /dev/null
+++ b/dev-ml/ppx_optional/Manifest
@@ -0,0 +1 @@
+DIST ppx_optional-0.9.0.tar.gz 6940 SHA256 4f9cae512eab8c3457329d9ca0655f8ea9ca0d1465ceb7d13734e0972912d6f2 SHA512 c341bc8e64b7caf7af5c878747697330db84b14959f22930dd6919cc861dce847983771cbad2ed7800ab8c64704e88fa0d8db3ca7c8f2924bf785a4dccd17fa0 WHIRLPOOL 2abb146131f62d7f8da17bd67bdeaf30ac495a3ac63ccd3506c81aa20f1287671ece5cd20e6fae7fa3e1177b4e6b6e0b10fb4252b623455134a0d708c6c1859b
diff --git a/dev-ml/ppx_optional/metadata.xml b/dev-ml/ppx_optional/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/ppx_optional/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ppx_optional/ppx_optional-0.9.0.ebuild b/dev-ml/ppx_optional/ppx_optional-0.9.0.ebuild
new file mode 100644
index 000000000000..f8bbaf9cb1c0
--- /dev/null
+++ b/dev-ml/ppx_optional/ppx_optional-0.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Pattern matching on flat options"
+HOMEPAGE="https://github.com/janestreet/ppx_optional"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}