summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-01-18 16:44:53 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2017-01-18 16:52:16 +0200
commit3fbe009eaa171fac368b1ea0327e28386599e7fe (patch)
treee2206d0f2d076611ba7668a613a99b13766f7399
parentapp-crypt/pinentry: cleanup (diff)
downloadgentoo-3fbe009eaa171fac368b1ea0327e28386599e7fe.tar.gz
gentoo-3fbe009eaa171fac368b1ea0327e28386599e7fe.tar.bz2
gentoo-3fbe009eaa171fac368b1ea0327e28386599e7fe.zip
dev-libs/botan: cleanup
Bug: 605202 Package-Manager: portage-2.3.0
-rw-r--r--dev-libs/botan/Manifest1
-rw-r--r--dev-libs/botan/botan-1.10.13.ebuild150
-rw-r--r--dev-libs/botan/files/botan-1.11.34-rng.patch30
3 files changed, 0 insertions, 181 deletions
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index 107b4380739a..7a022aa7c4c5 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -1,3 +1,2 @@
-DIST Botan-1.10.13.tgz 2710181 SHA256 23ec973d4b4a4fe04f490d409e08ac5638afe3aa09acd7f520daaff38ba19b90 SHA512 a09d2cb5dda21bf384b81675025f249abdfe232c95dc3383f0baebc2bf1603b2ed1e2aec9a81aae95df592ec2eeae8906c63474a6da42ad3701669a5d8f14656 WHIRLPOOL 4161d689205f02ed8b97bb371be47829d11dee744a024e24bb834264cfa6143c8a9fb7df969410975e4bf2b708063e3c05b6106c4dbe7f5566e3331ee5e901a9
DIST Botan-1.10.14.tgz 2710757 SHA256 10ed0b394db165733ac9557d8656356b7e9744d38c61c2b9c44cba6d84ff4c1c SHA512 ae524653a99b02d6d8d7bb2b88a446c066fe1044d8fd2708ea2a4cd5aafbe2b0d165d2ce1730669a4df18013cf5b6540bb5944bafea512b4957e3417de512e95 WHIRLPOOL 51aa1d68757ad515f65c255c585be8050efed085800340d43fa068b48647ef8c50fc9e284ac16d0cef3d874f5fa44f143210dcc004561807e1d1b307d89cff9d
DIST Botan-2.0.0.tgz 4989901 SHA256 031659cca0f80869e9d97a20917edbe2164cedbc079e8c53e0e7bd9bea15371a SHA512 4cb6992b5998ead175c10a9f193b0cde208b81a99bf30412a3b8386e7c91de2ff5d8191fd49893f02643519721bcf16c58db3cbee3eccbeb566f4456d310cf8f WHIRLPOOL ba180e5be87c9212fdf2e9252eb6d477bf608f976476b75e31e393ec19d94dada876b5dda9881f4cbe6dd7fec642a8a2b2a728bc90e07c44661237a067ae09ce
diff --git a/dev-libs/botan/botan-1.10.13.ebuild b/dev-libs/botan/botan-1.10.13.ebuild
deleted file mode 100644
index 43ef01ef44f6..000000000000
--- a/dev-libs/botan/botan-1.10.13.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="6"
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit eutils multilib python-r1 toolchain-funcs
-
-MY_PN="Botan"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="A C++ crypto library"
-HOMEPAGE="http://botan.randombit.net/"
-SRC_URI="http://botan.randombit.net/releases/${MY_P}.tgz"
-
-KEYWORDS="amd64 ~arm hppa ~ia64 ppc ppc64 sparc x86 ~ppc-macos"
-SLOT="0"
-LICENSE="BSD"
-IUSE="bindist doc python bzip2 gmp ssl static-libs threads zlib"
-
-S="${WORKDIR}/${MY_P}"
-
-RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
- zlib? ( >=sys-libs/zlib-1.2.3 )
- python? ( ${PYTHON_DEPS} >=dev-libs/boost-1.48[python,${PYTHON_USEDEP}] )
- gmp? ( >=dev-libs/gmp-4.2.2:* )
- ssl? ( >=dev-libs/openssl-0.9.8g:*[bindist=] )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-src_prepare() {
- default
-
- sed -e "s/-Wl,-soname,\$@ //" -i src/build-data/makefile/python.in || die "sed failed"
- sed \
- -e "/DOCDIR/d" \
- -e "/^install:/s/ docs//" \
- -i src/build-data/makefile/unix_shr.in || die "sed failed"
-
- # Fix ImportError with Python 3.
- sed -e "s/_botan/.&/" -i src/wrap/python/__init__.py || die "sed failed"
-
- use python && python_copy_sources
-}
-
-src_configure() {
- local disable_modules="proc_walk,unix_procs"
- use threads || disable_modules+=",pthreads"
- use bindist && disable_modules+=",ecdsa"
- elog "Disabling modules: ${disable_modules}"
-
- # Enable v9 instructions for sparc64
- if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
- CHOSTARCH="sparc32-v9"
- else
- CHOSTARCH="${CHOST%%-*}"
- fi
-
- local myos=
- case ${CHOST} in
- *-darwin*) myos=darwin ;;
- *) myos=linux ;;
- esac
-
- # foobared buildsystem, --prefix translates into DESTDIR, see also make
- # install in src_install, we need the correct live-system prefix here on
- # Darwin for a shared lib with correct install_name
- ./configure.py \
- --prefix="${EPREFIX}/usr" \
- --libdir=$(get_libdir) \
- --docdir=share/doc \
- --cc=gcc \
- --os=${myos} \
- --cpu=${CHOSTARCH} \
- --with-endian="$(tc-endian)" \
- --without-sphinx \
- --with-tr1=system \
- $(use_with bzip2) \
- $(use_with gmp gnump) \
- $(use_with python boost-python) \
- $(use_with ssl openssl) \
- $(use_with zlib) \
- --disable-modules=${disable_modules} \
- || die "configure.py failed"
-}
-
-src_compile() {
- emake CXX="$(tc-getCXX)" AR="$(tc-getAR) crs" LIB_OPT="${CXXFLAGS}" MACH_OPT=""
-
- if use python; then
- building() {
- rm -fr build/python
- ln -s "${BUILD_DIR}" build/python
- cp Makefile.python build/python
- sed -i \
- -e "s/-lboost_python/-lboost_python-$(echo ${EPYTHON} | sed 's/python//')/" \
- build/python/Makefile.python
- emake -f build/python/Makefile.python \
- CXX="$(tc-getCXX)" \
- CFLAGS="${CXXFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- PYTHON_ROOT="/usr/$(get_libdir)" \
- PYTHON_INC="-I$(python_get_includedir)"
- }
- python_foreach_impl building
- fi
-
- if use doc; then
- einfo "Generation of documentation"
- sphinx-build doc doc_output
- fi
-}
-
-src_test() {
- chmod -R ugo+rX "${S}"
- emake CXX="$(tc-getCXX)" CHECK_OPT="${CXXFLAGS}" check
- LD_LIBRARY_PATH="${S}" ./check --validate || die "Validation tests failed"
-}
-
-src_install() {
- emake DESTDIR="${ED}usr" install
-
- if ! use static-libs; then
- rm "${ED}usr/$(get_libdir)/libbotan"*.a || die 'remove of static libs failed'
- fi
-
- # Add compatibility symlinks.
- [[ -e "${ED}usr/bin/botan-config" ]] && die "Compatibility code no longer needed"
- [[ -e "${ED}usr/$(get_libdir)/pkgconfig/botan.pc" ]] && die "Compatibility code no longer needed"
- dosym botan-config-1.10 /usr/bin/botan-config
- dosym botan-1.10.pc /usr/$(get_libdir)/pkgconfig/botan.pc
-
- if use python; then
- installation() {
- rm -fr build/python
- ln -s "${BUILD_DIR}" build/python
- emake -f Makefile.python \
- PYTHON_SITE_PACKAGE_DIR="${ED}$(python_get_sitedir)" \
- install
- }
- python_foreach_impl installation
- fi
-
- if use doc; then
- pushd doc_output > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static
- popd > /dev/null
- fi
-}
diff --git a/dev-libs/botan/files/botan-1.11.34-rng.patch b/dev-libs/botan/files/botan-1.11.34-rng.patch
deleted file mode 100644
index da814f11b8c5..000000000000
--- a/dev-libs/botan/files/botan-1.11.34-rng.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 2b72637f06ad35bd5458372a964bf30a0b4f7cf9 Mon Sep 17 00:00:00 2001
-From: Alon Bar-Lev <alon.barlev@gmail.com>
-Date: Thu, 1 Dec 2016 21:55:17 +0200
-Subject: [PATCH] system_rng: workaround read only urandom
-
-Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
----
- src/lib/rng/system_rng/system_rng.cpp | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/src/lib/rng/system_rng/system_rng.cpp b/src/lib/rng/system_rng/system_rng.cpp
-index eaba382..12b0876 100644
---- a/src/lib/rng/system_rng/system_rng.cpp
-+++ b/src/lib/rng/system_rng/system_rng.cpp
-@@ -135,8 +135,11 @@ void System_RNG_Impl::add_entropy(const uint8_t input[], size_t len)
- * by the OS or sysadmin that additional entropy is not wanted
- * in the system pool, so we accept that and return here,
- * since there is no corrective action possible.
-+ *
-+ * In Linux EBADF or EPERM is returned if m_fd is not opened for
-+ * writing.
- */
-- if(errno == EPERM)
-+ if(errno == EPERM || errno == EBADF)
- return;
-
- // maybe just ignore any failure here and return?
---
-2.7.3
-