summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-09-18 19:04:58 -0700
committerZac Medico <zmedico@gentoo.org>2019-09-18 19:04:58 -0700
commit400b0c2e011d9466f5b53f709c5c0963bddd0c3e (patch)
tree4e634ef7653d4dae85e99fff04ba64beba83ffd2
parentapp-emulation/docker-swarm: LICENSE: account for vendored software (diff)
downloadgentoo-400b0c2e011d9466f5b53f709c5c0963bddd0c3e.tar.gz
gentoo-400b0c2e011d9466f5b53f709c5c0963bddd0c3e.tar.bz2
gentoo-400b0c2e011d9466f5b53f709c5c0963bddd0c3e.zip
app-emulation/docker-registry: Remove old versions
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-emulation/docker-registry/Manifest2
-rw-r--r--app-emulation/docker-registry/docker-registry-2.6.2-r1.ebuild43
-rw-r--r--app-emulation/docker-registry/docker-registry-2.7.0-r1.ebuild48
-rw-r--r--app-emulation/docker-registry/docker-registry-2.7.0.ebuild41
4 files changed, 0 insertions, 134 deletions
diff --git a/app-emulation/docker-registry/Manifest b/app-emulation/docker-registry/Manifest
index 9bf0d949d911..c13a696e584b 100644
--- a/app-emulation/docker-registry/Manifest
+++ b/app-emulation/docker-registry/Manifest
@@ -1,3 +1 @@
-DIST docker-registry-2.6.2.tar.gz 1579760 BLAKE2B d0e067f2e9124847b5e362f23ca7d67655fbf0a6227efc3fd9073d5360389d6d8531e5709b52225c54e6e3097a2d5d79102e27fd09412b95d2e5d8a4a30dde2d SHA512 a091db2e15d7c1dc8cd39a40de5bb63cc1ead68e95dfaf6b3735a789adb87f146c03eff81f700e0059e5f6ffc43e6c3dd3358503697882cb080b991629f82c60
-DIST docker-registry-2.7.0.tar.gz 1996485 BLAKE2B 49022546b72a1ea2b457a3dc059d8940bfba3070208b2962f8acd1351312d568d6facc1690ae8ee78742b5647c3a84bd6538a9eb0c279aec0a8dfae2c823fa61 SHA512 72bf5f0953c58e4d1adf6427ee13a9456204ab278d4489277e4dd1b3a3df6717cc02c966cdfcdf77d86e769209fa18e377e0b12a6c02b9f58980185e9844aec6
DIST docker-registry-2.7.1.tar.gz 1996699 BLAKE2B 2e22db69f476be5a4688f5b3d6b41fbbf71460351543ae849f707dd5b3d56624f674815a25214002886b057f0859f75fd197bb275a7b3cc8a7787422f716ad0e SHA512 f6baf0e7aa96ebe828c628f7dfd84ee899331c3c1bdab86662aef595b092702b6d9b2c9be766a6de6d153ff4ca55d85c5fd8785a0968f285f56a32a50092c754
diff --git a/app-emulation/docker-registry/docker-registry-2.6.2-r1.ebuild b/app-emulation/docker-registry/docker-registry-2.6.2-r1.ebuild
deleted file mode 100644
index 863b9ac50826..000000000000
--- a/app-emulation/docker-registry/docker-registry-2.6.2-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit golang-vcs-snapshot systemd user
-
-KEYWORDS="~amd64"
-EGO_PN="github.com/docker/distribution"
-EGIT_COMMIT="v${PV}"
-SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-DESCRIPTION="Docker Registry 2.0"
-HOMEPAGE="https://github.com/docker/distribution"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-SVCNAME=registry
-
-PATCHES=( "${FILESDIR}/${PN}-2.6.1-notifications-expvar.patch" )
-
-pkg_setup() {
- enewgroup ${SVCNAME}
- enewuser ${SVCNAME} -1 -1 /dev/null ${SVCNAME}
-}
-
-src_compile() {
- export -n GOCACHE XDG_CACHE_HOME #681072
- GOPATH="${S}" \
- go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}/..." || die
-}
-
-src_install() {
- exeinto /usr/libexec/${PN}
- doexe bin/*
- insinto /etc/docker/registry
- newins src/${EGO_PN}/cmd/registry/config-example.yml config.yml.example
- newinitd "${FILESDIR}/${SVCNAME}.initd" "${SVCNAME}"
- newconfd "${FILESDIR}/${SVCNAME}.confd" "${SVCNAME}"
- systemd_dounit "${FILESDIR}/${SVCNAME}.service"
- keepdir /var/{lib,log}/${SVCNAME}
- fowners ${SVCNAME}:${SVCNAME} /var/{lib,log}/${SVCNAME}
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${SVCNAME}.logrotated" "${SVCNAME}"
-}
diff --git a/app-emulation/docker-registry/docker-registry-2.7.0-r1.ebuild b/app-emulation/docker-registry/docker-registry-2.7.0-r1.ebuild
deleted file mode 100644
index c117f1e13143..000000000000
--- a/app-emulation/docker-registry/docker-registry-2.7.0-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit golang-vcs-snapshot systemd user
-
-KEYWORDS="~amd64"
-EGO_PN="github.com/docker/distribution"
-EGIT_COMMIT="v${PV}"
-SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-DESCRIPTION="Docker Registry 2.0"
-HOMEPAGE="https://github.com/docker/distribution"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-SVCNAME=registry
-
-pkg_setup() {
- enewgroup ${SVCNAME}
- enewuser ${SVCNAME} -1 -1 /dev/null ${SVCNAME}
-}
-
-src_prepare() {
- default
- pushd src/${EGO_PN} || die
- eapply "${FILESDIR}"/${P}-notification-metrics.patch
- popd || die
-}
-
-src_compile() {
- export -n GOCACHE XDG_CACHE_HOME #681072
- GOPATH="${S}" \
- go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}/..." || die
-}
-
-src_install() {
- exeinto /usr/libexec/${PN}
- doexe bin/*
- insinto /etc/docker/registry
- newins src/${EGO_PN}/cmd/registry/config-example.yml config.yml.example
- newinitd "${FILESDIR}/${SVCNAME}.initd" "${SVCNAME}"
- newconfd "${FILESDIR}/${SVCNAME}.confd" "${SVCNAME}"
- systemd_dounit "${FILESDIR}/${SVCNAME}.service"
- keepdir /var/{lib,log}/${SVCNAME}
- fowners ${SVCNAME}:${SVCNAME} /var/{lib,log}/${SVCNAME}
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${SVCNAME}.logrotated" "${SVCNAME}"
-}
diff --git a/app-emulation/docker-registry/docker-registry-2.7.0.ebuild b/app-emulation/docker-registry/docker-registry-2.7.0.ebuild
deleted file mode 100644
index 90b39c280c9e..000000000000
--- a/app-emulation/docker-registry/docker-registry-2.7.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit golang-vcs-snapshot systemd user
-
-KEYWORDS="~amd64"
-EGO_PN="github.com/docker/distribution"
-EGIT_COMMIT="v${PV}"
-SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-DESCRIPTION="Docker Registry 2.0"
-HOMEPAGE="https://github.com/docker/distribution"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-SVCNAME=registry
-
-pkg_setup() {
- enewgroup ${SVCNAME}
- enewuser ${SVCNAME} -1 -1 /dev/null ${SVCNAME}
-}
-
-src_compile() {
- export -n GOCACHE XDG_CACHE_HOME #681072
- GOPATH="${S}" \
- go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}/..." || die
-}
-
-src_install() {
- exeinto /usr/libexec/${PN}
- doexe bin/*
- insinto /etc/docker/registry
- newins src/${EGO_PN}/cmd/registry/config-example.yml config.yml.example
- newinitd "${FILESDIR}/${SVCNAME}.initd" "${SVCNAME}"
- newconfd "${FILESDIR}/${SVCNAME}.confd" "${SVCNAME}"
- systemd_dounit "${FILESDIR}/${SVCNAME}.service"
- keepdir /var/{lib,log}/${SVCNAME}
- fowners ${SVCNAME}:${SVCNAME} /var/{lib,log}/${SVCNAME}
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${SVCNAME}.logrotated" "${SVCNAME}"
-}