summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-04-09 09:46:31 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-04-09 10:07:21 -0700
commit407d119a2e5cf3cf8c06a094538fae999db6173a (patch)
tree94e9151465bbefb46521eea17b00af22398ad691
parentsys-cluster/kubectl: stable 1.15.11 on amd64 (diff)
downloadgentoo-407d119a2e5cf3cf8c06a094538fae999db6173a.tar.gz
gentoo-407d119a2e5cf3cf8c06a094538fae999db6173a.tar.bz2
gentoo-407d119a2e5cf3cf8c06a094538fae999db6173a.zip
dev-python/requests_pkcs12: bump to 1.7
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--dev-python/requests_pkcs12/Manifest1
-rw-r--r--dev-python/requests_pkcs12/requests_pkcs12-1.7.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/requests_pkcs12/Manifest b/dev-python/requests_pkcs12/Manifest
index 0595f75eac2d..b76bf56747f2 100644
--- a/dev-python/requests_pkcs12/Manifest
+++ b/dev-python/requests_pkcs12/Manifest
@@ -1 +1,2 @@
DIST requests_pkcs12-1.4.tar.gz 3884 BLAKE2B ebeb89349163d4f9995c00dfe3d725036a76660870d36203f47029f225698fe7a15993a9dd756e0b6b33011726ad26323962609bb94f223f4478096658f20a3c SHA512 f77703b7b0ba1f13aa095fcf4955f119c34a20e0601e0d6888a29932d8d4289548cf2b7b0e065abfea2ebcda542d48a4d9a3ded32974c1d24bdae223893f0241
+DIST requests_pkcs12-1.7.tar.gz 3914 BLAKE2B f91c7d1677964cfe903b4c0f688e25b5b3b7eb921fdeb4e794cbea24ceafe4e44f7587df48c0ad56ff20114641f6897ab4ef26a64b53e6fcb7d713ecf36bb1c0 SHA512 be3fe00ef405b44d9f160ff35c072b86da511a68380e2737e9316a0d1dd89c3d8ba7adbaaf9865ca01cfbbdb85c477364780cbe3e77e2963dcd7b54519a95356
diff --git a/dev-python/requests_pkcs12/requests_pkcs12-1.7.ebuild b/dev-python/requests_pkcs12/requests_pkcs12-1.7.ebuild
new file mode 100644
index 000000000000..3cf700117abc
--- /dev/null
+++ b/dev-python/requests_pkcs12/requests_pkcs12-1.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Adds PKCS#12 support to the Python requests library in a clean way"
+HOMEPAGE="https://github.com/m-click/requests_pkcs12"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DEPEND=""
+
+RDEPEND="
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.4[${PYTHON_USEDEP}]
+"