summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-03-17 22:29:42 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-03-17 22:34:12 +0100
commit40a025ff662a8266c051ea08b539c409780a1006 (patch)
treef936b4a0e3c79f81fd21e89487e822dd1d2e210f
parentprofiles: Undo games-engines/openxcom last-rite (diff)
downloadgentoo-40a025ff662a8266c051ea08b539c409780a1006.tar.gz
gentoo-40a025ff662a8266c051ea08b539c409780a1006.tar.bz2
gentoo-40a025ff662a8266c051ea08b539c409780a1006.zip
net-fs/cifs-utils: Bump to version 6.8
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--net-fs/cifs-utils/Manifest1
-rw-r--r--net-fs/cifs-utils/cifs-utils-6.8.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/net-fs/cifs-utils/Manifest b/net-fs/cifs-utils/Manifest
index 0ab7895c7036..43f1a41edbed 100644
--- a/net-fs/cifs-utils/Manifest
+++ b/net-fs/cifs-utils/Manifest
@@ -1,3 +1,4 @@
DIST cifs-utils-6.4.tar.bz2 392809 BLAKE2B 90d59cbc49e6d3cf427a43fd9deedc8ea8150e6c8a3ed93ff815445897e4a524785dd342e0547a651bd67de4495e09c6384d6b36c3ed01f9d532c6d533c9efd1 SHA512 05860ceed1e83b4f4da689d2fc1c1b48fddc0ca53ba52fc6cf26a277d6a884f5780060725c5df1401a665ac35ec5a170262ee62f61095e4a8d76348888182614
DIST cifs-utils-6.6.tar.bz2 401831 BLAKE2B 6a073d35911b74ea36ffda32dd3f5d6032c3d46d846419b641312d1571ac448777ab5f70fe8dcb7582ab782014f0cb52ab620e60239f2cbd5d05284620cd18ab SHA512 0059c85a9faeff4bba052a9bfc672baa658a923e03304dfb0c51f427079afc6effb2f83d7d09cdcacb2c8a30cdfccd3946957b1616790f5ad3ae2300f161458f
DIST cifs-utils-6.7.tar.bz2 363647 BLAKE2B 692c4b7de92c2cc5cb88591fb5b5b01ca7d925b105d10f7149e350d1b1661bb6447e71e0ca86095a9e294637d80126e54295413a685786b62c8e70cf26f893d0 SHA512 ee050a0eb4a72fbc8d773e86fbe6839ea2bf11cda5ebd071c8ead66e31b46d50ea4e1d1b26478373be53227cd60b32a90b65b5cb989b5a8237cddfc65bad8e5e
+DIST cifs-utils-6.8.tar.bz2 384426 BLAKE2B 002518f44489aefc94c47a23438b176a4056ff4d995b3ed9f25a6c6c8d4c8d7437a3158d5c592d16cb6bfcd289b937d6ac1ef0573c346993d576a88aa1fcb118 SHA512 54a094f78c9e07acc997adfe0c8d4c2fb8e15c18adcc1805450e2180f8539aaec8619e781e985b289e097932637e2de3e6815e32f59ec2fc06cfc3762b832e13
diff --git a/net-fs/cifs-utils/cifs-utils-6.8.ebuild b/net-fs/cifs-utils/cifs-utils-6.8.ebuild
new file mode 100644
index 000000000000..63b3e7afe463
--- /dev/null
+++ b/net-fs/cifs-utils/cifs-utils-6.8.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils linux-info multilib pam
+
+DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
+HOMEPAGE="https://wiki.samba.org/index.php/LinuxCIFS_utils"
+SRC_URI="https://ftp.samba.org/pub/linux-cifs/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE="+acl +ads +caps +caps-ng creds pam"
+
+RDEPEND="
+ !net-fs/mount-cifs
+ !<net-fs/samba-3.6_rc1
+ sys-apps/keyutils
+ ads? (
+ sys-libs/talloc
+ virtual/krb5
+ )
+ caps? ( !caps-ng? ( sys-libs/libcap ) )
+ caps? ( caps-ng? ( sys-libs/libcap-ng ) )
+ pam? ( virtual/pam )
+"
+DEPEND="${RDEPEND}"
+PDEPEND="
+ acl? ( >=net-fs/samba-4.0.0_alpha1 )
+"
+
+REQUIRED_USE="acl? ( ads )"
+
+DOCS="doc/linux-cifs-client-guide.odt"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists || ! linux_chkconfig_present CIFS; then
+ ewarn "You must enable CIFS support in your kernel config, "
+ ewarn "to be able to mount samba shares. You can find it at"
+ ewarn
+ ewarn " File systems"
+ ewarn " Network File Systems"
+ ewarn " CIFS support"
+ ewarn
+ ewarn "and recompile your kernel ..."
+ fi
+}
+
+src_prepare() {
+ default
+
+ if has_version app-crypt/heimdal ; then
+ # https://bugs.gentoo.org/612584
+ eapply "${FILESDIR}/${PN}-6.7-heimdal.patch"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable acl cifsacl cifsidmap)
+ $(use_enable ads cifsupcall)
+ $(use caps && use_with !caps-ng libcap || echo --without-libcap)
+ $(use caps && use_with caps-ng libcap-ng || echo --without-libcap-ng)
+ $(use_enable creds cifscreds)
+ $(use_enable pam)
+ $(use_with pam pamdir $(getpam_mod_dir))
+ )
+ ROOTSBINDIR="${EPREFIX}"/sbin \
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # remove empty directories
+ find "${ED}" -type d -print0 | xargs --null rmdir \
+ --ignore-fail-on-non-empty &>/dev/null
+
+ if use acl ; then
+ dodir /etc/cifs-utils
+ dosym /usr/$(get_libdir)/cifs-utils/idmapwb.so \
+ /etc/cifs-utils/idmap-plugin
+ dodir /etc/request-key.d
+ echo 'create cifs.idmap * * /usr/sbin/cifs.idmap %k' \
+ > "${ED}/etc/request-key.d/cifs.idmap.conf"
+ fi
+
+ if use ads ; then
+ dodir /etc/request-key.d
+ echo 'create dns_resolver * * /usr/sbin/cifs.upcall %k' \
+ > "${ED}/etc/request-key.d/cifs.upcall.conf"
+ echo 'create cifs.spnego * * /usr/sbin/cifs.upcall %k' \
+ > "${ED}/etc/request-key.d/cifs.spnego.conf"
+ fi
+}
+
+pkg_postinst() {
+ # Inform about set-user-ID bit of mount.cifs
+ ewarn "setuid use flag was dropped due to multiple security implications"
+ ewarn "such as CVE-2009-2948, CVE-2011-3585 and CVE-2012-1586"
+ ewarn "You are free to set setuid flags by yourself"
+
+ # Inform about upcall usage
+ if use acl ; then
+ einfo "The cifs.idmap utility has been enabled by creating the"
+ einfo "configuration file /etc/request-key.d/cifs.idmap.conf"
+ einfo "This enables you to get and set CIFS acls."
+ fi
+
+ if use ads ; then
+ einfo "The cifs.upcall utility has been enabled by creating the"
+ einfo "configuration file /etc/request-key.d/cifs.upcall.conf"
+ einfo "This enables you to mount DFS shares."
+ fi
+}