summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-19 00:07:41 +0000
committerSam James <sam@gentoo.org>2021-01-19 00:07:59 +0000
commit40f87905372a14d909acab170d22216664fc3914 (patch)
tree28221ae52cb66e3dc08b2b74627fdcc841f53440
parentmedia-libs/allegro: add github remote-id (diff)
downloadgentoo-40f87905372a14d909acab170d22216664fc3914.tar.gz
gentoo-40f87905372a14d909acab170d22216664fc3914.tar.bz2
gentoo-40f87905372a14d909acab170d22216664fc3914.zip
media-libs/allegro: cleanup old
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/allegro/Manifest1
-rw-r--r--media-libs/allegro/allegro-4.4.2-r2.ebuild115
-rw-r--r--media-libs/allegro/files/allegro-4.4.2-GLX_RGBA_FLOAT_BIT.patch20
-rw-r--r--media-libs/allegro/files/allegro-4.4.2-Werror-format-security.patch107
-rw-r--r--media-libs/allegro/files/allegro-4.4.2-glibc228.patch41
-rw-r--r--media-libs/allegro/files/allegro-4.4.2-static-func.patch13
6 files changed, 0 insertions, 297 deletions
diff --git a/media-libs/allegro/Manifest b/media-libs/allegro/Manifest
index 4158f3aee8fc..0bebd4ad1f95 100644
--- a/media-libs/allegro/Manifest
+++ b/media-libs/allegro/Manifest
@@ -1,3 +1,2 @@
-DIST allegro-4.4.2.tar.gz 4674902 BLAKE2B 9f43fad416348425692481524f6c15808ee03946d93df4a072a46557817ccd5f6ae7eede908ca4a02a0a9e49f9a7c42909c48c14923b2155d3999ff370401006 SHA512 ad4bc1c15fc83bc8a019031fed82f37a793664bb6683cf023ec05fd9cd945f00f43764f3126892426036249c63afa5678fb4906407bb325ce5827b36aee0fa86
DIST allegro-4.4.3.1.tar.gz 4663634 BLAKE2B 23fa8cd77858243bfa8191f6bca26f50d1621fa84616968595c1284c73a86160cdbad201eece5bd026bb7ac13753568b6915295646b86e536b5d26c0394e2d1f SHA512 c5a552ab710226493447eb2547b3d7559badb96f511fbefd315b665b7486013a6710c83b69363eb09f90f53ef4278fe7b90cfee88d90d88f0fe8dc7df7606729
DIST allegro-5.2.6.0.tar.gz 7867726 BLAKE2B 3f21372442e5b8c802ac179019a11648febdcecddfda864559e1e9621f99c9ff7584fb422594c6fd3a1c352c892533c825faef10e35ecbf97058396fbb46fc7d SHA512 a475de67b0e6c727295cc51e113859eb0c57825a240e70bc45cd3b000c40518932b89cecdd13ba957416136db4ee9a9363adb5d3bfa7c8acda04ee95de6ba721
diff --git a/media-libs/allegro/allegro-4.4.2-r2.ebuild b/media-libs/allegro/allegro-4.4.2-r2.ebuild
deleted file mode 100644
index 0387f700f4a8..000000000000
--- a/media-libs/allegro/allegro-4.4.2-r2.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-CMAKE_IN_SOURCE_BUILD=1
-inherit cmake-utils desktop
-
-DESCRIPTION="cross-platform multimedia library"
-HOMEPAGE="https://liballeg.org/"
-SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
-
-LICENSE="Allegro MIT GPL-2+ ZLIB"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~mips ppc ppc64 x86"
-IUSE="alsa fbcon jack jpeg opengl oss png svga test vga vorbis X"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- alsa? ( media-libs/alsa-lib )
- jack? ( media-sound/jack-audio-connection-kit )
- jpeg? ( virtual/jpeg:0 )
- png? ( media-libs/libpng:0= )
- svga? ( media-libs/svgalib )
- vorbis? ( media-libs/libvorbis )
- X? (
- x11-libs/libX11
- x11-libs/libXcursor
- x11-libs/libXext
- x11-libs/libXpm
- x11-libs/libXt
- x11-libs/libXxf86dga
- x11-libs/libXxf86vm
- opengl? (
- virtual/glu
- virtual/opengl
- )
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- X? ( x11-base/xorg-proto )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-shared.patch
- "${FILESDIR}"/${P}-underlink.patch
- "${FILESDIR}"/${P}-gentoo.patch
- "${FILESDIR}"/${P}-rpath.patch
- "${FILESDIR}"/${P}-Werror-format-security.patch # bug 540470
- "${FILESDIR}"/${P}-glibc228.patch # bug 670781
- "${FILESDIR}"/${P}-GLX_RGBA_FLOAT_BIT.patch # bug 672858
- "${FILESDIR}"/${P}-static-func.patch # bug 696034
-)
-
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -i \
- -e "s:allegro-\${ALLEGRO_VERSION}:${PF}:" \
- docs/CMakeLists.txt || die
-}
-
-src_configure() {
- # WANT_LINUX_CONSOLE is by default OFF
- # WANT_EXAMPLES doesn't install anything
- local mycmakeargs=(
- -DDOCDIR=share/doc
- -DMANDIR=share/man
- -DWANT_ALSA=$(usex alsa)
- -DWANT_DOCS_INFO=OFF
- -DWANT_EXAMPLES=OFF
- -DWANT_JACK=$(usex jack)
- -DWANT_JPGALLEG=$(usex jpeg)
- -DWANT_LINUX_CONSOLE=OFF
- -DWANT_LINUX_FBCON=$(usex fbcon)
- -DWANT_LINUX_SVGALIB=$(usex svga)
- -DWANT_LINUX_VGA=$(usex vga)
- -DWANT_LOADPNG=$(usex png)
- -DWANT_LOGG=$(usex vorbis)
- -DWANT_OSS=$(usex oss)
- -DWANT_TESTS=$(usex test)
- -DWANT_TOOLS=$(usex X)
- -DWANT_X11=$(usex X)
- )
-
- if use X; then
- mycmakeargs+=( -DWANT_ALLEGROGL=$(usex opengl) )
- else
- mycmakeargs+=( -DWANT_ALLEGROGL=OFF )
- fi
-
- cmake-utils_src_configure
-}
-
-src_install() {
- rm -r docs/html/{build,tmpfile.txt} || die
- local HTML_DOCS=( docs/html/. )
-
- cmake-utils_src_install
-
- #176020 (init_dialog.3), #409305 (key.3)
- pushd docs/man >/dev/null
- local manpage
- for manpage in $(ls -d *.3); do
- newman ${manpage} ${PN}-${manpage}
- done
- popd >/dev/null
-
- if use X; then
- newbin setup/setup ${PN}-setup
- insinto /usr/share/${PN}
- doins {keyboard,language,setup/setup}.dat
- newicon misc/icon.png ${PN}.png
- make_desktop_entry ${PN}-setup "Allegro Setup" ${PN} "Settings"
- fi
-}
diff --git a/media-libs/allegro/files/allegro-4.4.2-GLX_RGBA_FLOAT_BIT.patch b/media-libs/allegro/files/allegro-4.4.2-GLX_RGBA_FLOAT_BIT.patch
deleted file mode 100644
index 54ff4f97fbb1..000000000000
--- a/media-libs/allegro/files/allegro-4.4.2-GLX_RGBA_FLOAT_BIT.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/addons/allegrogl/src/x.c 2019-01-27 20:35:26.209055856 +0100
-+++ b/addons/allegrogl/src/x.c 2019-01-27 20:38:54.135570782 +0100
-@@ -650,7 +650,7 @@
- return -1;
- }
-
-- if (!(render_type & GLX_RGBA_BIT) && !(render_type & GLX_RGBA_FLOAT_BIT)) {
-+ if (!(render_type & GLX_RGBA_BIT) && !(render_type & GLX_RGBA_FLOAT_BIT_ARB)) {
- TRACE(PREFIX_I "decode_fbconfig: Not RGBA mode\n");
- return -1;
- }
-@@ -674,7 +674,7 @@
- /* Floating-point depth is not supported as glx extension (yet). */
- i->float_depth = 0;
-
-- i->float_color = (render_type & GLX_RGBA_FLOAT_BIT);
-+ i->float_color = (render_type & GLX_RGBA_FLOAT_BIT_ARB);
-
- v = glXGetVisualFromFBConfig(_xwin.display, fbc);
- if (!v) {
diff --git a/media-libs/allegro/files/allegro-4.4.2-Werror-format-security.patch b/media-libs/allegro/files/allegro-4.4.2-Werror-format-security.patch
deleted file mode 100644
index b3b0bc30b344..000000000000
--- a/media-libs/allegro/files/allegro-4.4.2-Werror-format-security.patch
+++ /dev/null
@@ -1,107 +0,0 @@
-diff -up allegro-4.4.2/src/unix/umodules.c~ allegro-4.4.2/src/unix/umodules.c
---- allegro-4.4.2/src/unix/umodules.c~ 2011-05-13 10:11:33.000000000 +0200
-+++ allegro-4.4.2/src/unix/umodules.c 2017-03-15 14:42:39.822612368 +0100
-@@ -126,11 +126,11 @@ void _unix_load_modules(int system_drive
- continue;
-
- if (!fullpath_slash) {
-- snprintf(fullpath, sizeof fullpath, filename);
-+ snprintf(fullpath, sizeof fullpath, "%s", filename);
- fullpath[(sizeof fullpath) - 1] = 0;
- }
- else {
-- snprintf(fullpath_slash+1, (sizeof fullpath) - (fullpath_slash - fullpath) - 1, filename);
-+ snprintf(fullpath_slash+1, (sizeof fullpath) - (fullpath_slash - fullpath) - 1, "%s", filename);
- fullpath[(sizeof fullpath) - 1] = 0;
- }
-
-diff -up allegro-4.4.2/src/linux/ljoy.c~ allegro-4.4.2/src/linux/ljoy.c
---- allegro-4.4.2/src/linux/ljoy.c~ 2010-02-20 06:18:16.000000000 +0100
-+++ allegro-4.4.2/src/linux/ljoy.c 2017-03-15 14:52:28.474215615 +0100
-@@ -93,7 +93,7 @@ static int joy_init(void)
-
- if (ioctl(joy_fd[i], JSIOCGVERSION, &raw_version) < 0) {
- /* NOTE: IOCTL fails if the joystick API is version 0.x */
-- uszprintf(allegro_error, ALLEGRO_ERROR_SIZE, get_config_text("Your Linux joystick API is version 0.x which is unsupported."));
-+ uszprintf(allegro_error, ALLEGRO_ERROR_SIZE, "%s", get_config_text("Your Linux joystick API is version 0.x which is unsupported."));
- return -1;
- }
-
-diff -up allegro-4.4.2/examples/extrans2.c~ allegro-4.4.2/examples/extrans2.c
---- allegro-4.4.2/examples/extrans2.c~ 2008-01-30 11:56:50.000000000 +0100
-+++ allegro-4.4.2/examples/extrans2.c 2017-03-15 15:43:03.494831521 +0100
-@@ -211,7 +211,7 @@ int main(int argc, char **argv)
- } else {
- msg = "no flipping";
- }
-- textprintf_ex(buffer, font, 1, 1, makecol(255, 255, 255), -1, msg);
-+ textprintf_ex(buffer, font, 1, 1, makecol(255, 255, 255), -1, "%s", msg);
-
- /* finally blit the back buffer on the screen */
- blit(buffer, screen, 0, 0, 0, 0, buffer->w, buffer->h);
-diff -up allegro-4.4.2/setup/setup.c~ allegro-4.4.2/setup/setup.c
---- allegro-4.4.2/setup/setup.c~ 2010-05-23 18:05:33.000000000 +0200
-+++ allegro-4.4.2/setup/setup.c 2017-03-15 16:13:42.243136380 +0100
-@@ -1163,7 +1163,7 @@ static void plot_joystick_state(BITMAP *
- textprintf_ex(bmp, font, SCREEN_W/2-96, SCREEN_H/2-60+c*20, -1, -1, uconvert_ascii("%s (%d/%d)", tmp),
- joystick_driver->name, i+1, num_joysticks);
- else
-- textprintf_ex(bmp, font, SCREEN_W/2-96, SCREEN_H/2-60+c*20, -1, -1, joystick_driver->name);
-+ textprintf_ex(bmp, font, SCREEN_W/2-96, SCREEN_H/2-60+c*20, -1, -1, "%s", joystick_driver->name);
- c++;
- }
-
-@@ -2879,7 +2879,7 @@ int main(void)
- alert(uconvert_ascii("Error loading " SETUP_DATA_FILE, tmp1), NULL, NULL, uconvert_ascii("OK", tmp2), NULL, 13, 0);
- #else
- set_gfx_mode(GFX_TEXT, 0, 0, 0, 0);
-- allegro_message(uconvert_ascii("Error loading " SETUP_DATA_FILE "\n", tmp1));
-+ allegro_message("%s", uconvert_ascii("Error loading " SETUP_DATA_FILE "\n", tmp1));
- #endif
- return 1;
- }
-diff -up allegro-4.4.2/examples/exkeys.c~ allegro-4.4.2/examples/exkeys.c
---- allegro-4.4.2/examples/exkeys.c~ 2008-01-10 20:46:00.000000000 +0100
-+++ allegro-4.4.2/examples/exkeys.c 2017-03-15 16:17:30.268545467 +0100
-@@ -193,7 +193,7 @@ int main(void)
- if (key_shifts & KB_NUMLOCK_FLAG) strcat(buf, " num");
- if (key_shifts & KB_SCROLOCK_FLAG) strcat(buf, " scrl");
- scroll();
-- textprintf_ex(screen, font, 8, SCREEN_H-16, makecol(0, 0, 0), makecol(255, 255, 255), buf);
-+ textprintf_ex(screen, font, 8, SCREEN_H-16, makecol(0, 0, 0), makecol(255, 255, 255), "%s", buf);
- } while (k != 27);
-
- /* various scan codes are defined in allegro.h as KEY_* constants */
-@@ -234,7 +234,7 @@ int main(void)
- if (key[KEY_8]) buf[8] = '8'; else buf[8] = ' ';
- if (key[KEY_9]) buf[9] = '9'; else buf[9] = ' ';
- buf[10] = 0;
-- textprintf_ex(screen, font, 8, SCREEN_H-16, makecol(0, 0, 0), makecol(255, 255, 255), buf);
-+ textprintf_ex(screen, font, 8, SCREEN_H-16, makecol(0, 0, 0), makecol(255, 255, 255), "%s", buf);
- rest(1);
- } while (!keypressed() || (readkey() >> 8) != KEY_ESC);
-
-diff -up allegro-4.4.2/tests/play.c~ allegro-4.4.2/tests/play.c
---- allegro-4.4.2/tests/play.c~ 2005-03-19 12:15:07.000000000 +0100
-+++ allegro-4.4.2/tests/play.c 2017-03-15 16:35:18.628156496 +0100
-@@ -74,7 +74,7 @@ void usage(void)
-
- strcat(msg, "\nIf you don't specify the card, Allegro will auto-detect (ie. guess :-)\n");
-
-- allegro_message(msg);
-+ allegro_message("%s", msg);
- free(msg);
- }
-
-diff -up allegro-4.2.3/tools/pack.c~ allegro-4.2.3/tools/pack.c
---- allegro-4.2.3/tools/pack.c~ 2006-05-20 16:49:58.000000000 +0200
-+++ allegro-4.2.3/tools/pack.c 2010-12-30 11:20:42.425231307 +0100
-@@ -42,7 +42,7 @@ static void err(char *s1, char *s2)
- printf(": %s", s1);
-
- if (s2)
-- printf(s2);
-+ printf("%s", s2);
-
- printf("\n");
-
diff --git a/media-libs/allegro/files/allegro-4.4.2-glibc228.patch b/media-libs/allegro/files/allegro-4.4.2-glibc228.patch
deleted file mode 100644
index afcdf5100c5e..000000000000
--- a/media-libs/allegro/files/allegro-4.4.2-glibc228.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 4848f1583c3dbe41f5f056869ff2c796d33d8121 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20R=C3=B6nnquist?= <andreas@ronnquist.net>
-Date: Wed, 12 Dec 2018 16:39:23 +0100
-Subject: [PATCH] Remove f* variants of fixed math functions
-
-Removing functions that conflicts with later glibc implementations,
-people should use fix* variants instead.
-(Simply use fixadd instead of fadd).
----
- include/allegro/alcompat.h | 18 ------------------
- 1 file changed, 18 deletions(-)
-
-diff --git a/include/allegro/alcompat.h b/include/allegro/alcompat.h
-index d31ab5b6d..c9536839d 100644
---- a/include/allegro/alcompat.h
-+++ b/include/allegro/alcompat.h
-@@ -40,24 +40,6 @@
- #endif
- #endif
-
-- #ifndef ALLEGRO_NO_FIX_ALIASES
-- AL_ALIAS(fixed fadd(fixed x, fixed y), fixadd(x, y))
-- AL_ALIAS(fixed fsub(fixed x, fixed y), fixsub(x, y))
-- AL_ALIAS(fixed fmul(fixed x, fixed y), fixmul(x, y))
-- AL_ALIAS(fixed fdiv(fixed x, fixed y), fixdiv(x, y))
-- AL_ALIAS(int fceil(fixed x), fixceil(x))
-- AL_ALIAS(int ffloor(fixed x), fixfloor(x))
-- AL_ALIAS(fixed fcos(fixed x), fixcos(x))
-- AL_ALIAS(fixed fsin(fixed x), fixsin(x))
-- AL_ALIAS(fixed ftan(fixed x), fixtan(x))
-- AL_ALIAS(fixed facos(fixed x), fixacos(x))
-- AL_ALIAS(fixed fasin(fixed x), fixasin(x))
-- AL_ALIAS(fixed fatan(fixed x), fixatan(x))
-- AL_ALIAS(fixed fatan2(fixed y, fixed x), fixatan2(y, x))
-- AL_ALIAS(fixed fsqrt(fixed x), fixsqrt(x))
-- AL_ALIAS(fixed fhypot(fixed x, fixed y), fixhypot(x, y))
-- #endif
--
- #endif /* !defined ALLEGRO_SRC */
-
-
diff --git a/media-libs/allegro/files/allegro-4.4.2-static-func.patch b/media-libs/allegro/files/allegro-4.4.2-static-func.patch
deleted file mode 100644
index ac107d387d56..000000000000
--- a/media-libs/allegro/files/allegro-4.4.2-static-func.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://sourceforge.net/p/alleg/bugs/398/
-
---- a/addons/jpgalleg/src/decode.c 2008-02-13 14:04:57.000000000 +0100
-+++ b/addons/jpgalleg/src/decode.c 2015-09-03 14:57:57.888485546 +0200
-@@ -477,7 +477,7 @@
- * Reads a string of bits from the input stream and returns a properly signed
- * number given the category.
- */
--INLINE int
-+static INLINE int
- get_value(int category)
- {
- int result = get_bits(category);