summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-30 11:39:14 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-30 13:34:28 -0400
commit41c55c13393963d9bf53898911052e2937160699 (patch)
treec185385dece6fe2887df18cbdca14a75419bf2fa
parentapp-emulation/wine-vanilla: Sync with ::wine (diff)
downloadgentoo-41c55c13393963d9bf53898911052e2937160699.tar.gz
gentoo-41c55c13393963d9bf53898911052e2937160699.tar.bz2
gentoo-41c55c13393963d9bf53898911052e2937160699.zip
net-mail/offlineimap: version bump to 7.2.1
-rw-r--r--net-mail/offlineimap/Manifest1
-rw-r--r--net-mail/offlineimap/offlineimap-7.2.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/offlineimap/Manifest b/net-mail/offlineimap/Manifest
index c30770086890..c5bd954d77b6 100644
--- a/net-mail/offlineimap/Manifest
+++ b/net-mail/offlineimap/Manifest
@@ -7,3 +7,4 @@ DIST offlineimap-7.1.2.tar.gz 708014 BLAKE2B 848e7cfdec79a443529307503e49a86729b
DIST offlineimap-7.1.3.tar.gz 710766 BLAKE2B 6a4c80e0ef12a77a2cdd84ba79307636e9a08fdee1d989936c6f6c3d42eadb6d5c98fb8ce3ed530c49a4ad5c424702342b55b78fc5ba7e46dd6d276675b80cd7 SHA512 bf24be740b0e7607a1b53df7e872b5dd4b4c720601d99bd88a7ac8add078e5512b62b18c12177e28a00f510aaa8a48e25be82decfdd7ae2da76b671d44071e4a
DIST offlineimap-7.1.4.tar.gz 711048 BLAKE2B 0ff678339cf7c90159e3f7f64ac581469503584e356a773804e513200b40eb8b99c3dd6367c21a69fe8ef46bdac146b6571f6ef2f1292014009af20df890e682 SHA512 f2623a400de2fac339249f887529e1f02224ba40c5f739b4084b5b26d1f8b6f26faf2c248aeaecd48dd7f6cc27bdaa8b7691c10f3db3b9673a1a5338f435447c
DIST offlineimap-7.1.5.tar.gz 711529 BLAKE2B 055fcaa714529407d404b45afc56f2b9c407865bbb6403a205f916926905c845c3dd9d025824de82850c17e2791c335aa11a38e9688c847d388ffaa97dbf5d2b SHA512 5e49e5e2f13a15f02036860d1622a79a1342c8d3c0ad1c3e56c32a90e9c6e439ed9b9de6b67e36bda19229e28bd17dcb132f093eb19524375b182dde079d6101
+DIST offlineimap-7.2.1.tar.gz 720220 BLAKE2B 309a51e88ebbc8dd7a4d807bc506a0d0d8a355e71f464e5347ba3ea02de6fd89a089bb982475982d62bed0900eb1aa5320163e49ac787b9d8abff029ac47ee7d SHA512 4e6bcda576fbf023e0192e8d19627d72ea824cd795ef65604d56b00f239298031ea512dcc17d47ae340be1515770c8588907bc767489717a9ab136e34843c197
diff --git a/net-mail/offlineimap/offlineimap-7.2.1.ebuild b/net-mail/offlineimap/offlineimap-7.2.1.ebuild
new file mode 100644
index 000000000000..c616c5e01582
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-7.2.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Normally you need only one version of this.
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads,sqlite,ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+SRC_URI="https://github.com/OfflineIMAP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="doc? ( app-text/asciidoc )"
+
+# see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
+PATCHES=(
+ "${FILESDIR}/${PN}-7.0.3-darwin10.patch"
+)
+
+src_compile() {
+ distutils-r1_src_compile
+ use doc && emake -C docs man
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ use doc && doman docs/{offlineimap.1,offlineimapui.7}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ fi
+}