summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-11-23 13:15:55 -0800
committerBrian Dolbec <dolsen@gentoo.org>2017-11-23 13:20:58 -0800
commit425014090c888a042f98bbb51461ac4c4e2e92d3 (patch)
tree023b35b58cd870cba2f1010894fe280cadb65b25
parentdev-util/buildbot-www: Version bump, adds python3_{4,6} (diff)
downloadgentoo-425014090c888a042f98bbb51461ac4c4e2e92d3.tar.gz
gentoo-425014090c888a042f98bbb51461ac4c4e2e92d3.tar.bz2
gentoo-425014090c888a042f98bbb51461ac4c4e2e92d3.zip
dev-util/buildbot-wsgi-dashboards: Version bump, adds python3_{4,6}
Package-Manager: Portage-2.3.16, Repoman-2.3.6
-rw-r--r--dev-util/buildbot-wsgi-dashboards/Manifest5
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-0.9.13.ebuild50
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/Manifest b/dev-util/buildbot-wsgi-dashboards/Manifest
index 017d3ff3be35..c800a3f4011f 100644
--- a/dev-util/buildbot-wsgi-dashboards/Manifest
+++ b/dev-util/buildbot-wsgi-dashboards/Manifest
@@ -1,2 +1,3 @@
-DIST buildbot-wsgi-dashboards-0.9.11.tar.gz 627215 SHA256 bb72b78045867bc0ee2cbe90df96978860ed14e61090dc67b5ecd9606bab2975 SHA512 6f829d5ead05cb91f5b85f128874f1df01288e87938df9f8dd1cca1552ccfb7cae35be4eb077ea97d5ca4f44b236947649131b9aed2bdc9142920c2ee1439f4b WHIRLPOOL d33937eb54c8c4f7bc8d5d3258d37b0fac39293657e2668fc96149a574ff583f37798ff0ce03b2bc5a2ab5db1015db5538c1d5806ff23ca7d2b7a8152666d97f
-DIST buildbot-wsgi-dashboards-0.9.12.tar.gz 627274 SHA256 6feaa8018ea4a16edefa3fa6ea48fa40a37ed374226473cf7a79369f599f9599 SHA512 113c1616b08feb64fd3d94c1186e3d7dd7ea93e563a96ddb802e6ff8135e194014464ef09a23004518451626584bc531fc17419188ebbdd388e9363541b80c3d WHIRLPOOL 6a3b07bd131f84ed13b940c19ca6680d76967135e50d53fb1da9115511707200ac322adc59ae4a3f36928f00903137df44fa012aa3f097af06660b75b728a1a9
+DIST buildbot-wsgi-dashboards-0.9.11.tar.gz 627215 BLAKE2B 627d9e6eff6a9e5091ab1073ee9701ee537c406b47e5a66a9c7d6424c046e00cc51a01db9b7c2f051746c18852a5554ae70ca50560834fc5573a6786e61df2c5 SHA512 6f829d5ead05cb91f5b85f128874f1df01288e87938df9f8dd1cca1552ccfb7cae35be4eb077ea97d5ca4f44b236947649131b9aed2bdc9142920c2ee1439f4b
+DIST buildbot-wsgi-dashboards-0.9.12.tar.gz 627274 BLAKE2B 26632ddd1577e9c419d13c07958c203440ef875bc4a79be6b894d0cf4dc457423528b7ea34c830511a5ef5d7f645fde2f71ac08578e1de32687c8b1ae2864491 SHA512 113c1616b08feb64fd3d94c1186e3d7dd7ea93e563a96ddb802e6ff8135e194014464ef09a23004518451626584bc531fc17419188ebbdd388e9363541b80c3d
+DIST buildbot-wsgi-dashboards-0.9.13.tar.gz 627272 BLAKE2B 1b4b8b6a0eed9572923a0dba24a9194557074e84640cf57141014a92294c56f22330566ae995bfa5e6be63640549e42e5aae01911df6989dbe4861b7ca5544f8 SHA512 08eedef62e85d71cbfde0f57727974a2bc1a9d33fc3821aaeb3a003df3b212c2b1ce00afa986dad062415b0bf8d8a9c0c328810e9d3fc994cdcbb82de2037366
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-0.9.13.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-0.9.13.ebuild
new file mode 100644
index 000000000000..f96d4962c322
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-0.9.13.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-wsgi-dashboards"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}