summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-10 18:14:37 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-10 18:14:45 +0100
commit428b8a3de05f2e1863b2adb0e8a5ccc2120a0b29 (patch)
tree6a15554a92506c883b2500f4aa684d56222665f1
parentsys-devel/llvm: Fix missing ||die on FreeBSD-added code (diff)
downloadgentoo-428b8a3de05f2e1863b2adb0e8a5ccc2120a0b29.tar.gz
gentoo-428b8a3de05f2e1863b2adb0e8a5ccc2120a0b29.tar.bz2
gentoo-428b8a3de05f2e1863b2adb0e8a5ccc2120a0b29.zip
dev-python/python-gflags: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/python-gflags/Manifest1
-rw-r--r--dev-python/python-gflags/files/python-gflags-3.0.2-scripts-install.patch29
-rw-r--r--dev-python/python-gflags/python-gflags-3.0.2.ebuild25
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/python-gflags/Manifest b/dev-python/python-gflags/Manifest
index 436669399ed4..0d03860e988f 100644
--- a/dev-python/python-gflags/Manifest
+++ b/dev-python/python-gflags/Manifest
@@ -1 +1,2 @@
DIST python-gflags-2.0.tar.gz 64929 SHA256 311066217acb8cd8519a4c872cb3fe64f02bcf105802bb761ab0de55c2386cd6 SHA512 28566acffd092f09105f3b9ad3be4ada11f024f940914e6efb103907f3779283c63bdfe13edad83aa470c5e887b49ad8b05031fc1895f3bad9b5d9c368bbfe18 WHIRLPOOL 61054cce9033ef26ee6d6296fc761c840f394de07f068a899b52a5d4212de4e4601f9a203fd8033db576e79369e4d53a0bb04bfca0e50cf828ff94105a2b453a
+DIST python-gflags-3.0.2.tar.gz 91481 SHA256 f2ca688f385bba47382a067d2d77322ab974fd4d596baad95bcd7d319241061d SHA512 f24b404a1821d55f2d7423548c241f54962e79b31ade6b718e0c50591756ec269545445326e459a1b02806ca5eab7ccf9c545211e4148b3da050069b9a97088f WHIRLPOOL 4a72cde4f2715d2fd32760b0b69f4ff1b0b14d94ad3d00d002cd16a9d3715f7f61bf14878fca4073c8c573ae853229c15d781eb766ad324ce053645a76cedba5
diff --git a/dev-python/python-gflags/files/python-gflags-3.0.2-scripts-install.patch b/dev-python/python-gflags/files/python-gflags-3.0.2-scripts-install.patch
new file mode 100644
index 000000000000..ffa6ec53e561
--- /dev/null
+++ b/dev-python/python-gflags/files/python-gflags-3.0.2-scripts-install.patch
@@ -0,0 +1,29 @@
+The scripts are installed as 'data' rather than scripts.
+http://code.google.com/p/python-gflags/issues/detail?id=12
+
+From d544cdad63faa5a53ba524e39f091f4a18e1eeb8 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 16 Dec 2012 16:27:13 +0100
+Subject: [PATCH] Install Python scripts using 'scripts' key.
+
+This is necessary to ensure that the shebangs are properly replaced when
+installing for multiple Python implementations.
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 573db2d..ddad318 100755
+--- a/setup.py
++++ b/setup.py
+@@ -39,6 +39,6 @@ setup(name='python-gflags',
+ author_email='google-gflags@googlegroups.com',
+ url='https://github.com/google/python-gflags',
+ py_modules=['gflags'],
+- data_files=[('bin', ['gflags2man.py'])],
++ scripts=['gflags2man.py'],
+ include_package_data=True,
+ )
+--
+1.8.0.2
+
diff --git a/dev-python/python-gflags/python-gflags-3.0.2.ebuild b/dev-python/python-gflags/python-gflags-3.0.2.ebuild
new file mode 100644
index 000000000000..d26a4bfc7892
--- /dev/null
+++ b/dev-python/python-gflags/python-gflags-3.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google's Python argument parsing library"
+HOMEPAGE="https://github.com/gflags/python-gflags"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc64 ~s390 ~sh ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-scripts-install.patch
+)