summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-03-12 19:06:15 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2016-03-12 19:14:55 -0500
commit428f5168452714a44c3527354043ccd2f413f854 (patch)
treeae1a72cfc3298a80bd8e8014c5ea3cc781d3f37e
parentdev-vcs/hub: remove old (diff)
downloadgentoo-428f5168452714a44c3527354043ccd2f413f854.tar.gz
gentoo-428f5168452714a44c3527354043ccd2f413f854.tar.bz2
gentoo-428f5168452714a44c3527354043ccd2f413f854.zip
www-plugins/pipelight: Add 0.2.8.2; Add 64 bit support per #528404
Package-Manager: portage-2.2.26
-rw-r--r--www-plugins/pipelight/Manifest1
-rw-r--r--www-plugins/pipelight/pipelight-0.2.8.2.ebuild100
-rw-r--r--www-plugins/pipelight/pipelight-9999.ebuild34
3 files changed, 124 insertions, 11 deletions
diff --git a/www-plugins/pipelight/Manifest b/www-plugins/pipelight/Manifest
index 6a74563e0711..288776658eb6 100644
--- a/www-plugins/pipelight/Manifest
+++ b/www-plugins/pipelight/Manifest
@@ -1,2 +1,3 @@
DIST pipelight-0.2.7.3.tar.gz 161967 SHA256 db4585f44874c0b647e7cf611b5bf8efe308fe11573891cd74dd4fa5867e2e52 SHA512 162b5f95b30c022a7f3bd821c7ba8e8af33ef0a4e2f38dff6a5da0a36725251a45b07c22c827c5a97b2320e395391f8d5c6702d3ed596e7cf66b064b2f9c8285 WHIRLPOOL 435bfb3f4fcb63b15af078da4765b0b0f1200e4691dcb3b92360cfda5f70f23c76458ff849c4a54ffab3f3f75c8d475c86c7ede6127cd57e6d34c50e1d07c367
+DIST pipelight-0.2.8.2.tar.gz 153877 SHA256 13ca5fb18cd68f63137a0dded5a4d0811aa78b033918a3331953903ced34decf SHA512 1599a7f1513e7d9bc9365bc5684050846e1827ec465103b042917963f6199d4af1d97d4943703d1e2a2dce8141c0c289b585ae485efb06b22ee30c17df465e8b WHIRLPOOL 6342af3bbe70604eecab0f4abe194dd4b19bf899656eaf0d1951c8ebfe23df548883367cecf6d836331f364aa791003334dec10e6fb939ad9b982b7fb8a23172
DIST pipelight-0.2.8.tar.gz 153492 SHA256 ae543d6eb95b3f681bf5807de63208e42c3be2ada1d2661017ad3a215c0684c4 SHA512 927fea510912879d0c976a20088dbbbadb3a1185e248d9a2ebb0afc4219bf4bcf4691f1ada678f4ccd24ea722e108615a04764ba664d66a6e03855aa663ae373 WHIRLPOOL 16d9b8460cb1d0f00097cf92d9c4d010a3f18b4d0c8c667b03b3b613bb80931b6fcf3d19d2ee96ae405375ee60e72aa4d6e84b9137ace7c7ac7d4d139e41eaff
diff --git a/www-plugins/pipelight/pipelight-0.2.8.2.ebuild b/www-plugins/pipelight/pipelight-0.2.8.2.ebuild
new file mode 100644
index 000000000000..75380cf01222
--- /dev/null
+++ b/www-plugins/pipelight/pipelight-0.2.8.2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib-build
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://bitbucket.org/mmueller2012/${PN}.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://bitbucket.org/mmueller2012/${PN}/get/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Wine-based wrapper for running Windows plugins on POSIX systems"
+HOMEPAGE="https://launchpad.net/pipelight"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1+ MPL-1.1 )"
+SLOT="0"
+IUSE="+abi_x86_32 abi_x86_64"
+
+DEPEND="app-emulation/wine[X,${MULTILIB_USEDEP},pipelight]"
+RDEPEND="${DEPEND}
+ app-arch/cabextract
+ app-crypt/gnupg
+ media-fonts/corefonts
+ || (
+ gnome-extra/zenity
+ kde-apps/kdialog
+ )"
+
+QA_FLAGS_IGNORED="usr/share/pipelight/pluginloader{,64}.exe
+ usr/share/pipelight/winecheck{,64}.exe"
+
+src_configure() {
+ local myconf=( --wine-path="${EPREFIX}/usr/bin/wine" )
+ if use abi_x86_64; then
+ myconf+=(
+ --with-win64
+ --win64-cxx=wineg++
+ --wine64-path="${EPREFIX}/usr/bin/wine64"
+ )
+ fi
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default_src_install
+
+ # Ideally, every wrapped plugin could be a symlink to pipelight's wrapper
+ # plugin, but some browsers do not like this. Upstream provides a script to
+ # duplicate the wrapper plugin as a hack to work around it. That script
+ # does not support DESTDIR, so we use sed to adjust it before running it to
+ # properly duplicate the plugins.
+ # XXX: Patch the script to support DESTDIR and send the patch upstream.
+ sed -e "s:^\(PIPELIGHT_LIBRARY_PATH=\"\)\\(.*\):\1${ED}usr/$(get_libdir)/${PN}\":" \
+ -e "s:^\(PLUGIN_PATH=\"\)\\(.*\):\1${ED}usr/$(get_libdir)/${PN}\":" \
+ "${ED}/usr/bin/pipelight-plugin" > "${T}/pipelight-plugin" \
+ || die "Generating temporary pipelight-plugin failed"
+ chmod u+x "${T}/pipelight-plugin" \
+ || die "Setting permissions on temporary pipelight-plugin failed"
+
+ # Create Plugins
+ "${T}/pipelight-plugin" --create-mozilla-plugins \
+ || die "Creating plugins failed"
+
+}
+
+postinst() {
+ # Obligatory warnings about proprietary software
+ ewarn "Neither the Gentoo developers nor the Pipelight developers can"
+ ewarn "patch security vulnerabilities in Windows plugins. Use them at your"
+ ewarn "own risk."
+ # Warn about missing pipelight-sandbox
+ ewarn
+ ewarn "The pipelight sandbox has not been packaged yet. Plugins will have"
+ ewarn "full privileges as Windows programs running inside wine."
+
+ # Helpful information for those willing to live dangerously
+ einfo "Using Windows plugins on certain websites might require a useragent"
+ einfo "switcher. See the upstream tutorial for more details."
+ einfo
+ einfo "http://www.pipelight.net/cms/installation-user-agent.html"
+ einfo
+ einfo "End users should use the pipelight-plugin utility to install and"
+ einfo "manage plugins. Updates are done at plugin initialization whenever"
+ einfo "/usr/share/pipelight/install-dependency has been updated. This can"
+ einfo "be done either by doing updates via portage or by running"
+ einfo "pipelight-plugin --update as root. Browsers like Chrome (all"
+ einfo "versions before 35) will initialize plugins at boot while browsers"
+ einfo "like Firefox will initialize plugins on demand."
+ einfo
+ # Users must be in the video group for video acceleration
+ einfo "Membership in the video group is required for using plugins that"
+ einfo "feature hardware acceleration for video decoding. This is important"
+ einfo "for video streaming sites that use Silverlight."
+}
diff --git a/www-plugins/pipelight/pipelight-9999.ebuild b/www-plugins/pipelight/pipelight-9999.ebuild
index 8f1557d50051..75380cf01222 100644
--- a/www-plugins/pipelight/pipelight-9999.ebuild
+++ b/www-plugins/pipelight/pipelight-9999.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit multilib
+inherit multilib-build
if [ ${PV} == "9999" ] ; then
- inherit git-2
+ inherit git-r3
EGIT_REPO_URI="https://bitbucket.org/mmueller2012/${PN}.git"
else
inherit vcs-snapshot
SRC_URI="https://bitbucket.org/mmueller2012/${PN}/get/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~x86"
fi
DESCRIPTION="Wine-based wrapper for running Windows plugins on POSIX systems"
@@ -20,19 +20,31 @@ HOMEPAGE="https://launchpad.net/pipelight"
LICENSE="|| ( GPL-2+ LGPL-2.1+ MPL-1.1 )"
SLOT="0"
-KEYWORDS=""
-IUSE=""
+IUSE="+abi_x86_32 abi_x86_64"
-DEPEND="app-emulation/wine[X,abi_x86_32,pipelight]"
+DEPEND="app-emulation/wine[X,${MULTILIB_USEDEP},pipelight]"
RDEPEND="${DEPEND}
app-arch/cabextract
- gnome-extra/zenity"
+ app-crypt/gnupg
+ media-fonts/corefonts
+ || (
+ gnome-extra/zenity
+ kde-apps/kdialog
+ )"
-QA_FLAGS_IGNORED="usr/share/pipelight/pluginloader.exe
- usr/share/pipelight/winecheck.exe"
+QA_FLAGS_IGNORED="usr/share/pipelight/pluginloader{,64}.exe
+ usr/share/pipelight/winecheck{,64}.exe"
src_configure() {
- econf --wine-path="${EPREFIX}/usr/bin/wine"
+ local myconf=( --wine-path="${EPREFIX}/usr/bin/wine" )
+ if use abi_x86_64; then
+ myconf+=(
+ --with-win64
+ --win64-cxx=wineg++
+ --wine64-path="${EPREFIX}/usr/bin/wine64"
+ )
+ fi
+ econf "${myconf[@]}"
}
src_install() {