summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-02-15 14:39:25 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-02-15 14:39:25 +0300
commit42c01a77a382a4c50db954638428d7c873a0ac0c (patch)
tree094f3910f1adf933f539f3e8e9e8daf7033c75e7
parentkde-plasma/bluedevil: arm64 stable (diff)
downloadgentoo-42c01a77a382a4c50db954638428d7c873a0ac0c.tar.gz
gentoo-42c01a77a382a4c50db954638428d7c873a0ac0c.tar.bz2
gentoo-42c01a77a382a4c50db954638428d7c873a0ac0c.zip
x11-terms/tilda: Version bump (v1.5.0)
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
-rw-r--r--x11-terms/tilda/Manifest1
-rw-r--r--x11-terms/tilda/tilda-1.4.1.ebuild5
-rw-r--r--x11-terms/tilda/tilda-1.5.0.ebuild32
3 files changed, 35 insertions, 3 deletions
diff --git a/x11-terms/tilda/Manifest b/x11-terms/tilda/Manifest
index 75d1352d0e3d..33e9e611c5e9 100644
--- a/x11-terms/tilda/Manifest
+++ b/x11-terms/tilda/Manifest
@@ -1 +1,2 @@
DIST tilda-1.4.1.tar.gz 471340 BLAKE2B a84d125bf81e384706347401ebbf7b11813bf5ed422e6b374e918ed564b9bfe168ebf3fef163b91a15350b49166b0040e90afdef716cc1762ecc410710f72c29 SHA512 d16878e762d94f94c219e8e711223a771a2ab816f02573f693cfbcfa0eee5aafff8a274898a65df168c0bf78258aa16e5a3be6b0c3dee418af61c68f43ed74c6
+DIST tilda-1.5.0.tar.gz 484754 BLAKE2B 8f04a5046b642e0cd67d375817d046920bbefd9b499458c2dab90f9801b0a4009b7b06cfe29af01095f1627581e4577ba5a7405948b29d21e233db288da48efd SHA512 2876b3ffbc5dd663b10c2f5fc7e6b838d6e3e18f30eb62afe07d9615b4567b04fba0b1efb2449204f4a5b78a90198092e397a24a41b978862d4fc6fab0b8de81
diff --git a/x11-terms/tilda/tilda-1.4.1.ebuild b/x11-terms/tilda/tilda-1.4.1.ebuild
index b3440c219be7..075ba71876f2 100644
--- a/x11-terms/tilda/tilda-1.4.1.ebuild
+++ b/x11-terms/tilda/tilda-1.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,11 +12,10 @@ SRC_URI="https://github.com/lanoxx/tilda/archive/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE=""
RDEPEND="x11-libs/vte:2.91
>=dev-libs/glib-2.8.4:2
- dev-libs/confuse
+ dev-libs/confuse:=
gnome-base/libglade
x11-libs/gtk+:3
x11-libs/libX11"
diff --git a/x11-terms/tilda/tilda-1.5.0.ebuild b/x11-terms/tilda/tilda-1.5.0.ebuild
new file mode 100644
index 000000000000..b7827af4144d
--- /dev/null
+++ b/x11-terms/tilda/tilda-1.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A drop down terminal, similar to the consoles found in first person shooters"
+HOMEPAGE="https://github.com/lanoxx/tilda"
+SRC_URI="https://github.com/lanoxx/tilda/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="x11-libs/vte:2.91
+ >=dev-libs/glib-2.8.4:2
+ dev-libs/confuse:=
+ gnome-base/libglade
+ x11-libs/gtk+:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ default
+ append-cflags -std=c99
+ eautoreconf
+}