summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-22 20:51:48 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-22 20:53:24 +0200
commit42c426baafe7444014734f877647ab4ab553142d (patch)
tree8b3d1db2146bb5ebde6dc5987bd5e94666598451
parentdev-libs/zziplib: remove obsolete version (diff)
downloadgentoo-42c426baafe7444014734f877647ab4ab553142d.tar.gz
gentoo-42c426baafe7444014734f877647ab4ab553142d.tar.bz2
gentoo-42c426baafe7444014734f877647ab4ab553142d.zip
Revert "dev-python/watchdog: Remove old"
This reverts commit db84463cec542e45b9233b73a7e3efd502df69e1. Still needed for stable www-apps/nikola. Can be cleaned up once we stabilize >=www-apps/nikola-8. Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-python/watchdog/Manifest1
-rw-r--r--dev-python/watchdog/watchdog-0.8.3-r2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/watchdog/Manifest b/dev-python/watchdog/Manifest
index 8424afdf095e..5e0bb5bb29a4 100644
--- a/dev-python/watchdog/Manifest
+++ b/dev-python/watchdog/Manifest
@@ -1 +1,2 @@
DIST watchdog-0.10.3.tar.gz 89215 BLAKE2B bbe8a2ab3f84b7eff60d4ebd38ac928db85998910fc5b107dcd645c9b91388a9e45d317777f08288ce3bc2befcf9310bb7c8aef4f8e3309481919dc87e84b2a1 SHA512 6061b1393cd07038ee22271101bd6d5c847ee9732b14f63bbb5d94fba9f8273ca728cdc58b6f53a95d8213d0ed35bc71e8bb9c54960bf3aea2f64da066a864f5
+DIST watchdog-0.8.3.tar.gz 83154 BLAKE2B d5d0635e83bbcd31544d5ea5811c2f202b0da76bd7a4086e8fc61e3293640e701b04599f95decaa82bee3705dbd6b91ad24b9dbd20edcfc329913600c8a3c932 SHA512 61f1db886e8e9a6d78b569329f4d5944c296778a5a34f94fbf115a748fb4c3be422bf4d3cc828e22fcdcd380fdf9009f5bd91a8a5edc87089afc58297a0b946f
diff --git a/dev-python/watchdog/watchdog-0.8.3-r2.ebuild b/dev-python/watchdog/watchdog-0.8.3-r2.ebuild
new file mode 100644
index 000000000000..7b2615c34eee
--- /dev/null
+++ b/dev-python/watchdog/watchdog-0.8.3-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_6)
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="https://github.com/gorakhargosh/watchdog"
+SRC_URI="mirror://pypi/w/watchdog/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/pathtools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}