summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-22 17:07:28 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-22 17:07:41 +0100
commit434c5826f7eba3584c752788056739a4052a277b (patch)
tree84c15d0851af365f833a02b14869850ae5dbc9cd
parentdev-lang/go: sync live (diff)
downloadgentoo-434c5826f7eba3584c752788056739a4052a277b.tar.gz
gentoo-434c5826f7eba3584c752788056739a4052a277b.tar.bz2
gentoo-434c5826f7eba3584c752788056739a4052a277b.zip
games-engines/frobtads: Fixed build with sys-libs/ncurses[tinfo]
Closes: https://bugs.gentoo.org/602446 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--games-engines/frobtads/files/frobtads-1.2.4-tinfo.patch12
-rw-r--r--games-engines/frobtads/frobtads-1.2.4.ebuild28
2 files changed, 32 insertions, 8 deletions
diff --git a/games-engines/frobtads/files/frobtads-1.2.4-tinfo.patch b/games-engines/frobtads/files/frobtads-1.2.4-tinfo.patch
new file mode 100644
index 000000000000..c50b5a05de43
--- /dev/null
+++ b/games-engines/frobtads/files/frobtads-1.2.4-tinfo.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/602446
+
+--- frobtads-1.2.4/configure.ac
++++ frobtads-1.2.4/configure.ac
+@@ -88,6 +88,7 @@
+ # doesn't hust to try pdcurses as a last resort.)
+ #
+ AC_SEARCH_LIBS([initscr], [ncurses curses pdcurses], [curseslibfound=true], [curseslibfound=false])
++AC_SEARCH_LIBS([keypad], [tinfo])
+
+ # Check for libcurl (network client library for http et al).
+ #
diff --git a/games-engines/frobtads/frobtads-1.2.4.ebuild b/games-engines/frobtads/frobtads-1.2.4.ebuild
index 7f2b43c14462..f0fd3816a632 100644
--- a/games-engines/frobtads/frobtads-1.2.4.ebuild
+++ b/games-engines/frobtads/frobtads-1.2.4.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils
+
+inherit autotools
DESCRIPTION="Curses-based interpreter and dev tools for TADS 2 and TADS 3 text adventures"
HOMEPAGE="http://www.tads.org/frobtads.htm"
@@ -16,17 +17,28 @@ IUSE="debug tads2compiler tads3compiler"
RESTRICT="!tads3compiler? ( test )"
RDEPEND="net-misc/curl
- sys-libs/ncurses:0"
-DEPEND=${RDEPEND}
+ sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
DOCS=( doc/{AUTHORS,BUGS,ChangeLog.old,NEWS,README,SRC_GUIDELINES,THANKS} )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.4-tinfo.patch #602446
+)
+
+src_prepare() {
+ default
+ eautoreconf #602446
+}
+
src_configure() {
- econf \
- $(use_enable debug error-checking) \
- $(use_enable debug t3debug) \
- $(use_enable tads2compiler t2-compiler) \
+ local myeconfargs=(
+ $(use_enable debug error-checking)
+ $(use_enable debug t3debug)
+ $(use_enable tads2compiler t2-compiler)
$(use_enable tads3compiler t3-compiler)
+ )
+ econf "${myeconfargs[@]}"
}
src_test() {