summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-07 09:02:35 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-08 19:44:15 +0100
commit437b20e7769bb1a7b441b352704c719be48526fc (patch)
treea061901a9f72dc6efd09ed00f1b04291f6e032ba
parentdev-ros/opencv_apps: bump to 2.0.0 (diff)
downloadgentoo-437b20e7769bb1a7b441b352704c719be48526fc.tar.gz
gentoo-437b20e7769bb1a7b441b352704c719be48526fc.tar.bz2
gentoo-437b20e7769bb1a7b441b352704c719be48526fc.zip
net-libs/ignition-transport: bump to 3.1.0
Package-Manager: Portage-2.3.16, Repoman-2.3.6
-rw-r--r--net-libs/ignition-transport/Manifest3
-rw-r--r--net-libs/ignition-transport/ignition-transport-3.1.0.ebuild36
2 files changed, 38 insertions, 1 deletions
diff --git a/net-libs/ignition-transport/Manifest b/net-libs/ignition-transport/Manifest
index 52516bce7f49..156c1963deff 100644
--- a/net-libs/ignition-transport/Manifest
+++ b/net-libs/ignition-transport/Manifest
@@ -1 +1,2 @@
-DIST ignition-transport3-3.0.1.tar.bz2 384679 SHA256 c2b8dd5f391a30f1239893b51d4ea487fd47bfe12ccdb3876a83df192df666be SHA512 a2e80d3b5a8b0ca327bd8892d1177f8316d3e2dbbb6f064626e00eb5e67572519377290973527d69ab4a8ff3970c350a7066625429d3a8403a5be8d491fb89c6 WHIRLPOOL 986b4af3deb1d24c3a4f9ff89b3e526efbf68f278b9ed0fff513fbf095e2f1752a4552a8c652545619fa3f5223f0353b68c728af0623f0ec66a2f6bc5aee01a5
+DIST ignition-transport3-3.0.1.tar.bz2 384679 BLAKE2B 1aace81c8d708dc06dedb53453718b019b1472c6c787fddb3b76c9e97cf2d518db2e037c20451b10c31db8a31d87b70f93c8339515a98f376bb660798bf07cd8 SHA512 a2e80d3b5a8b0ca327bd8892d1177f8316d3e2dbbb6f064626e00eb5e67572519377290973527d69ab4a8ff3970c350a7066625429d3a8403a5be8d491fb89c6
+DIST ignition-transport3-3.1.0.tar.bz2 385946 BLAKE2B 0ae44f0e1cd17369de9ee39f0d128ee5edbc68c1be672be5476d7cf8c161f59c069af63cec1966f6e0ba1c9e56ade0563b6546f7f285bdc49b6941939e2a4379 SHA512 438ab49f1c506e098c00becccf1856b3e0129d60f9aca32f713a74b38aefb178833353ff479c8512e7ffec812bdc0a06eb7f28f09766dc0cc5a9707184151555
diff --git a/net-libs/ignition-transport/ignition-transport-3.1.0.ebuild b/net-libs/ignition-transport/ignition-transport-3.1.0.ebuild
new file mode 100644
index 000000000000..8c6b71bda1c3
--- /dev/null
+++ b/net-libs/ignition-transport/ignition-transport-3.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils vcs-snapshot flag-o-matic
+
+DESCRIPTION="Combines ZeroMQ with Protobufs to create a fast and efficient message passing system"
+HOMEPAGE="http://ignitionrobotics.org/libraries/transport"
+SRC_URI="http://gazebosim.org/distributions/ign-transport/releases/${PN}3-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="3/3"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ net-libs/ignition-msgs:=
+ dev-libs/protobuf:=
+ >=net-libs/zeromq-3.2.0:=
+ sys-apps/util-linux
+ net-libs/cppzmq
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+S="${WORKDIR}/${PN}3-${PV}"
+
+src_configure() {
+ # upstream appends this conditionally...
+ append-flags "-fPIC"
+ echo "set (CMAKE_C_FLAGS_ALL \"${CXXFLAGS} \${CMAKE_C_FLAGS_ALL}\")" > "${S}/cmake/HostCFlags.cmake"
+ sed -i -e "s/LINK_FLAGS_RELWITHDEBINFO \" \"/LINK_FLAGS_RELWITHDEBINFO \" ${LDFLAGS} \"/" cmake/DefaultCFlags.cmake || die
+ cmake-utils_src_configure
+}