summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-07-18 14:25:01 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-07-18 15:01:22 +0200
commit4388dc7a3e7d4b280139d54e0b2800ee291443e6 (patch)
treef0ae484168e8d41df2d50ff2adfa21807f170826
parentdev-php/symfony-process: bump to v3.4.29 (diff)
downloadgentoo-4388dc7a3e7d4b280139d54e0b2800ee291443e6.tar.gz
gentoo-4388dc7a3e7d4b280139d54e0b2800ee291443e6.tar.bz2
gentoo-4388dc7a3e7d4b280139d54e0b2800ee291443e6.zip
dev-php/symfony-dependency-injection: bump to v2.8.50
security release Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-php/symfony-dependency-injection/Manifest1
-rw-r--r--dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-php/symfony-dependency-injection/Manifest b/dev-php/symfony-dependency-injection/Manifest
index a186b77f24dc..4102180b8f32 100644
--- a/dev-php/symfony-dependency-injection/Manifest
+++ b/dev-php/symfony-dependency-injection/Manifest
@@ -1 +1,2 @@
DIST symfony-dependency-injection-2.8.20.tar.gz 117123 BLAKE2B 469b11d55bbfdffe46b5cc94592f0bf81c1ddf82c656bbf9914a78cb7e5164960455c2ef1a70ef905b35775e91e279693af19015e586ddb3c95a0184d1737f32 SHA512 9ab6a4b36fde3908f26c2211066df501dd73387a7ec3d0aae85f8289257653bb54393bd9f4b50c347a4d5ba47214f13c089e475eaace3868f5c18f67b69bd829
+DIST symfony-dependency-injection-2.8.50.tar.gz 117771 BLAKE2B b71535619a45a03640064b987a7b5996dc991458c737661a983782d7af53bf89865bf511dbac99384f8ece583b628a2cde0def2cdd3e8c133055d84d9dbed1e1 SHA512 690b3f373c2fb549115f7fdb35880a2c94bf7afa28be2c75d718373e8925897f89d5e34f82b709b11cd8940547289345a8def4debe657f495a0b636a6aa72baa
diff --git a/dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild b/dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild
new file mode 100644
index 000000000000..e1ab01ad6686
--- /dev/null
+++ b/dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Symfony DependencyInjection Component"
+HOMEPAGE="https://github.com/symfony/dependency-injection"
+SRC_URI="https://github.com/symfony/dependency-injection/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# The test suite requires the unpackaged symfony-expression-language.
+RESTRICT=test
+
+# I'm not sure if symfony-config and symfony-yaml are actually needed if
+# you're not running the test suite...
+RDEPEND="dev-lang/php:*
+ dev-php/fedora-autoloader
+ >=dev-php/symfony-config-2.1.0
+ >=dev-php/symfony-yaml-2.1.0"
+DEPEND="test? ( ${RDEPEND} >=dev-php/phpunit-5.7.15 )"
+
+S="${WORKDIR}/dependency-injection-${PV}"
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}/autoload.php" "${S}/autoload-test.php" || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/Symfony/Component/DependencyInjection"
+ doins -r Compiler Dumper Exception Extension LazyProxy Loader ParameterBag
+ doins *.php "${FILESDIR}/autoload.php"
+ dodoc CHANGELOG.md README.md
+}
+
+src_test() {
+ phpunit --bootstrap "${S}/autoload-test.php" || die 'test suite failed'
+}