summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2020-04-21 15:12:34 +0300
committerMatthias Maier <tamiko@gentoo.org>2020-05-05 11:50:03 -0500
commit43d6a87a2087599304ddeb2996abb999102c8e74 (patch)
tree0b0c83281b0ab9e9861c3030af14286e88dbb16a
parentsci-libs/cantera: Fix site-packages install paths (diff)
downloadgentoo-43d6a87a2087599304ddeb2996abb999102c8e74.tar.gz
gentoo-43d6a87a2087599304ddeb2996abb999102c8e74.tar.bz2
gentoo-43d6a87a2087599304ddeb2996abb999102c8e74.zip
sci-libs/sundials: 5.2.0 version bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--sci-libs/sundials/Manifest1
-rw-r--r--sci-libs/sundials/files/sundials-5.2.0-fix-license-install-path.patch15
-rw-r--r--sci-libs/sundials/sundials-5.2.0.ebuild70
3 files changed, 86 insertions, 0 deletions
diff --git a/sci-libs/sundials/Manifest b/sci-libs/sundials/Manifest
index 7e84ebcb147d..0ad406c16c2b 100644
--- a/sci-libs/sundials/Manifest
+++ b/sci-libs/sundials/Manifest
@@ -3,3 +3,4 @@ DIST sundials-4.0.2.tar.gz 17183377 BLAKE2B e322a978186f41d84a936faa55962ef6794b
DIST sundials-4.1.0.tar.gz 17221960 BLAKE2B 598c7adc9e37fcfb1f44a3235f58af489ad907d053cb67ee0d3b076076621958374eb847e48318ddf7ced85a7601c5330ac640c7abe8723aaee7d650e3298b8d SHA512 1922dca3f0b8869098670aede802e48abec39607c96304e4efd9b03d195b16920175846fce10641aeebc48c216bda73c8691139dce57ffa7731a6bc8194b81b0
DIST sundials-5.0.0.tar.gz 18820465 BLAKE2B 77bc7bd489b52ff316f3e889aad4ec27830c42650591270443d45a0aa958d06663e93931a8933ca2d228619263219be4d7441cb473eaaedeab958ae47418a44e SHA512 4962adabcde19207b5044d1e63758d58b5d3cfeefcd0eae65ddfe5499931bf19fa98bafbd4742045cc255f6b4a45653f41df7a7739f86d6eb47c79c9312b4471
DIST sundials-5.1.0.tar.gz 18496945 BLAKE2B bfe2c88bd1a43c6e0b50e30a4498d23da9e495b4a27e67ff309a032f892cfd8ce54010f567f26b1ecd40a2e21e9364f0b75d0b5dde2771c9e35ad4912e7abf64 SHA512 ad2fef1197fe5680651b63a1da8fab0087416c943f9142e6d0ac8388113fb7e33a7297847f550585d7e8fed1d33111ab85235b3a2f94ac81004f5f3eb584c021
+DIST sundials-5.2.0.tar.gz 18639221 BLAKE2B c10e6deb5839993b8601347be94412d0b0c058084b4dc0d380681f7b4debd535f9736c2ef734e9fd84c6ddc190ab05f46abcb711225ec1f156a18d8edb6317fb SHA512 99163a104e436dab4779c77519502b5614b65d726324b29b14236315f6916beb5863fcd56b5acf19f62985c033b227fba1ebd3d3c4607ce991d94ee7739bb55f
diff --git a/sci-libs/sundials/files/sundials-5.2.0-fix-license-install-path.patch b/sci-libs/sundials/files/sundials-5.2.0-fix-license-install-path.patch
new file mode 100644
index 000000000000..8fb6c977ca76
--- /dev/null
+++ b/sci-libs/sundials/files/sundials-5.2.0-fix-license-install-path.patch
@@ -0,0 +1,15 @@
+diff -Naur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2020-04-01 00:03:37.000000000 +0300
++++ b/CMakeLists.txt 2020-04-21 13:27:58.000000000 +0300
+@@ -1146,9 +1146,9 @@
+ # install license and notice files
+ install(
+ FILES ${PROJECT_SOURCE_DIR}/LICENSE
+- DESTINATION include/sundials
++ DESTINATION share/doc/sundials-5.2.0
+ )
+ install(
+ FILES ${PROJECT_SOURCE_DIR}/NOTICE
+- DESTINATION include/sundials
++ DESTINATION share/doc/sundials-5.2.0
+ )
diff --git a/sci-libs/sundials/sundials-5.2.0.ebuild b/sci-libs/sundials/sundials-5.2.0.ebuild
new file mode 100644
index 000000000000..c6bc6848c819
--- /dev/null
+++ b/sci-libs/sundials/sundials-5.2.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD="77 90"
+# if FFLAGS and FCFLAGS are set then should be equal
+
+inherit cmake fortran-2 toolchain-funcs
+
+DESCRIPTION="Suite of nonlinear solvers"
+HOMEPAGE="https://computation.llnl.gov/projects/sundials"
+SRC_URI="https://computation.llnl.gov/projects/sundials/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cxx doc examples fortran hypre lapack mpi openmp sparse static-libs superlumt threads"
+REQUIRED_USE="hypre? ( mpi )"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ lapack? ( virtual/lapack )
+ mpi? ( virtual/mpi sci-libs/hypre:= )
+ sparse? ( sci-libs/klu )
+ superlumt? ( sci-libs/superlu_mt:= )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-license-install-path.patch )
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp && [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+}
+
+src_configure() {
+ mycmakeargs+=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_STATIC_LIBS="$(usex static-libs)"
+ -DCXX_ENABLE="$(usex cxx)"
+ -DFCMIX_ENABLE="$(usex fortran)"
+ -DF90_ENABLE="$(usex fortran)"
+ -DHYPRE_ENABLE="$(usex hypre)"
+ -DHYPRE_INCLUDE_DIR="${EPREFIX}/usr/include/hypre"
+ -DKLU_ENABLE="$(usex sparse)"
+ -DLAPACK_ENABLE="$(usex lapack)"
+ -DMPI_ENABLE="$(usex mpi)"
+ -DOPENMP_ENABLE="$(usex openmp)"
+ -DPTHREAD_ENABLE="$(usex threads)"
+ -DSUPERLUMT_ENABLE="$(usex superlumt)"
+ -DSUPERLUMT_INCLUDE_DIR="${EPREFIX}/usr/include/superlu_mt"
+ -DSUPERLUMT_LIBRARY="-lsuperlu_mt"
+ -DEXAMPLES_ENABLE="$(usex examples)"
+ -DEXAMPLES_INSTALL=ON
+ -DEXAMPLES_INSTALL_PATH="/usr/share/doc/${PF}/examples"
+ -DUSE_GENERIC_MATH=ON
+ )
+ use sparse && mycmakeargs+=( -DKLU_LIBRARY="${EPREFIX}/usr/$(get_libdir)/libklu.so" )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ use doc && dodoc doc/*/*.pdf
+}