summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger (asterix) <m.mairkeimberger@gmail.com>2016-08-06 16:51:48 +0200
committerDavid Seifert <soap@gentoo.org>2016-11-06 20:31:49 +0100
commit4487cff0713a8240761b079338d2617e768ee4f7 (patch)
tree4904c78f3655be45dd44dc6f020e253b7ad0c892
parentdev-lang/gforth: remove unused patches (diff)
downloadgentoo-4487cff0713a8240761b079338d2617e768ee4f7.tar.gz
gentoo-4487cff0713a8240761b079338d2617e768ee4f7.tar.bz2
gentoo-4487cff0713a8240761b079338d2617e768ee4f7.zip
dev-lang/gnat-gcc: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/2167 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-lang/gnat-gcc/files/gcc-configure-LANG.patch41
-rw-r--r--dev-lang/gnat-gcc/files/gcc-spec-env-r1.patch87
-rw-r--r--dev-lang/gnat-gcc/files/gnat-Make-lang.in.patch14
-rw-r--r--dev-lang/gnat-gcc/files/gnat-gcc-4.9.3-make-default-paths-match-slot.patch27
4 files changed, 0 insertions, 169 deletions
diff --git a/dev-lang/gnat-gcc/files/gcc-configure-LANG.patch b/dev-lang/gnat-gcc/files/gcc-configure-LANG.patch
deleted file mode 100644
index 3ef76ef911c0..000000000000
--- a/dev-lang/gnat-gcc/files/gcc-configure-LANG.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-The LANG vars aren't reset early enough so when sed tries to use [a-zA-Z] in
-option parsing, it may break.
-
-http://bugs.gentoo.org/103483
-
---- configure
-+++ configure
-@@ -54,6 +54,16 @@
- infodir='${prefix}/info'
- mandir='${prefix}/man'
-
-+# NLS nuisances.
-+# Only set these to C if already set. These must not be set unconditionally
-+# because not all systems understand e.g. LANG=C (notably SCO).
-+# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
-+# Non-C LC_CTYPE values break the ctype check.
-+if test "${LANG+set}" = set; then LANG=C; export LANG; fi
-+if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
-+if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
-+if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
-+
- # Initialize some other variables.
- subdirs=
- MFLAGS= MAKEFLAGS=
-@@ -452,16 +463,6 @@
- esac
- done
-
--# NLS nuisances.
--# Only set these to C if already set. These must not be set unconditionally
--# because not all systems understand e.g. LANG=C (notably SCO).
--# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
--# Non-C LC_CTYPE values break the ctype check.
--if test "${LANG+set}" = set; then LANG=C; export LANG; fi
--if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
--if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
--if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
--
- # confdefs.h avoids OS command line length limits that DEFS can exceed.
- rm -rf conftest* confdefs.h
- # AIX cpp loses on an empty file, so make sure it contains at least a newline.
diff --git a/dev-lang/gnat-gcc/files/gcc-spec-env-r1.patch b/dev-lang/gnat-gcc/files/gcc-spec-env-r1.patch
deleted file mode 100644
index a58926836e4e..000000000000
--- a/dev-lang/gnat-gcc/files/gcc-spec-env-r1.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-2013-08-22 Magnus Granberg <zorry@gentoo.org>
-
- * gcc/gcc.c (main): Add support for external spec file via the GCC_SPECS env var
- and move the process of the user specifed specs.
-
- This allows us to easily control pie/ssp defaults with gcc-config profiles.
- Original patch by Rob Holland
- Extended to support multiple entries separated by ':' by Kevin F. Quinn
- Modified to use getenv instead of poisoned GET_ENVIRONMENT by Ryan Hill
- Modified to process the GCC_SPECS env var befor DRIVER_SELF_SPECS by Magnus Granberg
-
---- gcc-4.8-20130210/gcc/gcc.c 2013-02-05 16:55:31.000000000 +0100
-+++ gcc-4.8-20130210-work/gcc/gcc.c 2013-07-26 02:32:14.625089864 +0200
-@@ -6427,6 +6428,48 @@ main (int argc, char **argv)
- do_option_spec (option_default_specs[i].name,
- option_default_specs[i].spec);
-
-+#if !(defined (__MSDOS__) || defined (OS2) || defined (VMS) || defined (WIN32))
-+ /* Add specs listed in GCC_SPECS. Note; in the process of separating
-+ * each spec listed, the string is overwritten at token boundaries
-+ * (':') with '\0', an effect of strtok_r().
-+ */
-+ specs_file = getenv ("GCC_SPECS");
-+ if (specs_file && (strlen(specs_file) > 0))
-+ {
-+ char *spec, *saveptr;
-+ for (spec=strtok_r(specs_file,":",&saveptr);
-+ spec!=NULL;
-+ spec=strtok_r(NULL,":",&saveptr))
-+ {
-+ struct user_specs *user = (struct user_specs *)
-+ xmalloc (sizeof (struct user_specs));
-+ user->next = (struct user_specs *) 0;
-+ user->filename = spec;
-+ if (user_specs_tail)
-+ user_specs_tail->next = user;
-+ else
-+ user_specs_head = user;
-+ user_specs_tail = user;
-+ }
-+ }
-+#endif
-+ /* Process any user specified specs in the order given on the command
-+ * line. */
-+ for (uptr = user_specs_head; uptr; uptr = uptr->next)
-+ {
-+ char *filename = find_a_file (&startfile_prefixes, uptr->filename,
-+ R_OK, true);
-+ read_specs (filename ? filename : uptr->filename, false, true);
-+ }
-+ /* Process any user self specs. */
-+ {
-+ struct spec_list *sl;
-+ for (sl = specs; sl; sl = sl->next)
-+ if (sl->name_len == sizeof "self_spec" - 1
-+ && !strcmp (sl->name, "self_spec"))
-+ do_self_spec (*sl->ptr_spec);
-+ }
-+
- /* Process DRIVER_SELF_SPECS, adding any new options to the end
- of the command line. */
-
-@@ -6535,24 +6578,6 @@ main (int argc, char **argv)
- PREFIX_PRIORITY_LAST, 0, 1);
- }
-
-- /* Process any user specified specs in the order given on the command
-- line. */
-- for (uptr = user_specs_head; uptr; uptr = uptr->next)
-- {
-- char *filename = find_a_file (&startfile_prefixes, uptr->filename,
-- R_OK, true);
-- read_specs (filename ? filename : uptr->filename, false, true);
-- }
--
-- /* Process any user self specs. */
-- {
-- struct spec_list *sl;
-- for (sl = specs; sl; sl = sl->next)
-- if (sl->name_len == sizeof "self_spec" - 1
-- && !strcmp (sl->name, "self_spec"))
-- do_self_spec (*sl->ptr_spec);
-- }
--
- if (compare_debug)
- {
- enum save_temps save;
diff --git a/dev-lang/gnat-gcc/files/gnat-Make-lang.in.patch b/dev-lang/gnat-gcc/files/gnat-Make-lang.in.patch
deleted file mode 100644
index ccb4e273d6e1..000000000000
--- a/dev-lang/gnat-gcc/files/gnat-Make-lang.in.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- Make-lang.in-orig 2005-12-14 19:11:41.538266250 +0100
-+++ Make-lang.in 2005-12-14 19:12:50.358567250 +0100
-@@ -341,9 +341,9 @@
- gnatlib-shared: force
- $(MAKE) -C ada $(FLAGS_TO_PASS) \
- GNATLIBFLAGS="$(GNATLIBFLAGS)" \
-- GNATLIBCFLAGS="$(GNATLIBCFLAGS)" \
-+ GNATLIBCFLAGS="$(GNATLIBCFLAGS) -fPIC" \
- GNATLIBLDFLAGS="$(GNATLIBLDFLAGS)" \
-- TARGET_LIBGCC2_CFLAGS="$(TARGET_LIBGCC2_CFLAGS)" \
-+ TARGET_LIBGCC2_CFLAGS="$(TARGET_LIBGCC2_CFLAGS) -fPIC" \
- THREAD_KIND="$(THREAD_KIND)" \
- TRACE="$(TRACE)" \
- gnatlib-shared
diff --git a/dev-lang/gnat-gcc/files/gnat-gcc-4.9.3-make-default-paths-match-slot.patch b/dev-lang/gnat-gcc/files/gnat-gcc-4.9.3-make-default-paths-match-slot.patch
deleted file mode 100644
index 0c197a15c134..000000000000
--- a/dev-lang/gnat-gcc/files/gnat-gcc-4.9.3-make-default-paths-match-slot.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- gcc/Makefile.in.orig 2016-05-20 15:01:04.277726220 -0700
-+++ gcc/Makefile.in 2016-05-20 18:40:43.658617109 -0700
-@@ -594,9 +594,9 @@
- # --------
-
- # Directory in which the compiler finds libraries etc.
--libsubdir = $(libdir)/gcc/$(target_noncanonical)/$(version)
-+libsubdir = $(libdir)/gnat-gcc/$(target_noncanonical)/SLOT_MARKER
- # Directory in which the compiler finds executables
--libexecsubdir = $(libexecdir)/gcc/$(target_noncanonical)/$(version)
-+libexecsubdir = $(libexecdir)/gnat-gcc/$(target_noncanonical)/SLOT_MARKER
- # Directory in which all plugin resources are installed
- plugin_resourcesdir = $(libsubdir)/plugin
- # Directory in which plugin headers are installed
-@@ -1944,9 +1944,9 @@
-
- DRIVER_DEFINES = \
- -DSTANDARD_STARTFILE_PREFIX=\"$(unlibsubdir)/\" \
-- -DSTANDARD_EXEC_PREFIX=\"$(libdir)/gcc/\" \
-- -DSTANDARD_LIBEXEC_PREFIX=\"$(libexecdir)/gcc/\" \
-- -DDEFAULT_TARGET_VERSION=\"$(version)\" \
-+ -DSTANDARD_EXEC_PREFIX=\"$(libdir)/gnat-gcc/\" \
-+ -DSTANDARD_LIBEXEC_PREFIX=\"$(libexecdir)/gnat-gcc/\" \
-+ -DDEFAULT_TARGET_VERSION=\"SLOT_MARKER\" \
- -DDEFAULT_TARGET_MACHINE=\"$(target_noncanonical)\" \
- -DSTANDARD_BINDIR_PREFIX=\"$(bindir)/\" \
- -DTOOLDIR_BASE_PREFIX=\"$(libsubdir_to_prefix)$(prefix_to_exec_prefix)\" \