summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-03-01 07:49:55 +0100
committerHans de Graaff <graaff@gentoo.org>2016-03-01 07:49:55 +0100
commit44fc8fe784b567fad5309d6e41c051ce73c25ba3 (patch)
tree346a4abfa59f6f13757121beebab584ba9934624
parentdev-ruby/rails: add rails 4.1.14.2, bug 576068 (diff)
downloadgentoo-44fc8fe784b567fad5309d6e41c051ce73c25ba3.tar.gz
gentoo-44fc8fe784b567fad5309d6e41c051ce73c25ba3.tar.bz2
gentoo-44fc8fe784b567fad5309d6e41c051ce73c25ba3.zip
dev-ruby/activesupport: add rails 3.2.22.2, bug 576068
Package-Manager: portage-2.2.26
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-3.2.22.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 2f620958a8e2..2fa48c40b039 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -1,4 +1,5 @@
DIST rails-3.2.22.1.tgz 3570617 SHA256 0678ec5677e6f70a20aa398b323a3d926531e1da266734ec90c34e111512b0fc SHA512 29b9e7aca818ed08111cc6306edfcbf88969ab2cbb0f36b9a189f8a29c2dec966e3a453d7b9ee9fc0cf06f0786aa493839440a2d6fb338b13b801978b08f4656 WHIRLPOOL b797311ab5420c4663b1617e5fabdc30a66619f1b6a16aa68ed96f5e38f4daff89cecc8bf9f3d7a702f17ae7da6bedf128adad2a3120f50a25ff85aff5cb6527
+DIST rails-3.2.22.2.tgz 3571822 SHA256 6aaef5723f3a409d057ace5500f1743168bde8f45114d9b5d861bb6e05444356 SHA512 b0c1817164168e2b8ae5b748dd1dd88097c2047d2e2eb31e403a5b865a1e50c43f8841a0e60ccdda6d5a859bba9acdfb06462cb8ba93a3e9ecc57dc349f8be13 WHIRLPOOL 8f5e674020a4c00a9a5da6e2e25aceb408ccb01f8adce74128a99cbb602d08da31de44b496a42d86bbf3887830785bfb961c95231d98bb1ce5d17755741dd3e1
DIST rails-4.0.13.tgz 3761572 SHA256 a693a8c5f767d153e765634cecb6356855ca51b6554b3af1a38888023a204a51 SHA512 3f2cca90187f800d1ec57fc6cbc58c1f3213113a94d1dee7d9cfd3dc0264b7f3a9c6cfc6dd95ef2fb3aa7d8ca5d6da50cedecc288ff8ff7e5305dc0309b4365d WHIRLPOOL a5b3f7f828a88d04b5687b3217b40903192ccea5eca36ca58cbb2baeec7471241fe5529f13688bd1f6396a384cf282c94bfaf54ee1cfafdf5ef400707dee7d01
DIST rails-4.1.14.1.tgz 3728574 SHA256 1b094a1d1f242c19d2fad0b4f0708d117fce281162d7550535a79c2919246179 SHA512 1ffb3d7f1f5b6db34bbae2015c220945fd780e42bc69242fdcadc6bd59b74c32f16cf54e153b9c3c2aa065d20b1231c19c7ebfe8f8d5f52a1048b8e0f1b7782a WHIRLPOOL 31eb9281d9e0b0e0c07807b14d7b1e52b1a08adc612da9c9c272a5eacb6b095d74b80400eb99818d37371963775942b9d85f38c18446d75de996595528fdf84d
DIST rails-4.1.14.2.tgz 3729630 SHA256 f37eee03321f41edce885c5753e2baf6803761d8ba56cde2df59d7f31ab66ac9 SHA512 526c47cd8710f5fbb752abf01ee80e01cef5f16a0dc7092a104ad8f165bb91e7fe656ca186aa027c622cec9d579a412f3d21e229167acbd8c761a18a77ed3e61 WHIRLPOOL c834ce049f299451c7eefe161ea5751f17b5605fe5a36cb9dff0b43c1fd23114b426c667a1e479ecc7f13cb413b6ccbab48890c0ac8c1336bcbbe4f2c9da04ad
diff --git a/dev-ruby/activesupport/activesupport-3.2.22.2.ebuild b/dev-ruby/activesupport/activesupport-3.2.22.2.ebuild
new file mode 100644
index 000000000000..3ced26cceb06
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.2.22.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/multi_json-1.0
+ >=dev-ruby/i18n-0.6.4:0.6
+ !!<dev-ruby/activesupport-3.0.11-r1:3.0"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ >=dev-ruby/memcache-client-1.5.8
+ dev-ruby/nokogiri
+ >=dev-ruby/builder-3.0.3:3
+ >=dev-ruby/tzinfo-0.3.29
+ )"
+
+# libxml is not strictly needed, there are tests using this code. jruby
+# uses a different xml implementation.
+ruby_add_bdepend "test? ( >=dev-ruby/libxml-2.0.0 )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
+
+ # Avoid test requiring the "de" locale.
+ sed -i -e '/test_transliterate_should_work_with_custom_i18n_rules_and_uncomposed_utf8/,/^ end/ s:^:#:' test/transliterate_test.rb || die
+}