summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-21 08:57:37 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-21 09:18:28 +0200
commit450ab5036328c9b6f6c332dfa26452c95251afee (patch)
tree7d525921c07722946db96b4ded7c24d77a378dd3
parentdev-python/numpy: Bump to 1.19.0 (diff)
downloadgentoo-450ab5036328c9b6f6c332dfa26452c95251afee.tar.gz
gentoo-450ab5036328c9b6f6c332dfa26452c95251afee.tar.bz2
gentoo-450ab5036328c9b6f6c332dfa26452c95251afee.zip
dev-python/certifi: Fork the patch into certifi-shim
Instead of carrying a growing patch that replaces the whole of package's code with a shim, just put the shim in a repository of its own and install it in place of the original package. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/certifi/Manifest1
-rw-r--r--dev-python/certifi/certifi-9999.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/certifi/Manifest b/dev-python/certifi/Manifest
index bb51482438f1..29e2111ba5ba 100644
--- a/dev-python/certifi/Manifest
+++ b/dev-python/certifi/Manifest
@@ -1 +1,2 @@
DIST certifi-2020.4.5.1.tar.gz 158038 BLAKE2B 988b29097b869b43095363b6ca344e3ce6c895f699b9d8b2576cb7108c5e12ea8a485c5f1dbc3d304d4243bdb09bce231fae15eb6abe47eee30afc1dc4ab4075 SHA512 8b0312aba427c29f6ebaf8140493f9673043e3f76f9bb1002a8fbc7a943303effad15173805e276147548d0978630655763b9ea60410135ba08f413fa77a5738
+DIST certifi-shim-9999.tar.gz 3762 BLAKE2B 3ea85314e37a989d4894ea5fc89fb138e06c7912277f90466c6edb121c39f33b031bcc08346c4766c99fb193a2d53801aa1e8ef30cfede9a7e8247c7e443faef SHA512 ca2844f1680a019dbb5a440141d8ebaddd7c78ce47a23a48a50d2d857d012f90d74d4200168964787e31f16b1e9d7c981c033ff99f1e3ea1fa73cbbbf255edbd
diff --git a/dev-python/certifi/certifi-9999.ebuild b/dev-python/certifi/certifi-9999.ebuild
new file mode 100644
index 000000000000..d05d83f13c9a
--- /dev/null
+++ b/dev-python/certifi/certifi-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+MY_P=certifi-shim-${PV}
+DESCRIPTION="Thin replacement for certifi using system certificate store"
+HOMEPAGE="
+ https://github.com/mgorny/certifi-shim
+ https://pypi.org/project/certifi"
+SRC_URI="
+ https://github.com/mgorny/certifi-shim/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ sed -i -e "s^/etc^${EPREFIX}/etc^" certifi/core.py || die
+ distutils-r1_src_prepare
+}