summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-12-05 12:51:58 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-05 20:19:49 -0500
commit456dbaf0c5ad663e9cdce4d9dedcc8b6fcb447d4 (patch)
tree4ae82c00b2be0f081efb24594aae4c211a02a3f3
parentgui-apps/swayidle: add 1.8.0 (diff)
downloadgentoo-456dbaf0c5ad663e9cdce4d9dedcc8b6fcb447d4.tar.gz
gentoo-456dbaf0c5ad663e9cdce4d9dedcc8b6fcb447d4.tar.bz2
gentoo-456dbaf0c5ad663e9cdce4d9dedcc8b6fcb447d4.zip
app-misc/tracker: Version bump to 3.4.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-misc/tracker/Manifest1
-rw-r--r--app-misc/tracker/tracker-3.4.2.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/app-misc/tracker/Manifest b/app-misc/tracker/Manifest
index 35e057b9c638..3ef1733cf7c0 100644
--- a/app-misc/tracker/Manifest
+++ b/app-misc/tracker/Manifest
@@ -1,2 +1,3 @@
DIST tracker-3.4.0.tar.xz 1876476 BLAKE2B 9745a496df30ebcd2f7e4a525bcd047d48ec4f68e12ef9775958e01939b538832e4d2622498a8ffd358d1a404c67365c70437e083497e8c12e1cbbb0c07713f7 SHA512 0a765d93cbe737a9cf902d1dc1ca00463065c1e7b3f93a7a8132919dfed97acdf80d99cf8f49b61e1a2bfc77a115f74e88731b3b0739651d2f727215c83f077f
DIST tracker-3.4.1.tar.xz 1865584 BLAKE2B 78a1c461e628095ca134241d7f8580806f8de018608c991644422503a3af6bab2c317859624cb811dd2907f2965af3ab2cfb1a58fa35017ed6a71b24e68f3c97 SHA512 102d61abd98feb6e39575c3df25cd4604e89106ed928b8edb1a3adc1bccd41f4ab92fc8bfd33d96b48c3b2cf5a3d901130ac6bf6f657faebe7339fffb95eed26
+DIST tracker-3.4.2.tar.xz 1865236 BLAKE2B 31cdb33de38d9251fc60a71b31c539e3f045748fb5dc160656dd5187dce109da858bad5390864cda8b63466a5113e0a193e0799b662ec250a31cfdff79467e6e SHA512 2214bce7cdbaf1039b11986cf101f615337bbc450331ee703edcfd7ad62dee6e1db831c2c89bf341663cadcdaae6ee9e5a15f49a8087acaafd58b389292ef480
diff --git a/app-misc/tracker/tracker-3.4.2.ebuild b/app-misc/tracker/tracker-3.4.2.ebuild
new file mode 100644
index 000000000000..3ec170a80cdb
--- /dev/null
+++ b/app-misc/tracker/tracker-3.4.2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit bash-completion-r1 flag-o-matic gnome.org gnome2-utils linux-info meson python-any-r1 systemd vala xdg
+
+DESCRIPTION="A tagging metadata database, search tool and indexer"
+HOMEPAGE="https://wiki.gnome.org/Projects/Tracker https://gitlab.gnome.org/GNOME/tracker"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3/0" # libtracker-sparql-3.0 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk-doc +miners stemmer test"
+RESTRICT="!test? ( test )"
+
+PV_SERIES=$(ver_cut 1-2)
+
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=sys-apps/dbus-1.3.2
+ >=dev-libs/gobject-introspection-1.54:=
+ >=dev-libs/icu-4.8.1.2:=
+ >=dev-libs/json-glib-1.4
+ >=net-libs/libsoup-2.99.2:3.0
+ >=dev-libs/libxml2-2.7
+ >=dev-db/sqlite-3.29.0:3
+ stemmer? ( dev-libs/snowball-stemmer:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ app-text/asciidoc
+ dev-libs/libxslt
+ $(vala_depend)
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.8
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xml-dtd:4.5
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ $(python_gen_any_dep 'dev-python/pygobject[${PYTHON_USEDEP}]')
+ $(python_gen_any_dep 'dev-python/tappy[${PYTHON_USEDEP}]')
+ )
+ ${PYTHON_DEPS}
+"
+PDEPEND="miners? ( >=app-misc/tracker-miners-${PV_SERIES} )"
+
+function inotify_enabled() {
+ if linux_config_exists; then
+ if ! linux_chkconfig_present INOTIFY_USER; then
+ ewarn "You should enable the INOTIFY support in your kernel."
+ ewarn "Check the 'Inotify support for userland' under the 'File systems'"
+ ewarn "option. It is marked as CONFIG_INOTIFY_USER in the config"
+ die 'missing CONFIG_INOTIFY'
+ fi
+ else
+ einfo "Could not check for INOTIFY support in your kernel."
+ fi
+}
+
+python_check_deps() {
+ python_has_version -b \
+ "dev-python/pygobject[${PYTHON_USEDEP}]" \
+ "dev-python/tappy[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ inotify_enabled
+
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ append-cflags -DTRACKER_DEBUG -DG_DISABLE_CAST_CHECKS
+
+ local emesonargs=(
+ $(meson_use gtk-doc docs)
+ -Dman=true
+ $(meson_feature stemmer)
+ -Dunicode_support=icu
+ -Dbash_completion_dir="$(get_bashcompdir)"
+ -Dsystemd_user_services_dir="$(systemd_get_userunitdir)"
+ $(meson_use test tests)
+ -Dintrospection=enabled
+ -Dsoup=soup3
+ )
+ meson_src_configure
+}
+
+src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}