summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:47:45 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:47:45 +0200
commit46533addf9796fea6e0376a3ea1b83277de3754e (patch)
tree91a2572ef23249e97ee5a80874d58898b3e08053
parentdev-ros/pr2_dashboard_aggregator: Initial import. Ebuild by me. (diff)
downloadgentoo-46533addf9796fea6e0376a3ea1b83277de3754e.tar.gz
gentoo-46533addf9796fea6e0376a3ea1b83277de3754e.tar.bz2
gentoo-46533addf9796fea6e0376a3ea1b83277de3754e.zip
dev-ros/urdf_tutorial: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
-rw-r--r--dev-ros/urdf_tutorial/Manifest1
-rw-r--r--dev-ros/urdf_tutorial/metadata.xml5
-rw-r--r--dev-ros/urdf_tutorial/urdf_tutorial-0.2.4.ebuild24
-rw-r--r--dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild24
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-ros/urdf_tutorial/Manifest b/dev-ros/urdf_tutorial/Manifest
new file mode 100644
index 000000000000..30110743174a
--- /dev/null
+++ b/dev-ros/urdf_tutorial/Manifest
@@ -0,0 +1 @@
+DIST urdf_tutorial-0.2.4.tar.gz 580617 SHA256 ac6c1d666eae7987ace46bab78dc9cc837a17462e59a80574d5441d0653cf333 SHA512 be1909b6b2f4efd5e0b846ab465d9b5b4096f729ffda7568194e4d3208604be83f7007160a767cc8f6df71edca9822e7e49e8f069e88e7b27d11690f7a17bf35 WHIRLPOOL 0b1fa28982bb5cf85d6241e8bbb75f56b88c8998dce23be0ac93d31559abb1ae563dab466673cd958bef0bfa956f43687b2b14f0d996f1583b57ea04357344cb
diff --git a/dev-ros/urdf_tutorial/metadata.xml b/dev-ros/urdf_tutorial/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/urdf_tutorial/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/urdf_tutorial/urdf_tutorial-0.2.4.ebuild b/dev-ros/urdf_tutorial/urdf_tutorial-0.2.4.ebuild
new file mode 100644
index 000000000000..bf1820d60426
--- /dev/null
+++ b/dev-ros/urdf_tutorial/urdf_tutorial-0.2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/urdf_tutorial"
+KEYWORDS="~amd64"
+
+inherit ros-catkin
+
+DESCRIPTION="URDF tutorials"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/urdf
+ dev-ros/joint_state_publisher
+ dev-ros/pr2_description
+ dev-ros/robot_state_publisher
+ dev-ros/rviz
+ dev-ros/xacro
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild b/dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild
new file mode 100644
index 000000000000..bf1820d60426
--- /dev/null
+++ b/dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/urdf_tutorial"
+KEYWORDS="~amd64"
+
+inherit ros-catkin
+
+DESCRIPTION="URDF tutorials"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/urdf
+ dev-ros/joint_state_publisher
+ dev-ros/pr2_description
+ dev-ros/robot_state_publisher
+ dev-ros/rviz
+ dev-ros/xacro
+"
+DEPEND="${RDEPEND}"