summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-08-06 09:28:56 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-08-06 09:34:42 -0500
commit4756ca24d21a6ab8abe0324dbfa33d37947ae762 (patch)
tree7d669b4845bdfecca9858c3a686c24ec8e34bbee
parentmedia-sound/murmur: Took over maintenance. (diff)
downloadgentoo-4756ca24d21a6ab8abe0324dbfa33d37947ae762.tar.gz
gentoo-4756ca24d21a6ab8abe0324dbfa33d37947ae762.tar.bz2
gentoo-4756ca24d21a6ab8abe0324dbfa33d37947ae762.zip
app-emulation/docker-compose: add version 1.8.0
Package-Manager: portage-2.3.0
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.8.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index f91c20bc2916..e7bff55bfc32 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -1,3 +1,4 @@
DIST docker-compose-1.7.1.tar.gz 141471 SHA256 97460873bfa9228afee543881ff6f6f7e4c12ac81974a2fcfa40fce272b2934e SHA512 eca5bbcf3785131cb813ed58bd4b662a70d7516ce875ea18bbb17ebb74f5c4b8189081add8f5befa11a5583063209d1121978aaec8f69ef8dc7ae3a077e0965a WHIRLPOOL 3366c5a6fa9e1acf244ba128118cf65a1b8f2658c93ab5424d00ae9ab6b4ad2771ed34b50d5ff8ab200bb669a1ee2d91f636ee5750d65d311931b3df7baef1d1
+DIST docker-compose-1.8.0.tar.gz 149822 SHA256 65f46b2ac836918c68306646206612ecadbb0cf17fae1557f6d565554747a2a9 SHA512 ed7aa5b7f318cd71492ad3da672937619063b824809888928bd64275dbf89ea6152c72d96028ca796d63da7fe028dc164ae871db0fdc531c918ba9f946b0b17d WHIRLPOOL c3cbf631d01d1e96c8e29965d3e493ade80869ad43c31d6ae7129c875d4b7d0856bc6a990f5af46db761dfb1f6a615f1e4056d00b0e423be6e0a41bb6db6a564
DIST docker-compose-1.8.0_rc1.tar.gz 145401 SHA256 9c897c6dc99b0cc63b402220e5c3ff530a09c974b965d6a07f050bd7a07ef663 SHA512 75c0ec21e0edbe0086ff5229115f12469996c2a6cb569fe744b381536aa590f0001ccab7aa8f67d052613a8475e4901316c99db4116ccf1e4bc47b0b0ecb016f WHIRLPOOL 32f6f0311adb2ebaec798f1b8f654f16c397e2aa48bb0ec44c1e92c38cea8438a6fbab67b5c9b7db06a89d081675568dcb40214d3d3c9c07aff9d71e2f5f3ce8
DIST docker-compose-1.8.0_rc2.tar.gz 148581 SHA256 a2b6ff7c8cc8121567a26e158c4c3a246ab5173fc0ebdb4208923df88b4bd683 SHA512 390f65d6bca940cef8d5bedfbf20d0da4897d06a466c61d419aff6a5458d2982375f948f8a714303e8bdd62298020a506ef1430794a3d3116614f3ae14d3a6f3 WHIRLPOOL 3b874adc90704c6a02c14e8431d6ac425e0ffe3458427ff35df69ba3804aba906ac4c9ca7ef2e33a3c0ac9ff0f466d9c39c886626b37b5d4c465ccb3b3e2b686
diff --git a/app-emulation/docker-compose/docker-compose-1.8.0.ebuild b/app-emulation/docker-compose/docker-compose-1.8.0.ebuild
new file mode 100644
index 000000000000..0cb7e375ed3f
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.8.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit bash-completion-r1 distutils-r1 vcs-snapshot
+
+MY_PV=${PV//_/}
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/cached-property-2[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ <dev-python/dockerpty-0.5[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-1.9.0[${PYTHON_USEDEP}]
+ <dev-python/docker-py-2.0[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ <dev-python/docopt-0.7[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
+ <dev-python/requests-2.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.8.1[${PYTHON_USEDEP}]
+ <dev-python/texttable-0.9[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ ${PYTHON} -m pytest tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}