summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-06-10 14:49:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-06-10 17:29:54 +0200
commit47af69296870092c8d1cfd4bdcba8af8da65e678 (patch)
tree47b3114ebfbd6727af21b65e016ad4b3313e7ff3
parentkde-plasma/plasma-meta: 5.22.0 version bump (diff)
downloadgentoo-47af69296870092c8d1cfd4bdcba8af8da65e678.tar.gz
gentoo-47af69296870092c8d1cfd4bdcba8af8da65e678.tar.bz2
gentoo-47af69296870092c8d1cfd4bdcba8af8da65e678.zip
kde-plasma/plasma-nm: 5.22.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/files/plasma-nm-5.22.0-qt-5.15.2ff-missing-include.patch30
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.22.0.ebuild83
3 files changed, 114 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index 2eb49f755ccd..7b1d788f2f99 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1 +1,2 @@
DIST plasma-nm-5.21.5.tar.xz 902104 BLAKE2B 8b881f39e01b7de0107b897c81fffb7bfa429a0bd7d8eb58026328ac42c411d5dd8e154e843767098731174a492e64b6c8a28c8af474584862f58081d9a5e751 SHA512 ac074e50d5ee3be99bab515b02522e391b14936c1c8152ca067c7513af7a8e8b81cb55ab9b412ca703554f3e35fc9392368159c9872d8c372017089a4a65e3fa
+DIST plasma-nm-5.22.0.tar.xz 899628 BLAKE2B 6b6f25a09d27ebf60ac8fb91191bbef258b857e0b4ecb0cb74b4ff9bd458350ac82b3d166f31a938058f09e9a0b2d5df245839d70cc9d6c3449df8e1d13dccc1 SHA512 5fea3c71bba5481b363abba0ced6a546a3384225f57166c4fcba9f370f89f3a3b0bb98320239e61733c496ed17230fa38b0bcaeae927206f113976467f116a43
diff --git a/kde-plasma/plasma-nm/files/plasma-nm-5.22.0-qt-5.15.2ff-missing-include.patch b/kde-plasma/plasma-nm/files/plasma-nm-5.22.0-qt-5.15.2ff-missing-include.patch
new file mode 100644
index 000000000000..133b3e225c54
--- /dev/null
+++ b/kde-plasma/plasma-nm/files/plasma-nm-5.22.0-qt-5.15.2ff-missing-include.patch
@@ -0,0 +1,30 @@
+From 55ab9bfd83fb74d14e26cc1a3d8f257bc47c45ea Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heiko.becker@kde.org>
+Date: Sun, 6 Jun 2021 19:34:16 +0200
+Subject: [PATCH] Add missing QFile include
+
+Used since 40d056195bc400bc4e249cd152993000011687c2. I suppose it's
+implicitly pulled in some cases, but for me the build fails against
+Qt from KDE's patch collection with "libs/handler.cpp:704:5: error:
+'QFile' was not declared in this scope;".
+
+(cherry picked from commit 6cac88b61da1277dcb9a801e47f2d69829c68086)
+---
+ libs/handler.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libs/handler.cpp b/libs/handler.cpp
+index 470b0fc1..7c8302be 100644
+--- a/libs/handler.cpp
++++ b/libs/handler.cpp
+@@ -45,6 +45,7 @@
+ #include <QDBusError>
+ #include <QDBusMetaType>
+ #include <QDBusPendingReply>
++#include <QFile>
+ #include <QIcon>
+
+ #include <KNotification>
+--
+GitLab
+
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.22.0.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.22.0.ebuild
new file mode 100644
index 000000000000..ff7ecdc7c367
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.22.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+KFMIN=5.82.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ >=app-crypt/qca-2.3.0:2
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5[widgets]
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/networkmanager-qt-${KFMIN}:5[teamd=]
+ >=kde-frameworks/plasma-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ net-misc/networkmanager[teamd=]
+ modemmanager? (
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/modemmanager-qt-${KFMIN}:5
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ >=dev-qt/qtxml-${QTMIN}:5
+ net-vpn/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+"
+
+PATCHES=( "${FILESDIR}/${P}-qt-5.15.2ff-missing-include.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)
+ $(cmake_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake_use_find_package openconnect OpenConnect)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}