summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-09-02 15:32:03 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-02 22:09:13 +0200
commit4803c92cb7aab2e819b4d32a49b14d6ffe5d83c8 (patch)
treec004cc412e877e295d1f616e7c930e16a687358b
parentsci-libs/buddy: Removed EAPI 4 ebuild buddy-2.4.ebuild (diff)
downloadgentoo-4803c92cb7aab2e819b4d32a49b14d6ffe5d83c8.tar.gz
gentoo-4803c92cb7aab2e819b4d32a49b14d6ffe5d83c8.tar.bz2
gentoo-4803c92cb7aab2e819b4d32a49b14d6ffe5d83c8.zip
sci-libs/ccfits: revbump (EAPI 4 -> 6)
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2189 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-libs/ccfits/ccfits-2.4-r1.ebuild49
-rw-r--r--sci-libs/ccfits/files/ccfits-2.2-makefile.patch4
2 files changed, 51 insertions, 2 deletions
diff --git a/sci-libs/ccfits/ccfits-2.4-r1.ebuild b/sci-libs/ccfits/ccfits-2.4-r1.ebuild
new file mode 100644
index 000000000000..bf971df37af4
--- /dev/null
+++ b/sci-libs/ccfits/ccfits-2.4-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+MYPN=CCfits
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="C++ interface for cfitsio"
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/fitsio/CCfits/"
+SRC_URI="${HOMEPAGE}/${MYP}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND=">=sci-libs/cfitsio-3.080"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYPN}"
+
+DOCS=( CHANGES README.INSTALL )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2-makefile.patch # avoid building cookbook by default and no rpath
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ AT_M4DIR=config/m4 eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install () {
+ if use doc; then
+ DOCS+=( *.pdf )
+ HTML_DOCS=( html/. )
+ fi
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/ccfits/files/ccfits-2.2-makefile.patch b/sci-libs/ccfits/files/ccfits-2.2-makefile.patch
index e92d9306900c..f8fa5d518591 100644
--- a/sci-libs/ccfits/files/ccfits-2.2-makefile.patch
+++ b/sci-libs/ccfits/files/ccfits-2.2-makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.am.orig 2010-01-20 02:52:22.000000000 +0000
-+++ Makefile.am 2010-01-20 02:50:34.000000000 +0000
+--- a/Makefile.am
++++ b/Makefile.am
@@ -26,12 +26,11 @@
EXTRA_DIST = config CHANGES README.INSTALL License.txt file1.pha $(MSVC_FILES)