summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-11-15 15:19:57 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2015-11-15 15:22:57 -0800
commit498b00b0486c6d84265cf47608a45faee948533e (patch)
tree57f8e77c0dc9ccf80f3ea00bb7263f44d14ee9e5
parentUpdate gnome 3.18 mask (diff)
downloadgentoo-498b00b0486c6d84265cf47608a45faee948533e.tar.gz
gentoo-498b00b0486c6d84265cf47608a45faee948533e.tar.bz2
gentoo-498b00b0486c6d84265cf47608a45faee948533e.zip
dev-ruby/shorturl: build fix
Without fixing 'rake doc', the documentation is never built, and the 'doc' directory does not exist; this caused pushd/popd to fail. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--dev-ruby/shorturl/shorturl-1.0.0-r2.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-ruby/shorturl/shorturl-1.0.0-r2.ebuild b/dev-ruby/shorturl/shorturl-1.0.0-r2.ebuild
index 6fe5b84e2727..ae31b1e8c27b 100644
--- a/dev-ruby/shorturl/shorturl-1.0.0-r2.ebuild
+++ b/dev-ruby/shorturl/shorturl-1.0.0-r2.ebuild
@@ -7,7 +7,8 @@ EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"
RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_DOC="doc"
RUBY_FAKEGEM_EXTRADOC="ChangeLog.txt README.rdoc TODO.rdoc"
@@ -31,7 +32,10 @@ each_ruby_test() {
all_ruby_install() {
all_fakegem_install
- pushd doc &>/dev/null
- dohtml -r .
- popd &>/dev/null
+ if use doc; then
+ # If the doc build fails, the doc directory might not exist
+ pushd doc &>/dev/null || die "pushd doc failed"
+ dohtml -r .
+ popd &>/dev/null
+ fi
}