summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-30 15:03:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-30 16:18:10 +0200
commit49f585d8455bab58b8977879883f23f1b4437327 (patch)
treeb975d23fac60f5af491ec36bcd9b895049c79de6
parentmedia-video/ffmpeg: bump to 3.0.2 (diff)
downloadgentoo-49f585d8455bab58b8977879883f23f1b4437327.tar.gz
gentoo-49f585d8455bab58b8977879883f23f1b4437327.tar.bz2
gentoo-49f585d8455bab58b8977879883f23f1b4437327.zip
dev-ml/oasis: bump to 0.4.6
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ml/oasis/Manifest1
-rw-r--r--dev-ml/oasis/oasis-0.4.6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/oasis/Manifest b/dev-ml/oasis/Manifest
index 0cf9d6e7cfbf..32c8f8b690bc 100644
--- a/dev-ml/oasis/Manifest
+++ b/dev-ml/oasis/Manifest
@@ -1 +1,2 @@
DIST oasis-0.4.5.tar.gz 336502 SHA256 6623a603415c4718add6a6ebad80f6688164a2e9b28576c082548b17bf8b2e44 SHA512 97d5401762ffda6bf4d7a239d9c77f8647d58da1728925e6de6e8fdfded6f8e7bb69652a838b86ab7203cd68436b06f76921c76840b97db56a94bb87d74450d7 WHIRLPOOL 46f5c3f900baa3d3b6ada8c0cf90cc90cfddc70523510d5ba5541e5075c96360ebacdd23a1b0f8b28a90bda7fb1700b9a2e9d7989af650e9aa5d50f358795d92
+DIST oasis-0.4.6.tar.gz 337490 SHA256 1324becb9fbc181f7276936339f62db224d166f01e50ea19f8f62037271bbbfb SHA512 c85432c75de1814024b11f9aea89fc740016fc13f2fd16ad1a4819de406d26a698f33a43e64649cbc17fe194c5da336e83ad85af91d6b97d0b3f70db44f33d88 WHIRLPOOL 7a742e67dcab5468b57ae2e5c730508b07ff9380a584e75d4b269d84a09a73e826819511d9ebfbbc5748d57163104fc7ab93756e8bfcd56954a2ad411e9ab04c
diff --git a/dev-ml/oasis/oasis-0.4.6.ebuild b/dev-ml/oasis/oasis-0.4.6.ebuild
new file mode 100644
index 000000000000..c654858785ae
--- /dev/null
+++ b/dev-ml/oasis/oasis-0.4.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${P/_/\~}
+DESCRIPTION="OASIS is a tool to integrate a configure, build and install system in OCaml project"
+HOMEPAGE="http://oasis.forge.ocamlcore.org/index.php"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1604/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-ml/ocaml-data-notation-0.0.11:=
+ dev-ml/ocamlbuild:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.3.1
+ dev-ml/ocamlify
+ dev-ml/ocamlmod
+ !<sci-chemistry/oasis-4.0-r3
+ test? (
+ >=dev-ml/ocaml-fileutils-0.4.2
+ >=dev-ml/ounit-2.0.0
+ >=dev-ml/ocaml-expect-0.0.4
+ dev-ml/pcre-ocaml
+ dev-ml/extlib
+ )"
+
+STRIP_MASK="*/bin/*"
+S="${WORKDIR}/${MY_P}"
+DOCS=( "README.txt" "TODO.txt" "AUTHORS.txt" "CHANGES.txt" )