summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:23:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:23:23 +0200
commit4a4c28dba83371ebdd7948cec5014a2d25469429 (patch)
tree385e792bf3844121f79f24ed242c1d1c70b63639
parentdev-ros/rqt_plot: Initial import. Ebuild by me. (diff)
downloadgentoo-4a4c28dba83371ebdd7948cec5014a2d25469429.tar.gz
gentoo-4a4c28dba83371ebdd7948cec5014a2d25469429.tar.bz2
gentoo-4a4c28dba83371ebdd7948cec5014a2d25469429.zip
dev-ros/rqt_publisher: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
-rw-r--r--dev-ros/rqt_publisher/Manifest1
-rw-r--r--dev-ros/rqt_publisher/metadata.xml5
-rw-r--r--dev-ros/rqt_publisher/rqt_publisher-0.3.12.ebuild28
-rw-r--r--dev-ros/rqt_publisher/rqt_publisher-9999.ebuild28
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-ros/rqt_publisher/Manifest b/dev-ros/rqt_publisher/Manifest
new file mode 100644
index 000000000000..a503bd56f8f3
--- /dev/null
+++ b/dev-ros/rqt_publisher/Manifest
@@ -0,0 +1 @@
+DIST rqt_common_plugins-0.3.12.tar.gz 231733 SHA256 602ceea814b152865cd55c140565ec82d72277d9de75b869ce9fd3ac5a17b749 SHA512 567fb85324a85ef935379762026f7f3b5fbe491f61d947c273c1d138286acb919a2f458151b7137587bddbe028617934a75695a165fc7e7e6fd4b4cd87247b7d WHIRLPOOL d49809544f3de32129233c562f643afeed599b4f42688050aa433023188467243409ac048464eac05fc06f9a20c9d8992946dc68db0b01d7bcfde585a65fc42b
diff --git a/dev-ros/rqt_publisher/metadata.xml b/dev-ros/rqt_publisher/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/rqt_publisher/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rqt_publisher/rqt_publisher-0.3.12.ebuild b/dev-ros/rqt_publisher/rqt_publisher-0.3.12.ebuild
new file mode 100644
index 000000000000..6786cf1da9ea
--- /dev/null
+++ b/dev-ros/rqt_publisher/rqt_publisher-0.3.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for publishing arbitrary messages with fixed or computed field values"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_publisher/rqt_publisher-9999.ebuild b/dev-ros/rqt_publisher/rqt_publisher-9999.ebuild
new file mode 100644
index 000000000000..6786cf1da9ea
--- /dev/null
+++ b/dev-ros/rqt_publisher/rqt_publisher-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for publishing arbitrary messages with fixed or computed field values"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"