summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2019-12-11 23:42:35 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2019-12-11 23:43:37 +0100
commit4ad4e117eeb677a88ad5551cfc19554631ffe79d (patch)
treed595476c1228d067b3ef36551ecdeea11536dc47
parentsys-cluster/ceph: Version bump to 14.2.5 (diff)
downloadgentoo-4ad4e117eeb677a88ad5551cfc19554631ffe79d.tar.gz
gentoo-4ad4e117eeb677a88ad5551cfc19554631ffe79d.tar.bz2
gentoo-4ad4e117eeb677a88ad5551cfc19554631ffe79d.zip
media-plugins/vdr-mp3ng: fixed Magick++.h: No such file or directory
removed imagemagick support, as it do not compile with any versions of imagemagick in the tree. plugin will still works with imlib2 support. Bug: https://bugs.gentoo.org/590950 Closes: https://bugs.gentoo.org/590950 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
-rw-r--r--media-plugins/vdr-mp3ng/vdr-mp3ng-0.0.1_pre5-r2.ebuild (renamed from media-plugins/vdr-mp3ng/vdr-mp3ng-0.0.1_pre5-r1.ebuild)44
1 files changed, 20 insertions, 24 deletions
diff --git a/media-plugins/vdr-mp3ng/vdr-mp3ng-0.0.1_pre5-r1.ebuild b/media-plugins/vdr-mp3ng/vdr-mp3ng-0.0.1_pre5-r2.ebuild
index da4eb768f836..c64dcd95e6b9 100644
--- a/media-plugins/vdr-mp3ng/vdr-mp3ng-0.0.1_pre5-r1.ebuild
+++ b/media-plugins/vdr-mp3ng/vdr-mp3ng-0.0.1_pre5-r2.ebuild
@@ -1,34 +1,35 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vdr-plugin-2 flag-o-matic
MY_PV=0.9.13-MKIV-pre3
MY_P=${PN}-${MY_PV}
-S=${WORKDIR}/mp3ng-0.9.13-MKIV-pre3
-
DESCRIPTION="VDR Plugin: play mp3 and ogg on VDR"
-HOMEPAGE="http://www.glaserei-franz.de/VDR/Moronimo2/vdrplugins.htm"
-SRC_URI="http://www.glaserei-franz.de/VDR/Moronimo2/downloads/${MY_P}.tar.gz
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://vdr.websitec.de/download/${PN}/${PN}-0.9.13-MKIV-pre3.tar.gz
mirror://gentoo/${PN}-pictures-0.0.1.tar.gz
mirror://gentoo/${PN}-0.0.1_pre4-span-0.0.3.diff.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="vorbis oss imagemagick"
+IUSE="oss vorbis"
-DEPEND=">=media-video/vdr-1.6
+DEPEND="media-libs/imlib2
media-libs/libmad
media-libs/libid3tag
- sys-libs/zlib
media-libs/libsndfile
- vorbis? ( media-libs/libvorbis )
- imagemagick? ( virtual/imagemagick-tools )
- !imagemagick? ( media-libs/imlib2 )"
+ media-video/vdr
+ sys-libs/zlib
+ vorbis? ( media-libs/libvorbis )"
+
+DOCS=(HISTORY MANUAL README README-MORONIMO examples/network.sh.example)
+
+S=${WORKDIR}/mp3ng-0.9.13-MKIV-pre3
src_prepare() {
vdr-plugin-2_src_prepare
@@ -36,20 +37,17 @@ src_prepare() {
# wrt bug 595248
append-cxxflags $(test-flags-CXX -std=gnu++03) -std=gnu++03
- epatch "${FILESDIR}/${PN}-0.0.1_pre4-gentoo.diff"
- epatch "${FILESDIR}/${PN}-0.0.1_pre4-gcc4.diff"
- epatch "${DISTDIR}/${PN}-0.0.1_pre4-span-0.0.3.diff.tar.gz"
- epatch "${FILESDIR}/${PN}-0.0.1_pre4-vdr-1.5.1.diff"
- epatch "${FILESDIR}/${PN}-0.0.1_pre4-glibc-2.10.patch"
+ eapply -p0 "${FILESDIR}/${PN}-0.0.1_pre4-gentoo.diff"
+ eapply "${FILESDIR}/${PN}-0.0.1_pre4-gcc4.diff"
+ eapply "${WORKDIR}/${PN}-0.0.1_pre4-span.diff"
+ eapply "${FILESDIR}/${PN}-0.0.1_pre4-vdr-1.5.1.diff"
+ eapply "${FILESDIR}/${PN}-0.0.1_pre4-glibc-2.10.patch"
use !vorbis && sed -i "s:#WITHOUT_LIBVORBISFILE:WITHOUT_LIBVORBISFILE:" Makefile
use oss && sed -i "s:#WITH_OSS_OUTPUT:WITH_OSS_OUTPUT:" Makefile
- use imagemagick && sed -i Makefile \
- -e "s:HAVE_IMLIB2:#HAVE_IMLIB2:" \
- -e "s:#HAVE_MAGICK:HAVE_MAGICK:"
- has_version ">=media-video/vdr-1.3.37" && epatch "${FILESDIR}/${PN}-0.0.1_pre4-1.3.37.diff"
- has_version ">=media-gfx/imagemagick-6.4" && epatch "${FILESDIR}/imagemagick-6.4.x.diff"
+ has_version ">=media-video/vdr-1.3.37" && eapply "${FILESDIR}/${PN}-0.0.1_pre4-1.3.37.diff"
+ has_version ">=media-gfx/imagemagick-6.4" && eapply "${FILESDIR}/imagemagick-6.4.x.diff"
sed -i mp3ng.c -e "s:RegisterI18n:// RegisterI18n:"
@@ -69,6 +67,4 @@ src_install() {
doins "${S}/images/mp3MKIV-spectrum-analyzer-bg.png"
newbin examples/mount.sh.example mount-mp3ng.sh
-
- dodoc HISTORY MANUAL README README-MORONIMO examples/network.sh.example
}