summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-11-08 23:55:07 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-11-08 23:59:55 +0000
commit4ba7ea61625be6c78cc4e76b4110b0e0a6471e0b (patch)
tree66a94a651314d0e18ee37f19b93a66a933fac464
parentnet-analyzer/poink: bump EAPI and stuff (diff)
downloadgentoo-4ba7ea61625be6c78cc4e76b4110b0e0a6471e0b.tar.gz
gentoo-4ba7ea61625be6c78cc4e76b4110b0e0a6471e0b.tar.bz2
gentoo-4ba7ea61625be6c78cc4e76b4110b0e0a6471e0b.zip
sys-devel/binutils: update live ebuild to EAPI=7
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--sys-devel/binutils/binutils-2.33.1.ebuild10
-rw-r--r--sys-devel/binutils/binutils-9999.ebuild10
2 files changed, 10 insertions, 10 deletions
diff --git a/sys-devel/binutils/binutils-2.33.1.ebuild b/sys-devel/binutils/binutils-2.33.1.ebuild
index e4e5fd60e822..e7f493b2b0e2 100644
--- a/sys-devel/binutils/binutils-2.33.1.ebuild
+++ b/sys-devel/binutils/binutils-2.33.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils libtool flag-o-matic gnuconfig multilib versionator
+inherit eutils libtool flag-o-matic gnuconfig multilib
DESCRIPTION="Tools necessary to build programs"
HOMEPAGE="https://sourceware.org/binutils/"
@@ -36,13 +36,13 @@ case ${PV} in
inherit git-r3
S=${WORKDIR}/binutils
EGIT_CHECKOUT_DIR=${S}
- EGIT_BRANCH=$(get_version_component_range 1-2)
+ EGIT_BRANCH=$(ver_cut 1-2)
EGIT_BRANCH="binutils-${EGIT_BRANCH/./_}-branch"
- SLOT=$(get_version_component_range 1-2)
+ SLOT=$(ver_cut 1-2)
;;
*)
SRC_URI="mirror://gnu/binutils/binutils-${PV}.tar.xz"
- SLOT=$(get_version_component_range 1-2)
+ SLOT=$(ver_cut 1-2)
;;
esac
diff --git a/sys-devel/binutils/binutils-9999.ebuild b/sys-devel/binutils/binutils-9999.ebuild
index ac40bd24d645..ef0da89a59f5 100644
--- a/sys-devel/binutils/binutils-9999.ebuild
+++ b/sys-devel/binutils/binutils-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils libtool flag-o-matic gnuconfig multilib versionator
+inherit eutils libtool flag-o-matic gnuconfig multilib
DESCRIPTION="Tools necessary to build programs"
HOMEPAGE="https://sourceware.org/binutils/"
@@ -35,13 +35,13 @@ case ${PV} in
inherit git-r3
S=${WORKDIR}/binutils
EGIT_CHECKOUT_DIR=${S}
- EGIT_BRANCH=$(get_version_component_range 1-2)
+ EGIT_BRANCH=$(ver_cut 1-2)
EGIT_BRANCH="binutils-${EGIT_BRANCH/./_}-branch"
- SLOT=$(get_version_component_range 1-2)
+ SLOT=$(ver_cut 1-2)
;;
*)
SRC_URI="mirror://gnu/binutils/binutils-${PV}.tar.xz"
- SLOT=$(get_version_component_range 1-2)
+ SLOT=$(ver_cut 1-2)
;;
esac