summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-24 23:53:00 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-25 00:03:28 +0200
commit4c06c94edfcce28396491a81569f4e8ca18ec26d (patch)
tree16c3207c9e5435301e23efbb0796636491ab44a9
parentapp-portage/smart-live-rebuild: Bump the live ebuild to EAPI=6 (diff)
downloadgentoo-4c06c94edfcce28396491a81569f4e8ca18ec26d.tar.gz
gentoo-4c06c94edfcce28396491a81569f4e8ca18ec26d.tar.bz2
gentoo-4c06c94edfcce28396491a81569f4e8ca18ec26d.zip
app-portage/smart-live-rebuild: Bump to 1.3.5
-rw-r--r--app-portage/smart-live-rebuild/Manifest1
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.3.5.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-portage/smart-live-rebuild/Manifest b/app-portage/smart-live-rebuild/Manifest
index 7b5a9d227ce8..d7dff16c2f5b 100644
--- a/app-portage/smart-live-rebuild/Manifest
+++ b/app-portage/smart-live-rebuild/Manifest
@@ -1 +1,2 @@
DIST smart-live-rebuild-1.3.4.1.tar.bz2 15980 SHA256 dd1e780937322a4cdee5a8f9af48d24283bda203e40167d02c7bb18924a4335f SHA512 65b864532e662d0fa032962673c2c2d6c1e21c557c82e295591086aea22de90ca9fed0e90bb0da0f6926ab19176a04ab41ee80c88dd8c5c05c3751c30ca39a92 WHIRLPOOL 329ea91bba103c6b2728905dac33532030d2c0ae802deb19056b1719bec6d85bd9b9a039cad4b3add92620c003cc573c797080cb2e02f09e670a0475439904be
+DIST smart-live-rebuild-1.3.5.tar.bz2 16004 SHA256 f7d304bb00ec32ab48bb3062a89896dbd0df344e010e91ea40417d162f5ad881 SHA512 46933334c8c46a056c837e60a5d8aed30a35b1ddd20d7c0f03e813f6cac11cc2dc9469674b1e9c23d94c9ebc474e5eacc7aa0e8f82492554a7f49b438ed740d2 WHIRLPOOL d9a5ab93057cc3070f46fec49eee0c71237481a8e3dc84a9de40df5eb78d2fe3617b5fd1f82c04b24e9bfaef81de0883d0c8696c00ff8e7a685f175e30783370
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.5.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.5.ebuild
new file mode 100644
index 000000000000..19a3369a8d7a
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
+SRC_URI="https://github.com/mgorny/smart-live-rebuild/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
+
+# Tests need to be fixed
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example smart-live-rebuild.conf
+}