summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-13 15:55:01 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-13 15:55:01 +0200
commit4c090313f91ccd70c19902a11e54d33c9c9a3756 (patch)
tree77ca6b6ae706b9a73b11e44fcbfe2ed635bf0628
parentnet-misc/openssh: drop unused multilib inherit (diff)
downloadgentoo-4c090313f91ccd70c19902a11e54d33c9c9a3756.tar.gz
gentoo-4c090313f91ccd70c19902a11e54d33c9c9a3756.tar.bz2
gentoo-4c090313f91ccd70c19902a11e54d33c9c9a3756.zip
sys-apps/gawk: drop unused multilib inherit, tidy ebuild
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sys-apps/gawk/gawk-4.2.1-r1.ebuild20
-rw-r--r--sys-apps/gawk/gawk-5.0.1.ebuild19
-rw-r--r--sys-apps/gawk/gawk-5.1.0.ebuild20
3 files changed, 41 insertions, 18 deletions
diff --git a/sys-apps/gawk/gawk-4.2.1-r1.ebuild b/sys-apps/gawk/gawk-4.2.1-r1.ebuild
index 0fb4a83be30e..fb28795e5fbb 100644
--- a/sys-apps/gawk/gawk-4.2.1-r1.ebuild
+++ b/sys-apps/gawk/gawk-4.2.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
-inherit toolchain-funcs multilib
+inherit toolchain-funcs
DESCRIPTION="GNU awk pattern-matching language"
HOMEPAGE="https://www.gnu.org/software/gawk/gawk.html"
@@ -25,13 +25,16 @@ DEPEND="${RDEPEND}
src_prepare() {
default
- # use symlinks rather than hardlinks, and disable version links
+ # Use symlinks rather than hardlinks, and disable version links
sed -i \
-e '/^LN =/s:=.*:= $(LN_S):' \
-e '/install-exec-hook:/s|$|\nfoo:|' \
Makefile.in doc/Makefile.in || die
- sed -i '/^pty1:$/s|$|\n_pty1:|' test/Makefile.in #413327
- # fix standards conflict on Solaris
+
+ # bug #413327
+ sed -i '/^pty1:$/s|$|\n_pty1:|' test/Makefile.in || die
+
+ # Fix standards conflict on Solaris
if [[ ${CHOST} == *-solaris* ]] ; then
sed -i \
-e '/\<_XOPEN_SOURCE\>/s/1$/600/' \
@@ -42,17 +45,21 @@ src_prepare() {
src_configure() {
export ac_cv_libsigsegv=no
+
local myeconfargs=(
--libexec='$(libdir)/misc'
$(use_with mpfr)
$(use_enable nls)
$(use_with readline)
)
+
econf "${myeconfargs[@]}"
}
src_install() {
- rm -rf README_d # automatic dodocs barfs
+ # Automatic dodocs barfs
+ rm -rf README_d || die
+
default
# Install headers
@@ -62,7 +69,7 @@ src_install() {
}
pkg_postinst() {
- # symlink creation here as the links do not belong to gawk, but to any awk
+ # Symlink creation here as the links do not belong to gawk, but to any awk
if has_version app-admin/eselect \
&& has_version app-eselect/eselect-awk ; then
eselect awk update ifunset
@@ -71,6 +78,7 @@ pkg_postinst() {
for l in "${EROOT}"/usr/share/man/man1/gawk.1* "${EROOT}"/usr/bin/gawk; do
[[ -e ${l} && ! -e ${l/gawk/awk} ]] && ln -s "${l##*/}" "${l/gawk/awk}"
done
+
[[ ! -e ${EROOT}/bin/awk ]] && ln -s "../usr/bin/gawk" "${EROOT}/bin/awk"
fi
}
diff --git a/sys-apps/gawk/gawk-5.0.1.ebuild b/sys-apps/gawk/gawk-5.0.1.ebuild
index 4d4f28b7627a..e6200d02e5d7 100644
--- a/sys-apps/gawk/gawk-5.0.1.ebuild
+++ b/sys-apps/gawk/gawk-5.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit toolchain-funcs multilib
+inherit toolchain-funcs
DESCRIPTION="GNU awk pattern-matching language"
HOMEPAGE="https://www.gnu.org/software/gawk/gawk.html"
@@ -27,13 +27,16 @@ BDEPEND="
src_prepare() {
default
- # use symlinks rather than hardlinks, and disable version links
+ # Use symlinks rather than hardlinks, and disable version links
sed -i \
-e '/^LN =/s:=.*:= $(LN_S):' \
-e '/install-exec-hook:/s|$|\nfoo:|' \
Makefile.in doc/Makefile.in || die
- sed -i '/^pty1:$/s|$|\n_pty1:|' test/Makefile.in || die #413327
- # fix standards conflict on Solaris
+
+ # bug #413327
+ sed -i '/^pty1:$/s|$|\n_pty1:|' test/Makefile.in || die
+
+ # Fix standards conflict on Solaris
if [[ ${CHOST} == *-solaris* ]] ; then
sed -i \
-e '/\<_XOPEN_SOURCE\>/s/1$/600/' \
@@ -44,17 +47,20 @@ src_prepare() {
src_configure() {
export ac_cv_libsigsegv=no
+
local myeconfargs=(
--libexec='$(libdir)/misc'
$(use_with mpfr)
$(use_enable nls)
$(use_with readline)
)
+
econf "${myeconfargs[@]}"
}
src_install() {
- rm -rf README_d # automatic dodocs barfs
+ # Automatic dodocs barfs
+ rm -rf README_d
default
# Install headers
@@ -64,7 +70,7 @@ src_install() {
}
pkg_postinst() {
- # symlink creation here as the links do not belong to gawk, but to any awk
+ # Symlink creation here as the links do not belong to gawk, but to any awk
if has_version app-admin/eselect && has_version app-eselect/eselect-awk ; then
eselect awk update ifunset
else
@@ -74,6 +80,7 @@ pkg_postinst() {
ln -s "${l##*/}" "${l/gawk/awk}" || die
fi
done
+
if ! [[ -e ${EROOT}/bin/awk ]] ; then
ln -s "../usr/bin/gawk" "${EROOT}/bin/awk" || die
fi
diff --git a/sys-apps/gawk/gawk-5.1.0.ebuild b/sys-apps/gawk/gawk-5.1.0.ebuild
index 3ab54c018ff1..3c3416405784 100644
--- a/sys-apps/gawk/gawk-5.1.0.ebuild
+++ b/sys-apps/gawk/gawk-5.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit toolchain-funcs multilib
+inherit toolchain-funcs
DESCRIPTION="GNU awk pattern-matching language"
HOMEPAGE="https://www.gnu.org/software/gawk/gawk.html"
@@ -29,13 +29,16 @@ BDEPEND="
src_prepare() {
default
- # use symlinks rather than hardlinks, and disable version links
+ # Use symlinks rather than hardlinks, and disable version links
sed -i \
-e '/^LN =/s:=.*:= $(LN_S):' \
-e '/install-exec-hook:/s|$|\nfoo:|' \
Makefile.in doc/Makefile.in || die
- sed -i '/^pty1:$/s|$|\n_pty1:|' test/Makefile.in || die #413327
- # fix standards conflict on Solaris
+
+ # bug #413327
+ sed -i '/^pty1:$/s|$|\n_pty1:|' test/Makefile.in || die
+
+ # Fix standards conflict on Solaris
if [[ ${CHOST} == *-solaris* ]] ; then
sed -i \
-e '/\<_XOPEN_SOURCE\>/s/1$/600/' \
@@ -46,17 +49,21 @@ src_prepare() {
src_configure() {
export ac_cv_libsigsegv=no
+
local myeconfargs=(
--libexec='$(libdir)/misc'
$(use_with mpfr)
$(use_enable nls)
$(use_with readline)
)
+
econf "${myeconfargs[@]}"
}
src_install() {
- rm -rf README_d # automatic dodocs barfs
+ # Automatic dodocs barfs
+ rm -rf README_d || die
+
default
# Install headers
@@ -66,7 +73,7 @@ src_install() {
}
pkg_postinst() {
- # symlink creation here as the links do not belong to gawk, but to any awk
+ # Symlink creation here as the links do not belong to gawk, but to any awk
if has_version app-admin/eselect && has_version app-eselect/eselect-awk ; then
eselect awk update ifunset
else
@@ -76,6 +83,7 @@ pkg_postinst() {
ln -s "${l##*/}" "${l/gawk/awk}" || die
fi
done
+
if ! [[ -e ${EROOT}/bin/awk ]] ; then
ln -s "../usr/bin/gawk" "${EROOT}/bin/awk" || die
fi