summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-02-12 19:37:24 +0000
committerJustin Lecher <jlec@gentoo.org>2017-02-12 19:51:50 +0000
commit4cf3fe6662033dee34c33a2ed48246c9cdee6835 (patch)
tree10ba3bcdc1a8118399e035a5a3d67a3b5d9463a0
parentsci-chemistry/pymol: Update icon (diff)
downloadgentoo-4cf3fe6662033dee34c33a2ed48246c9cdee6835.tar.gz
gentoo-4cf3fe6662033dee34c33a2ed48246c9cdee6835.tar.bz2
gentoo-4cf3fe6662033dee34c33a2ed48246c9cdee6835.zip
sci-biology/finchtv: Install icon
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=608722 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-biology/finchtv/finchtv-1.3.1-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-biology/finchtv/finchtv-1.3.1-r3.ebuild b/sci-biology/finchtv/finchtv-1.3.1-r3.ebuild
new file mode 100644
index 000000000000..a08703a6457d
--- /dev/null
+++ b/sci-biology/finchtv/finchtv-1.3.1-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+MY_PV="${PV//./_}"
+MY_P=${PN}_${MY_PV}
+
+DESCRIPTION="Graphical viewer for chromatogram files"
+HOMEPAGE="http://www.geospiza.com/finchtv/"
+SRC_URI="http://www.geospiza.com/finchtv/download/programs/linux/${MY_P}.tar.gz"
+
+LICENSE="finchtv"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+QA_PREBUILT="opt/bin/*"
+
+src_install() {
+ exeinto /opt/bin
+ doexe finchtv
+
+ dodoc ReleaseNotes.txt
+ docinto html
+ dodoc -r Help/*
+
+ insinto /usr/share/doc/${PN}
+ doins -r SampleData
+
+ newicon Help/media/FinchTV_Mac_App.png ${PN}.png
+}