summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-10-01 13:29:12 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-10-01 13:29:32 +0200
commit4cf5b106137a571ae2b558a0643fe6adecbea505 (patch)
treea1861c78cdbdab7fae85fcd51c424026f31a9696
parentlxqt-base/liblxqt: Add missed dependency on libXScrnSaver (diff)
downloadgentoo-4cf5b106137a571ae2b558a0643fe6adecbea505.tar.gz
gentoo-4cf5b106137a571ae2b558a0643fe6adecbea505.tar.bz2
gentoo-4cf5b106137a571ae2b558a0643fe6adecbea505.zip
app-vim/vim-tmux: new package.
vim-tmux is a vim plugin which offers support for tmux.conf. Gentoo-Bug: https://bugs.gentoo.org/592090 Package-Manager: portage-2.2.28
-rw-r--r--app-vim/vim-tmux/Manifest1
-rw-r--r--app-vim/vim-tmux/metadata.xml15
-rw-r--r--app-vim/vim-tmux/vim-tmux-3.0.0.ebuild23
3 files changed, 39 insertions, 0 deletions
diff --git a/app-vim/vim-tmux/Manifest b/app-vim/vim-tmux/Manifest
new file mode 100644
index 000000000000..d5c0fd77eb29
--- /dev/null
+++ b/app-vim/vim-tmux/Manifest
@@ -0,0 +1 @@
+DIST vim-tmux-3.0.0.zip 12713 SHA256 8ca059d610489a7d8be010aa1136c2501cbe18e86b0552e173fc0a5b6694dc24 SHA512 d6bc94c34ab32608610fdfffc3a3522b6056b3b61dd3cb9c63a71cb20d1597954aec65a06c5ce22352731d4e70b6a239ca5f303427182cce93324042b7f10c8c WHIRLPOOL 49f5b3e9b6e7d4608c049684605b393686c5f1ab447a71ac4af5c6b208829ab5df7f053eaa3bd8b327e6f9d5bd8d0af1547da8a47e89873325d3328ee42830bb
diff --git a/app-vim/vim-tmux/metadata.xml b/app-vim/vim-tmux/metadata.xml
new file mode 100644
index 000000000000..a383dda3cb39
--- /dev/null
+++ b/app-vim/vim-tmux/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Tools Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/vim-tmux/vim-tmux-3.0.0.ebuild b/app-vim/vim-tmux/vim-tmux-3.0.0.ebuild
new file mode 100644
index 000000000000..3bc87cf8efce
--- /dev/null
+++ b/app-vim/vim-tmux/vim-tmux-3.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: tmux support for vim"
+HOMEPAGE="https://github.com/tmux-plugins/vim-tmux"
+SRC_URI="https://github.com/tmux-plugins/${PN}/archive/v${PV}.zip -> ${P}.zip"
+LICENSE="vim.org"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ app-misc/tmux
+ app-arch/unzip"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ :;
+}