summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-30 05:08:37 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-30 05:08:37 -0500
commit4d2c46c944e666850ed4c48ce0c78e2eb1d4296d (patch)
tree104ae248a5f318d7a13786538c7a5efdf41cb52a
parentnet-mail/dovecot: fix automagic libexttextcat dependency (diff)
downloadgentoo-4d2c46c944e666850ed4c48ce0c78e2eb1d4296d.tar.gz
gentoo-4d2c46c944e666850ed4c48ce0c78e2eb1d4296d.tar.bz2
gentoo-4d2c46c944e666850ed4c48ce0c78e2eb1d4296d.zip
app-admin/puppet-agent: bup
Package-Manager: portage-2.2.20.1
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.2.7.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 7d29ce792b00..e89ca8e8faa1 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -6,3 +6,5 @@ DIST puppet-agent_1.2.5-1wheezy_amd64.deb 15187830 SHA256 4d557e45571df033a9e1ba
DIST puppet-agent_1.2.5-1wheezy_i386.deb 15122650 SHA256 f34a6e9c70b5276806dacf64fb2b41fd927e6875071d044f9901c5a8d9dacd1d SHA512 0989501ca3f011601bb301126ad58084571ee67eb961fbf1f5cf002eb9155bf4f8e838452ac62b45472f00c0a7538cb5c72c3e43c651675a7940d8ab9a1a309c WHIRLPOOL f9698e3154254d9931fdbccd9a75edccae8ab799f8add0e32995453d62a0d070001ad858449c5b816c1b1a448beb8b99b180558feea3b36fc84c0e730e2d5b7e
DIST puppet-agent_1.2.6-1wheezy_amd64.deb 15187698 SHA256 3448a92d6761bc1c284b17508bf541b0a8c40394b03e7608826e4f2a900e40cc SHA512 b5e6e43f22728cd7d9f4d103aa4de8fa1eccb3159abc31a921fa8f387dd0436a8d0f915b38be8ce233e39448b94f30be90e18da4e2861d6aeda9ef8a312474d2 WHIRLPOOL eca0f32e11b29050e53d93d02a68e874cc5f0f90d823aa7ea5241599872ef39d65f45103542fac84083b40ec47cf09435f27c4fb91b5a5c9a4dee84aa50a2c41
DIST puppet-agent_1.2.6-1wheezy_i386.deb 15122826 SHA256 271d62f7f6634b49632308d95c75519620335d176d3ee694a3cee42bb445d658 SHA512 3eae7b5a112baf1123c6d942e0b60ee07d76b02a8313a7122884b66f08077fbe430447857e5862182de7cf64ef90f931a49936d6967134937ccff84dd419ae4c WHIRLPOOL bce7ce95c3f6c21ca658d7ba25b3cb7b04c20e5af5499e3f4efb1df997dedd01e0982c67da332fcd8da901f06ce8683219baa6c7e02a7a4eed5ce20547bcfa35
+DIST puppet-agent_1.2.7-1wheezy_amd64.deb 15280016 SHA256 c250bcdeb22296ef3b0097da507b32f1503abbff332c68df10291dcb975243ed SHA512 f2e8d37415d9b6c260c8b4fdee44cc1b85ab784b57c944b856082cc9a65b3de32985527a65aac49ae3c3eea54736bf3c26e11af91c09fd6bfb3b065e98ca99d0 WHIRLPOOL e6b62d968dd0a10031b42afd052c2a280e5d50caae5d51f493a3f432cb4f74ff783db8c4cb77fd2bb6defb4fd1743ce220bf9143fa7c1c02a1b8dffe01a474b2
+DIST puppet-agent_1.2.7-1wheezy_i386.deb 15214412 SHA256 c2b9f51cfe3d3e43b3cdfb7a1c6c92abaeaf2c4ab26e9ceac5aba2b58cf1480e SHA512 6950e09c49da35c0cf463364b4ec468ba011f15d3caf9c59c58ef01a0cfd859cb5c97a3271d9a11c958a71c4c77ba45a8dab205124b92a80354da519dc1a2f3c WHIRLPOOL 12ce6f5ba23f00d1320d7cd40734485ac69bdddda8a9711e18f3549c12919592ca27394963578c5850400864e2b524e7034833e8b2985b15f06bb66f06df1b75
diff --git a/app-admin/puppet-agent/puppet-agent-1.2.7.ebuild b/app-admin/puppet-agent/puppet-agent-1.2.7.ebuild
new file mode 100644
index 000000000000..7de77c52fb14
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.2.7.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/wheezy/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1wheezy"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ sys-apps/dmidecode
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"
+
+S=${WORKDIR}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit "${FILESDIR}/puppet.service"
+ systemd_dounit "${FILESDIR}/mcollective.service"
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}