summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Petrina <jakov.petrina@sartura.hr>2021-12-08 11:32:26 +0100
committerJakov Smolić <jsmolic@gentoo.org>2021-12-08 12:26:09 +0100
commit4d8a8d9fe769fbf94f8fdf9bd2e1dcfaf5027c07 (patch)
tree511d65804ac1b947dd81923229e25c6f7ea23774
parentwww-servers/tomcat: bump to 9.0.56 (diff)
downloadgentoo-4d8a8d9fe769fbf94f8fdf9bd2e1dcfaf5027c07.tar.gz
gentoo-4d8a8d9fe769fbf94f8fdf9bd2e1dcfaf5027c07.tar.bz2
gentoo-4d8a8d9fe769fbf94f8fdf9bd2e1dcfaf5027c07.zip
app-misc/jdupes: add missing USE flags
This change introduces several USE flags enabling support for deduplication (enabled by default), low memory scenario handling, and compile-time hardening. Closes: https://bugs.gentoo.org/828495 Thanks-to: Andreas Thalhammer <andreas.thalhammer@linux.com> Signed-off-by: Jakov Petrina <jakov.petrina@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/23223 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--app-misc/jdupes/jdupes-1.20.2-r1.ebuild44
-rw-r--r--app-misc/jdupes/jdupes-9999.ebuild9
-rw-r--r--app-misc/jdupes/metadata.xml4
3 files changed, 56 insertions, 1 deletions
diff --git a/app-misc/jdupes/jdupes-1.20.2-r1.ebuild b/app-misc/jdupes/jdupes-1.20.2-r1.ebuild
new file mode 100644
index 000000000000..a6b6e30cf675
--- /dev/null
+++ b/app-misc/jdupes/jdupes-1.20.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Identify duplicate files on the filesystem"
+HOMEPAGE="https://github.com/jbruchon/jdupes"
+if [[ "${PV}" == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/jbruchon/jdupes.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jbruchon/jdupes/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="+dedupe lowmem hardened"
+
+# missing test.sh script
+# https://github.com/jbruchon/jdupes/issues/191
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e '/PREFIX/s/=/?=/' Makefile || die
+ default
+}
+
+src_compile() {
+ tc-export CC
+ local myconf=(
+ $(usex dedupe 'ENABLE_DEDUPE=1' '')
+ $(usex lowmem 'LOW_MEMORY=1' '')
+ $(usex hardened 'HARDEN=1' '')
+ )
+ emake ${myconf[@]}
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ einstalldocs
+}
diff --git a/app-misc/jdupes/jdupes-9999.ebuild b/app-misc/jdupes/jdupes-9999.ebuild
index 681f1d0f1493..a6b6e30cf675 100644
--- a/app-misc/jdupes/jdupes-9999.ebuild
+++ b/app-misc/jdupes/jdupes-9999.ebuild
@@ -17,6 +17,8 @@ fi
LICENSE="MIT"
SLOT="0"
+IUSE="+dedupe lowmem hardened"
+
# missing test.sh script
# https://github.com/jbruchon/jdupes/issues/191
RESTRICT="test"
@@ -28,7 +30,12 @@ src_prepare() {
src_compile() {
tc-export CC
- default
+ local myconf=(
+ $(usex dedupe 'ENABLE_DEDUPE=1' '')
+ $(usex lowmem 'LOW_MEMORY=1' '')
+ $(usex hardened 'HARDEN=1' '')
+ )
+ emake ${myconf[@]}
}
src_install() {
diff --git a/app-misc/jdupes/metadata.xml b/app-misc/jdupes/metadata.xml
index a710c4ca4077..5079763f7636 100644
--- a/app-misc/jdupes/metadata.xml
+++ b/app-misc/jdupes/metadata.xml
@@ -13,6 +13,10 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <use>
+ <flag name="dedupe">Enable deduplication support</flag>
+ <flag name="lowmem">Enable support for low-memory operation</flag>
+ </use>
<upstream>
<remote-id type="github">jbruchon/jdupes</remote-id>
</upstream>