summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2015-09-09 02:33:31 +0200
committerMichael Palimaka <kensington@gentoo.org>2015-09-25 05:29:25 +1000
commit4da17bc0ba54412fc25afbe7e7a01cdd9d42649a (patch)
treed18048c351787b299dbd3c79c10a7183909d7edc
parentapp-crypt/qca: Add upstream fix to use Q_SLOTS/Q_SIGNALS (diff)
downloadgentoo-4da17bc0ba54412fc25afbe7e7a01cdd9d42649a.tar.gz
gentoo-4da17bc0ba54412fc25afbe7e7a01cdd9d42649a.tar.bz2
gentoo-4da17bc0ba54412fc25afbe7e7a01cdd9d42649a.zip
kde-apps/konsole: Disable LibKonq if USE=minimal
LibKonq is required for drag-n-drop menus in konsole application. USE=minimal only installs konsolepart though, so disable it. One less blocker against kde-apps/libkonq:5 Package-Manager: portage-2.2.20.1
-rw-r--r--kde-apps/konsole/konsole-4.14.3-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/kde-apps/konsole/konsole-4.14.3-r1.ebuild b/kde-apps/konsole/konsole-4.14.3-r1.ebuild
new file mode 100644
index 000000000000..f5cb4e919455
--- /dev/null
+++ b/kde-apps/konsole/konsole-4.14.3-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KDE_DOC_DIRS="doc/manual"
+VIRTUALX_REQUIRED="test"
+VIRTUALDBUS_TEST="true"
+inherit kde4-base
+
+DESCRIPTION="X terminal for use with KDE"
+HOMEPAGE="https://www.kde.org/applications/system/konsole https://konsole.kde.org"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug minimal"
+
+COMMONDEPEND="
+ !aqua? (
+ x11-libs/libX11
+ x11-libs/libXext
+ >=x11-libs/libxklavier-3.2
+ x11-libs/libXrender
+ x11-libs/libXtst
+ !minimal? ( $(add_kdeapps_dep libkonq) )
+ )
+"
+DEPEND="${COMMONDEPEND}
+ !aqua? (
+ x11-apps/bdftopcf
+ x11-proto/kbproto
+ x11-proto/renderproto
+ )
+"
+RDEPEND="${COMMONDEPEND}"
+
+# can't connect to a kded instance, fails to connect to dbus
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with "!minimal" LibKonq)
+ )
+
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+
+ if use minimal; then
+ rm "${D}/usr/bin/konsole" || die
+ rm "${D}/usr/bin/konsoleprofile" || die
+ fi
+}