summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-06 04:21:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-06 04:21:57 +0200
commit4eeac9d11baf1f9760549a6c589c333ecc3b203c (patch)
treecd2a5298d31b4547cc924ef1dc55b2bc55d1d855
parentkde4-meta.eclass: Remove last-rited eclass (diff)
downloadgentoo-4eeac9d11baf1f9760549a6c589c333ecc3b203c.tar.gz
gentoo-4eeac9d11baf1f9760549a6c589c333ecc3b203c.tar.bz2
gentoo-4eeac9d11baf1f9760549a6c589c333ecc3b203c.zip
dev-python/pandas: Sync live with 0.20.3 bump changes
Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--dev-python/pandas/pandas-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/pandas/pandas-9999.ebuild b/dev-python/pandas/pandas-9999.ebuild
index c29b323ee1ac..bc2a5b634154 100644
--- a/dev-python/pandas/pandas-9999.ebuild
+++ b/dev-python/pandas/pandas-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -45,6 +45,7 @@ OPTIONAL_DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/statsmodels[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-0.8.1[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
dev-python/xlrd[${PYTHON_USEDEP}]
dev-python/xlwt[${PYTHON_USEDEP}]
sci-libs/scipy[${PYTHON_USEDEP}]
@@ -66,6 +67,7 @@ DEPEND="${MINIMAL_DEPEND}
>=dev-python/cython-0.23[${PYTHON_USEDEP}]
doc? (
${VIRTUALX_DEPEND}
+ app-text/pandoc
dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
@@ -101,13 +103,11 @@ RDEPEND="
python_prepare_all() {
# Prevent un-needed download during build
- sed \
- -e "/^ 'sphinx.ext.intersphinx',/d" \
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" \
-i doc/source/conf.py || die
# https://github.com/pydata/pandas/issues/11299
- sed \
- -e 's:testOdArray:disable:g' \
+ sed -e 's:testOdArray:disable:g' \
-i pandas/tests/io/json/test_ujson.py || die
distutils-r1_python_prepare_all