summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-03 19:17:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-03 19:17:18 +0200
commit4facdcf3c790bcac6d699f8e5da263c7477b4466 (patch)
tree4e7a2774c712b17071d66c1df4bca0666d4d2101
parentdev-libs/libgcrypt: Cleanup vulnerable version (diff)
downloadgentoo-4facdcf3c790bcac6d699f8e5da263c7477b4466.tar.gz
gentoo-4facdcf3c790bcac6d699f8e5da263c7477b4466.tar.bz2
gentoo-4facdcf3c790bcac6d699f8e5da263c7477b4466.zip
dev-ml/findlib: bump to 1.6.3
Package-Manager: portage-2.3.1
-rw-r--r--dev-ml/findlib/Manifest1
-rw-r--r--dev-ml/findlib/findlib-1.6.3.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-ml/findlib/Manifest b/dev-ml/findlib/Manifest
index f429cb801fc4..4c32d7e7c33c 100644
--- a/dev-ml/findlib/Manifest
+++ b/dev-ml/findlib/Manifest
@@ -2,3 +2,4 @@ DIST findlib-1.4.tar.gz 231526 SHA256 6e4065e5d79d31176ec213ff94599c4eae17c3904c
DIST findlib-1.5.6.tar.gz 250865 SHA256 7743b3dcaf8a344c882e89f61601f7f086d46c0f2ea4fcc3e54069236825e3f8 SHA512 18d23861a25b1508cb419af4cdd6e3cd83d51bef259f162c86b91460cf3dad75d6c2fc11173f60fe36b61ce3f81b78e69344f093adb9a82c36256d95180e93d8 WHIRLPOOL eb374e60c3f2fcc6172ec08803fbc5b0e83ea0d38644b4c13cb3d27b3dc13c7240a4f49a9ee51f9465ac6ff6075140c3e98b3eb0ea48690f260f139f37dfb63c
DIST findlib-1.6.1.tar.gz 254797 SHA256 411c816e89d17d1b5b454e3d42f9b261cf929fc468f9f6e2787273ab69784b09 SHA512 b781d117ff033e8b91b6610c562382c5868a25ceed51f0a5947a77bfdd5825723ad32adcbe1636d4f7952d4c7535093f5c8ad3b954bebb1dcf4738f7a16d3ef8 WHIRLPOOL 1c3ed89aeb53cd95c0eaa82f1df8c364ad79403cf89ca19245620819998353da089daf5d3377919f2b4676c48f4d926d384e5a80312884f84e1efc41307f88fd
DIST findlib-1.6.2.tar.gz 253764 SHA256 3917904342ffbb66089f9fec1adc023b8854178bc21f303e4cbf96b8b164c946 SHA512 8c4098e6956530bc88d20a1b91512c68368e8a866398ce4d504afe3f71e81124c01644ba31ff97da6e61e7410328b533fb1d31a513166231047dab1933179fc4 WHIRLPOOL a980082607ac97c738ef0899ba08af81eaa45c09a0e96f41ddfb3faaf25c77f133a3063f45a9393819e76b839b17bb10fe71613e83bfc943b4988511547eaa6b
+DIST findlib-1.6.3.tar.gz 254512 SHA256 0f989f3f8ea69838423331c34c72a81e5422038e88c2a2bf10bc6e89869cab7e SHA512 ab23eeef3ec301f1a429934a309734386169d31d16a82706a45d9914b1fdc50f04b4fdf86f9436be3d7f0c8869b2cd9a9e07c78247e12eabdfe0738861e22035 WHIRLPOOL ae0fd2ae107d0074bbf8aefffa0facd7d9b892fc3408f94911522866d0bf8e9d7ac9e20da92e0a20b2f6cdf2f26dac6f86fd7c97231119eef890306166bcf05b
diff --git a/dev-ml/findlib/findlib-1.6.3.ebuild b/dev-ml/findlib/findlib-1.6.3.ebuild
new file mode 100644
index 000000000000..f94705fd1236
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.6.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib eutils
+
+DESCRIPTION="OCaml tool to find/use non-standard packages"
+HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
+SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
+IUSE="doc +ocamlopt tk"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]
+ tk? ( dev-ml/labltk:= )"
+RDEPEND="${DEPEND}"
+
+ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
+stublibs="${ocamlfind_destdir}/stublibs"
+
+src_prepare() {
+ epatch "${FILESDIR}/externalmeta3.patch"
+}
+
+src_configure() {
+ local myconf
+ use tk && myconf="-with-toolbox"
+ ./configure -bindir "${EPREFIX}"/usr/bin -mandir "${EPREFIX}"/usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf \
+ -no-custom \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt # optimized code
+ fi
+}
+
+src_install() {
+ emake prefix="${D}" install
+
+ dodir "${stublibs#${EPREFIX}}"
+
+ cd "${S}/doc"
+ dodoc QUICKSTART README DOCINFO
+ use doc && dohtml -r ref-html guide-html
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}