summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-27 13:10:35 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-27 13:10:35 +0200
commit5099389df20a0d315dafb62cf41624149bd3deac (patch)
treebcdc6642cac7814f4c00c63e6337b532a3434125
parentdev-python/sphinxcontrib-trio: import from ::guru (diff)
downloadgentoo-5099389df20a0d315dafb62cf41624149bd3deac.tar.gz
gentoo-5099389df20a0d315dafb62cf41624149bd3deac.tar.bz2
gentoo-5099389df20a0d315dafb62cf41624149bd3deac.zip
dev-python/outcome: import from ::guru
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/outcome/Manifest1
-rw-r--r--dev-python/outcome/metadata.xml14
-rw-r--r--dev-python/outcome/outcome-1.1.0.ebuild29
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/outcome/Manifest b/dev-python/outcome/Manifest
new file mode 100644
index 000000000000..08ba4dcd8f2d
--- /dev/null
+++ b/dev-python/outcome/Manifest
@@ -0,0 +1 @@
+DIST outcome-1.1.0.tar.gz 18675 BLAKE2B eef22274bb4d1ddd19fa223167b6c8ce96f015ac0b3b0609aed3717deb306087457ab068fd2466d492fcc5859d561e6d3172ad14611a937ec59a75b604565953 SHA512 65de1c0a38b8cbb041a9fc3a79518eeacea54ec87341846ae80a9a2075369f72a397f5aa747ae179eaac8f341a7e07cc1641555fbb809cc7924b2171f7f3d90e
diff --git a/dev-python/outcome/metadata.xml b/dev-python/outcome/metadata.xml
new file mode 100644
index 000000000000..8423947bf6d0
--- /dev/null
+++ b/dev-python/outcome/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">python-trio/outcome</remote-id>
+ <remote-id type="pypi">outcome</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/outcome/outcome-1.1.0.ebuild b/dev-python/outcome/outcome-1.1.0.ebuild
new file mode 100644
index 000000000000..ca48567e6299
--- /dev/null
+++ b/dev-python/outcome/outcome-1.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Capture the outcome of Python function calls"
+HOMEPAGE="
+ https://github.com/python-trio/outcome
+ https://pypi.org/project/outcome
+"
+SRC_URI="https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/attrs[${PYTHON_USEDEP}]"
+
+BDEPEND="test? (
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source dev-python/sphinxcontrib-trio