summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2018-01-11 01:23:00 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2018-01-11 01:24:04 +0100
commit50a9c4534f66c91eecbd66a3932fd9112f6a5998 (patch)
treece1cb73968b214b484bf959556645ebbf57f7841
parentapp-text/docbook-xsl-stylesheets: fix HOMEPAGE (diff)
downloadgentoo-50a9c4534f66c91eecbd66a3932fd9112f6a5998.tar.gz
gentoo-50a9c4534f66c91eecbd66a3932fd9112f6a5998.tar.bz2
gentoo-50a9c4534f66c91eecbd66a3932fd9112f6a5998.zip
dev-python/scapy-python3: bump
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/scapy-python3/Manifest1
-rw-r--r--dev-python/scapy-python3/scapy-python3-0.23.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/scapy-python3/Manifest b/dev-python/scapy-python3/Manifest
index db30b834bbee..d67a849de796 100644
--- a/dev-python/scapy-python3/Manifest
+++ b/dev-python/scapy-python3/Manifest
@@ -1,2 +1,3 @@
DIST scapy-python3-0.18.tar.gz 2052898 BLAKE2B bf692fa71561dbbdfd5e3ccce7218af149bcfdbbd0232877d761cecfd3736259faaf8a5388a21461a3825c92b62046e44c06c8f5ce53c541cd63edfadd44ff5a SHA512 3b39e8cdb60dfd5d1e92eae681eb08f065ba14bbd647d55f3d4f62383a459c217024311c945c3731f1a58fe47e6b525492e760e2e1c8ea6eb807f7d59c975c5b
DIST scapy-python3-0.21.tar.gz 2179545 BLAKE2B 3ecedf3899fa36da5aa98374f599c51b1198e9f60e98e1d7e2bcc04509ca8ecb8f8985e8dfdc70da838cd555c8cbc0fe5dcab87b7cb6ba47abc7780b95471370 SHA512 d1f5eee914a25a7217f187fe8c757d330aa0375e1c90fb2e5f71ffaa2c7f97d0bf7e62f1e5ed9f9b7238a5d467d3c4f7186f5238b6d7444e94d9d98a1a602f76
+DIST scapy-python3-0.23.tar.gz 2196173 BLAKE2B 32a3b48c83a2e2a4262f47307bde02c272106f863bb52e362dc0e1a23ef2095426a7cdfe7ae53bc6ff980ef08277857a3e877777a6222d89a26812fd69b030b1 SHA512 9cb214a46f6f8b90c10afb903600472e389c30840e6e42c876cb035d18fe13f2affb2914263a668e802ac55727e7651e8dcc1c0ed753a92cd234488158a9ff60
diff --git a/dev-python/scapy-python3/scapy-python3-0.23.ebuild b/dev-python/scapy-python3/scapy-python3-0.23.ebuild
new file mode 100644
index 000000000000..9da508913c37
--- /dev/null
+++ b/dev-python/scapy-python3/scapy-python3-0.23.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+IUSE="test"
+inherit distutils-r1
+
+DESCRIPTION="Packet crafting/sending/... PCAP processing tool with python3 compatibility"
+HOMEPAGE="https://pypi.python.org/pypi/scapy-python3/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ !net-analyzer/scapy
+ "