summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 11:58:25 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commit50f067a442430d3c4227510fa00b648ae7448ba4 (patch)
tree34d5ace7bb2f6865e680cd0760b2d01cbd9c1e6b
parentdev-python/sphinx: Add python3.5 support (diff)
downloadgentoo-50f067a442430d3c4227510fa00b648ae7448ba4.tar.gz
gentoo-50f067a442430d3c4227510fa00b648ae7448ba4.tar.bz2
gentoo-50f067a442430d3c4227510fa00b648ae7448ba4.zip
dev-python/sphinx_rtd_theme: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.1.9-r1.ebuild23
-rw-r--r--dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.1.9.ebuild1
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.1.9-r1.ebuild b/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.1.9-r1.ebuild
new file mode 100644
index 000000000000..41a15f15b3fd
--- /dev/null
+++ b/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.1.9-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ReadTheDocs.org theme for Sphinx"
+HOMEPAGE="https://github.com/snide/sphinx_rtd_theme/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+
+# dev-python/sphinx previously set in PDEPEND which broke some doc builds.
diff --git a/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.1.9.ebuild b/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.1.9.ebuild
index c0c496b20577..1b3504ea2b5f 100644
--- a/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.1.9.ebuild
+++ b/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.1.9.ebuild
@@ -3,6 +3,7 @@
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1