summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPoncho <poncho@spahan.ch>2018-02-14 13:16:17 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-03-04 23:11:13 +0100
commit5101c60417100439ea1902db0ee9b3ccb0bbc192 (patch)
tree728d0a4486a1a76c97c3c9ca8bd17294bebc9ae5
parentapp-vim/info: use HTTPS. (diff)
downloadgentoo-5101c60417100439ea1902db0ee9b3ccb0bbc192.tar.gz
gentoo-5101c60417100439ea1902db0ee9b3ccb0bbc192.tar.bz2
gentoo-5101c60417100439ea1902db0ee9b3ccb0bbc192.zip
media-video/mediainfo: don't install two desktop files, fix QA warnings.
fix the following desktop file related QA warnings QA Notice: new icons were found installed but GTK+ icon cache has not been updated QA Notice: .desktop files with MimeType= were found installed but desktop mimeinfo cache has not been updated Closes: https://bugs.gentoo.org/638862 Closes: https://github.com/gentoo/gentoo/pull/7183 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--media-video/mediainfo/mediainfo-17.12.ebuild28
1 files changed, 17 insertions, 11 deletions
diff --git a/media-video/mediainfo/mediainfo-17.12.ebuild b/media-video/mediainfo/mediainfo-17.12.ebuild
index a6625f97df57..904d5ce192e3 100644
--- a/media-video/mediainfo/mediainfo-17.12.ebuild
+++ b/media-video/mediainfo/mediainfo-17.12.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
WX_GTK_VER="3.0"
-inherit eutils autotools wxwidgets
+inherit eutils gnome2-utils xdg-utils autotools wxwidgets
DESCRIPTION="MediaInfo supplies technical and tag information about media files"
HOMEPAGE="https://mediaarea.net/mediainfo/ https://github.com/MediaArea/MediaInfo"
@@ -34,8 +34,8 @@ src_prepare() {
local target
for target in ${TARGETS}; do
- cd "${S}"/Project/GNU/${target}
- sed -i -e "s:-O2::" configure.ac
+ cd "${S}"/Project/GNU/${target} || die
+ sed -i -e "s:-O2::" configure.ac || die
eautoreconf
done
}
@@ -43,7 +43,7 @@ src_prepare() {
src_configure() {
local target
for target in ${TARGETS}; do
- cd "${S}"/Project/GNU/${target}
+ cd "${S}"/Project/GNU/${target} || die
local args=""
[[ ${target} == "GUI" ]] && args="--with-wxwidgets --with-wx-gui"
econf ${args}
@@ -53,19 +53,25 @@ src_configure() {
src_compile() {
local target
for target in ${TARGETS}; do
- cd "${S}"/Project/GNU/${target}
+ cd "${S}"/Project/GNU/${target} || die
default
done
}
src_install() {
local target
for target in ${TARGETS}; do
- cd "${S}"/Project/GNU/${target}
+ cd "${S}"/Project/GNU/${target} || die
default
dodoc "${S}"/History_${target}.txt
- if [[ ${target} == "GUI" ]]; then
- newicon "${S}"/Source/Resource/Image/MediaInfo.png ${PN}.png
- make_desktop_entry ${PN}-gui MediaInfo ${PN} "AudioVideo;GTK"
- fi
done
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}