summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:05:56 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:05:56 -0500
commit513638242806025416eaa41a9b088a40595f161a (patch)
tree9c6688ffce5875c7e2d7a8c95e44d90041194fd5
parentEAPI=5 (diff)
downloadgentoo-513638242806025416eaa41a9b088a40595f161a.tar.gz
gentoo-513638242806025416eaa41a9b088a40595f161a.tar.bz2
gentoo-513638242806025416eaa41a9b088a40595f161a.zip
EAPI=5; minor tidying
Package-Manager: portage-2.2.24
-rw-r--r--games-action/bomberclone/bomberclone-0.11.8.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-action/bomberclone/bomberclone-0.11.8.ebuild b/games-action/bomberclone/bomberclone-0.11.8.ebuild
index 82e306259943..b9539b71d44f 100644
--- a/games-action/bomberclone/bomberclone-0.11.8.ebuild
+++ b/games-action/bomberclone/bomberclone-0.11.8.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit eutils autotools games
DESCRIPTION="BomberMan clone with network game support"
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="amd64 ~mips ppc ppc64 x86"
IUSE="X"
-DEPEND=">=media-libs/libsdl-1.1.0
+DEPEND=">=media-libs/libsdl-1.1.0[video]
media-libs/sdl-image[png]
media-libs/sdl-mixer[mod]
X? ( x11-libs/libXt )"
@@ -24,6 +24,7 @@ src_prepare() {
ecvs_clean
epatch "${FILESDIR}"/${P}-underlink.patch \
"${FILESDIR}"/${P}-gcc52.patch
+ mv configure.{in,ac} || die
eautoreconf
}
@@ -33,8 +34,7 @@ src_configure() {
--datadir="${GAMES_DATADIR_BASE}"
sed -i \
-e "/PACKAGE_DATA_DIR/ s:/usr/games/share/games/:${GAMES_DATADIR}/:" \
- config.h \
- || die
+ config.h || die
}
src_install() {