summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-04-04 12:49:57 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-04-04 12:53:52 +0100
commit51e3b7b286da47e86ac2959c49194304ab77dd95 (patch)
treede7db933b66cec23cb3c77cbf457f1295ce8de9d
parentdev-haskell/geniplate: drop masked package (diff)
downloadgentoo-51e3b7b286da47e86ac2959c49194304ab77dd95.tar.gz
gentoo-51e3b7b286da47e86ac2959c49194304ab77dd95.tar.bz2
gentoo-51e3b7b286da47e86ac2959c49194304ab77dd95.zip
dev-haskell/encoding: drop masked package
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/encoding/Manifest1
-rw-r--r--dev-haskell/encoding/encoding-0.8.5.ebuild46
-rw-r--r--dev-haskell/encoding/files/encoding-0.8.2-overflow.patch41
-rw-r--r--dev-haskell/encoding/metadata.xml14
-rw-r--r--profiles/package.mask5
5 files changed, 0 insertions, 107 deletions
diff --git a/dev-haskell/encoding/Manifest b/dev-haskell/encoding/Manifest
deleted file mode 100644
index b44f16e2b072..000000000000
--- a/dev-haskell/encoding/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST encoding-0.8.5.tar.gz 380798 BLAKE2B 0b8ccca2de17e00c59b114c8b6b7107a80e92e376cc3bf9d5e95eadf2a2c1e5a2d2a12294e7ec669b1203d4b4c6809c8a129aaf17f1022f361b64542fcf45d9b SHA512 2ae2f44007735bdcb6b7cd35614ffcb5fe211321d516350555b03d9074c679995260f30de1df788b800711613bfdca037cb9c24cf90afc88d32a706c237df386
diff --git a/dev-haskell/encoding/encoding-0.8.5.ebuild b/dev-haskell/encoding/encoding-0.8.5.ebuild
deleted file mode 100644
index 48de713accc6..000000000000
--- a/dev-haskell/encoding/encoding-0.8.5.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.6.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="A library for various character encodings"
-HOMEPAGE="http://code.haskell.org/encoding/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+systemencoding"
-
-RDEPEND=">=dev-haskell/extensible-exceptions-0.1:=[profile?] <dev-haskell/extensible-exceptions-0.2:=[profile?]
- >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
- >=dev-haskell/regex-compat-0.71:=[profile?]
- >=dev-lang/ghc-7.8.2:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.0
- >=dev-haskell/haxml-1.22 <dev-haskell/haxml-1.26
- test? ( dev-haskell/hunit
- dev-haskell/quickcheck )
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-0.8.2-overflow.patch
-)
-
-src_prepare() {
- default
-
- cabal_chdeps \
- 'regex-compat >=0.71 && <0.95' 'regex-compat >=0.71' \
- 'containers >=0.4 && <0.6' 'containers >=0.4 && <0.7'
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag systemencoding systemencoding)
-}
diff --git a/dev-haskell/encoding/files/encoding-0.8.2-overflow.patch b/dev-haskell/encoding/files/encoding-0.8.2-overflow.patch
deleted file mode 100644
index c8085c827197..000000000000
--- a/dev-haskell/encoding/files/encoding-0.8.2-overflow.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-https://github.com/dmwit/encoding/pull/11
-
-From ce27249d4260c7eb3f514c95d5edd762804dd4f3 Mon Sep 17 00:00:00 2001
-From: Sergei Trofimovich <slyfox@gentoo.org>
-Date: Sat, 29 Aug 2020 13:52:33 +0100
-Subject: [PATCH] Data/Map/Static/Builder.hs: avoid shiftL with negative offset
-
-On ghc-8.8 building `encoding` fails as:
-
-```
-Preprocessing library for encoding-0.8.5..
-arithmetic overflow
-```
-
-This happens because `findSplitSize` can't handle
-small values, like `findSplitSize 1` and calls `shiftL`
-with negative value, which is forbdden:
- https://hackage.haskell.org/package/base-4.14.0.0/docs/Data-Bits.html#v:shiftL
-
-Work it around by always passing non-negative offset.
-
-Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
----
- Data/Map/Static/Builder.hs | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Data/Map/Static/Builder.hs b/Data/Map/Static/Builder.hs
-index 486e19c..61851cd 100644
---- a/Data/Map/Static/Builder.hs
-+++ b/Data/Map/Static/Builder.hs
-@@ -37,6 +37,6 @@ treeDepth sz = find' [0..]
- findSplitSize :: Int -> Int
- findSplitSize len = let depth = treeDepth len
- free = (maxSize depth) - len
-- in if free <= (1 `shiftL` (depth - 2))
-+ in if 2 * free <= (1 `shiftL` (depth - 1))
- then maxSize (depth - 1)
- else len - (maxSize (depth - 2)) - 1
---
-2.28.0
-
diff --git a/dev-haskell/encoding/metadata.xml b/dev-haskell/encoding/metadata.xml
deleted file mode 100644
index 91bcaa50b9b3..000000000000
--- a/dev-haskell/encoding/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- Haskell has excellect handling of unicode, the Char type covers all unicode chars. Unfortunatly, there's no possibility to read or write something to the outer world in an encoding other than ascii due to the lack of support for encodings. This library should help with that.
- </longdescription>
- <use>
- <flag name="systemencoding">Provide the getSystemEncoding action to query the locale.</flag>
- </use>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 11e393549d93..b2ed7890be86 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -196,11 +196,6 @@ dev-haskell/network-protocol-xmpp
# in a month.
dev-haskell/test-framework-th-prime
-# Sergei Trofimovich <slyfox@gentoo.org> (2021-03-15)
-# Needs a port to ghc-8.10. No revdeps. Mask for removal
-# in a month.
-dev-haskell/encoding
-
# Andreas Sturmlechner <asturm@gentoo.org> (2021-03-15)
# Unmaintained for >1 year, blocking cleanup of deprecated libraries.
# Succeeded by LXQt many years ago (see also: lxqt-base/lxqt-meta).