summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2018-06-27 08:37:31 -0700
committerBrian Dolbec <dolsen@gentoo.org>2018-07-01 19:12:24 -0700
commit51e5d56a7aa25ee9e0065006c25788f705851f16 (patch)
tree667d749619944dd909bb34c37dcd048450425e85
parentsys-kernel/gentoo-sources: x86 stable (bug #649198) (diff)
downloadgentoo-51e5d56a7aa25ee9e0065006c25788f705851f16.tar.gz
gentoo-51e5d56a7aa25ee9e0065006c25788f705851f16.tar.bz2
gentoo-51e5d56a7aa25ee9e0065006c25788f705851f16.zip
dev-python/automat: Version bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
-rw-r--r--dev-python/automat/Manifest1
-rw-r--r--dev-python/automat/automat-0.7.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/automat/Manifest b/dev-python/automat/Manifest
index 055496074c2f..af99aefb7a7e 100644
--- a/dev-python/automat/Manifest
+++ b/dev-python/automat/Manifest
@@ -1,2 +1,3 @@
DIST Automat-0.5.0.tar.gz 32599 BLAKE2B 951da8840c2334fe3cd86804b39beedaad0d344d66742e8bb72e2d2ace2029b037acac8ffccc5643fd37f81020a567374a25ed42f7bc386770a30956464f52eb SHA512 7b4fc64e1b3cc514e3513c4be7387309a9e0c6d59ef091131404642b517a324b4a0eb677bee99da038664bd6713f2d2078c621f056e98b35966caf324741eeeb
DIST Automat-0.6.0.tar.gz 31767 BLAKE2B 28baa9d6cc7497f9c0a4b7f4050b197d3dff871b91f5f3e29bdc47ace443af8de0fbeacf1657dc6565b3ab824365362a42204d6d89a8dfc82eaa6cd92d4e2308 SHA512 94f2fa06b0e0e1c0538bcf4bd9046ea40600a018bdd1da2d5bed479877807ad56e448c4f1d7ec87341f80013ae6c35b01201cbe3c4ecae1105419038ed43024d
+DIST Automat-0.7.0.tar.gz 61461 BLAKE2B dd09ce090c7333ee17b701bde2c78e01dacf40cefee847061a2019bb27f0982091e7628737211421ada351937caf9c6734cb445ee6462ce84b381030b013bd05 SHA512 a6f307d312a3ceb721071b5212297c73d2306894b5fafd39265578041a2859bd6f041ac43a654bdda4175a70a4e90e0db1ee35cd43fa620cd5c594b5d1988a74
diff --git a/dev-python/automat/automat-0.7.0.ebuild b/dev-python/automat/automat-0.7.0.ebuild
new file mode 100644
index 000000000000..9671b0f11176
--- /dev/null
+++ b/dev-python/automat/automat-0.7.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+MYPN="Automat"
+MYP="${MYPN}-${PV}"
+
+DESCRIPTION="Self-service finite-state machines for the programmer on the go"
+HOMEPAGE="https://github.com/glyph/automat https://pypi.org/project/Automat/"
+SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/m2r[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+S=${WORKDIR}/${MYP}
+
+python_prepare_all() {
+ if use test ; then
+ # Remove since this is upstream benchmarking tests
+ rm -r benchmark || die "FAILED to remove benchmark tests"
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+src_install() {
+ if use examples; then
+ docinto examples
+ dodoc docs/examples/*.py
+ fi
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ einfo "For additional visualization functionality install these optional dependencies"
+ einfo " >=dev-python/twisted-16.1.1"
+ einfo " media-gfx/graphviz[python]"
+}