summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-31 23:57:27 +0000
committerSam James <sam@gentoo.org>2021-05-31 23:57:27 +0000
commit5276cd483e6fc3be512f28b1cb122702cfd3911e (patch)
treec3fc808b174f25fa58f78fb3ac7e5d6a42df28a0
parentdev-python/gmpy: remove broken mpir useflag (diff)
downloadgentoo-5276cd483e6fc3be512f28b1cb122702cfd3911e.tar.gz
gentoo-5276cd483e6fc3be512f28b1cb122702cfd3911e.tar.bz2
gentoo-5276cd483e6fc3be512f28b1cb122702cfd3911e.zip
dev-python/python-xmlsec: add 1.3.11
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/python-xmlsec/Manifest1
-rw-r--r--dev-python/python-xmlsec/python-xmlsec-1.3.11.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/python-xmlsec/Manifest b/dev-python/python-xmlsec/Manifest
index 9670aa3e5594..cabba08f444d 100644
--- a/dev-python/python-xmlsec/Manifest
+++ b/dev-python/python-xmlsec/Manifest
@@ -1,2 +1,3 @@
DIST python-xmlsec-1.3.10.tar.gz 75249 BLAKE2B 0e16e75c0bcb18d42cd4b5df95a2ecdb9918f0c654f81ee0a668ac9a8c0ffb1ccdfce71d552a0d8b4c218dd769be31ab2c5a1b80e8cdfb70a424a1cdba49da6e SHA512 9274ba4b9d9190a8f0f580e530c5c1efc34e3452a1459cea27636e7c594390902e8555dd4df0c38c243214ccb246430f4f60b1022d7cc369a7d67c3f113c8c68
+DIST python-xmlsec-1.3.11.tar.gz 75023 BLAKE2B 87fe4b47a9df6bc2fb2f1a459fa20240d9d5c92e0f7fa9bfc466e1fbfc0e3f12d90d01f5c7a6eac1389ea3252b8267a545203edf34c30117573bada9a7f5481a SHA512 fe0144d67edcad366b1d0f4615983f5630afd8f22aa056f46d1e6564f1c3114c0a469675e64a06591540515b0d12b5bf9304845f5138b24e15acaf4e5b861961
DIST python-xmlsec-1.3.9.tar.gz 75465 BLAKE2B 32aa8bcc2a17e1164fab6ebf37b47ad64bf8164a5d5cc5929571c32715e37d22143f996afc75c8a73a08e0a0a07d74ce1f8e405731260c1bcdb26c7ccb5faf25 SHA512 3c212c409430297a85316e0c4f7f704be112dfda323fd0300b7d70de812d90dd4681c6a5a3cc0314d1937ebc4f8e012fac7f787bccdfb2dc699d5d6f17316b38
diff --git a/dev-python/python-xmlsec/python-xmlsec-1.3.11.ebuild b/dev-python/python-xmlsec/python-xmlsec-1.3.11.ebuild
new file mode 100644
index 000000000000..2cdbbac944bb
--- /dev/null
+++ b/dev-python/python-xmlsec/python-xmlsec-1.3.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the XML Security Library"
+HOMEPAGE="https://github.com/mehcode/python-xmlsec"
+SRC_URI="https://github.com/mehcode/python-xmlsec/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-libs/xmlsec:=
+"
+RDEPEND="${DEPEND}
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+# tests fail, has been reported upstream
+# https://github.com/mehcode/python-xmlsec/issues/84
+RESTRICT=test
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s:use_scm_version=.*:version='${PV}',:" \
+ -e "/setup_requires/ d" \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}