summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-08-02 16:25:19 -0400
committerAaron Bauman <bman@gentoo.org>2020-08-02 16:27:08 -0400
commit529f1bfb60e92a2390761f4f6d764490af6c5d95 (patch)
treedfb6b95729cc75a4a3376d441e1a3012a0c96179
parentdev-python/sentry-sdk: formatting (diff)
downloadgentoo-529f1bfb60e92a2390761f4f6d764490af6c5d95.tar.gz
gentoo-529f1bfb60e92a2390761f4f6d764490af6c5d95.tar.bz2
gentoo-529f1bfb60e92a2390761f4f6d764490af6c5d95.zip
app-misc/khal: port to py3_{7,8}
Closes: https://bugs.gentoo.org/718230 Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--app-misc/khal/Manifest1
-rw-r--r--app-misc/khal/khal-0.10.1-r1.ebuild4
-rw-r--r--app-misc/khal/khal-0.9.10.ebuild43
3 files changed, 2 insertions, 46 deletions
diff --git a/app-misc/khal/Manifest b/app-misc/khal/Manifest
index 21514ca988a3..6c5897b1b924 100644
--- a/app-misc/khal/Manifest
+++ b/app-misc/khal/Manifest
@@ -1,2 +1 @@
DIST khal-0.10.1.tar.gz 173636 BLAKE2B 97158bc78dfbda3a3555df3588c61f6a5e8b20d71921099a74ba997eb7ccef05ed931e930afbb09f9c125f3e0e782143dd2cdf4d0da6bd09952765b9117d6ac4 SHA512 5b81a60099c201fa112ab17740b73edb17b29efa1548086766d57d9d595451e7d779aad5a2ce7a2afc78050116782ff6696c4bd284021a5e12c87fe361d15e47
-DIST khal-0.9.10.tar.gz 171132 BLAKE2B c9356bd65197db3a492939fbeec3c51c092ce02388a61fa1c426cc16e97fe509110c2f129203882504dd4d7bbe6ddf95a01d7147abf78a0a9b6c898af89814ee SHA512 7618e34e35726670721dfd12e1434d5ffe4221ffad5d751ef26dc26edab4334c847582bbd4f50cfb93f37a07397ccc467e240adaf3dcf1d9446e0ca6faff7721
diff --git a/app-misc/khal/khal-0.10.1-r1.ebuild b/app-misc/khal/khal-0.10.1-r1.ebuild
index 094279f9a340..6ef78da963d9 100644
--- a/app-misc/khal/khal-0.10.1-r1.ebuild
+++ b/app-misc/khal/khal-0.10.1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{7,8} )
PYTHON_REQ_USE="sqlite"
inherit distutils-r1
diff --git a/app-misc/khal/khal-0.9.10.ebuild b/app-misc/khal/khal-0.9.10.ebuild
deleted file mode 100644
index ab611970184e..000000000000
--- a/app-misc/khal/khal-0.9.10.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="A CalDAV based calendar"
-HOMEPAGE="http://lostpackets.de/khal/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-SLOT="0"
-IUSE="zsh-completion"
-
-RDEPEND=">=dev-python/click-3.2[${PYTHON_USEDEP}]
- >=dev-python/click-log-0.2.0[${PYTHON_USEDEP}]
- >=dev-python/icalendar-3.11.7[${PYTHON_USEDEP}]
- dev-python/urwid[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/configobj[${PYTHON_USEDEP}]
- >=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/tzlocal-1.0[${PYTHON_USEDEP}]
- dev-python/setproctitle[${PYTHON_USEDEP}]
- zsh-completion? ( app-shells/zsh )"
-DEPEND=">dev-python/setuptools_scm-1.12.0[${PYTHON_USEDEP}]
- dev-python/freezegun"
-
-DOCS=( AUTHORS.txt CHANGELOG.rst CONTRIBUTING.rst README.rst khal.conf.sample )
-
-src_install() {
- distutils-r1_src_install
- if use zsh-completion; then
- insinto /usr/share/zsh/site-functions
- doins misc/__khal
- fi
-}