summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-23 11:11:43 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-23 11:13:02 +0200
commit54b35723cd3d692b28eed7ccac7dc443499075bf (patch)
tree0d97dfc1abd3a4becb09ab8bb8fab9595a6e8b77
parentx11-apps/xkbset: move to x11-misc/xkbset (bug #571860). (diff)
downloadgentoo-54b35723cd3d692b28eed7ccac7dc443499075bf.tar.gz
gentoo-54b35723cd3d692b28eed7ccac7dc443499075bf.tar.bz2
gentoo-54b35723cd3d692b28eed7ccac7dc443499075bf.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.0
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.07.22.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 92c518f65522..bed130a0af77 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.07.13.tar.gz 2279744 SHA256 16cda6c8151445b90d3c43412788ff0bb7176e7d7d2a4325642b0e8113249443 SHA512 d0564f724e6b62ee65c48ee9db953101cc2045a2f4b66960be5be135bc61b0249553f74b6bd9f797cc6660109a4a266e43bf9a8646bbe3a8d806b5c022a96ee3 WHIRLPOOL 14720370cc11291d9f192d71ba3bdf241422e3331881e37f86165153f87ca636cc181ee2db8cc5cc9ed7b14c6eac0f2a910387159f421e5131cce4894fc92c82
DIST youtube-dl-2016.07.17.tar.gz 2288138 SHA256 a87d716b796df153a3561107a935d96c2b049507a09c0a02a4039e751ae63e33 SHA512 20349a25d15259509dfd34837b8938e050c7fd5da7566f435d83ccd76c02bf3ccce79ade1f3e97f2fe08dfe90473fe2e3cad754482f524fd8961fd1324d66025 WHIRLPOOL 128f2c7849669eff58bacc6d11f89f8758524cf615457a099e5b37707d23ca208ad98f587f68c4ec360ef27a310024f65883e2731039b1fb241e535423cc05aa
+DIST youtube-dl-2016.07.22.tar.gz 2291788 SHA256 69aad90eb92d0c2814ebdd3eefc863ad74a02a490e42cbbadf4befbbd8ed8c0b SHA512 1f1bb80bded13c45bfbdaded01a0259d91dcccbb583b34719426c26b00c3810cd6dc864953c2dc34f87f092e7973c22bb45042aecda5873984069a8031e25e92 WHIRLPOOL f8c3e67f4f2331ec5e6a97269cff88e4fed858f07b3203b605c6b2b7ac592a8a00bf308e5dd3d756c1cc3eae26aad9d482e199822bc5e0c1c12f5c8b97abfe6a
diff --git a/net-misc/youtube-dl/youtube-dl-2016.07.22.ebuild b/net-misc/youtube-dl/youtube-dl-2016.07.22.ebuild
new file mode 100644
index 000000000000..9d7ca82d0e68
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.07.22.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav trutube
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+}