summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-07-07 23:58:06 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-11 09:38:50 +0100
commit54b9f2f29bdea49f51e69b4ee1566fe28afbae30 (patch)
tree4094d2551ee5cae89bcb7918e9bc91f30ecb7c31
parentnet-im/yowsup: New package (diff)
downloadgentoo-54b9f2f29bdea49f51e69b4ee1566fe28afbae30.tar.gz
gentoo-54b9f2f29bdea49f51e69b4ee1566fe28afbae30.tar.bz2
gentoo-54b9f2f29bdea49f51e69b4ee1566fe28afbae30.zip
www-apps/cgp: new package
Closes: https://bugs.gentoo.org/654150 Package-Manager: Portage-2.3.41, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9096 Closes: https://bugs.gentoo.org/654150
-rw-r--r--www-apps/cgp/Manifest1
-rw-r--r--www-apps/cgp/cgp-1.ebuild52
-rw-r--r--www-apps/cgp/metadata.xml20
3 files changed, 73 insertions, 0 deletions
diff --git a/www-apps/cgp/Manifest b/www-apps/cgp/Manifest
new file mode 100644
index 000000000000..7fddb0cd05da
--- /dev/null
+++ b/www-apps/cgp/Manifest
@@ -0,0 +1 @@
+DIST cgp-1.tar.gz 139265 BLAKE2B bf0f18def8ac3c2117b951172d4150f0626e8dcbe22accbcc6ad156e5f9f5c21792e38fa1bf5a964d8b50cbc7ee9003e4dcdcd75730ba2b0445f4dcfeffdda6c SHA512 fc5bc6d39dac896b56579cb6ca013c81493b994a7a190e0c0eec8a64f7b87c6eb2e0ad5cc969b8ea03ca4b00eee212ccee5c8785c23f5656bff3fe5490ff8f75
diff --git a/www-apps/cgp/cgp-1.ebuild b/www-apps/cgp/cgp-1.ebuild
new file mode 100644
index 000000000000..0d1bc985b145
--- /dev/null
+++ b/www-apps/cgp/cgp-1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PN="${PN^^}"
+
+DESCRIPTION="A graphical web-based front-end for visualizing RRD collected by collectd"
+HOMEPAGE="https://github.com/pommi/CGP
+ https://pommi.nethuis.nl/category/cgp/"
+SRC_URI="https://github.com/pommi/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC-BY-2.0 GPL-2+ GPL-3 MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/php[json]
+ net-analyzer/rrdtool[graph]
+ virtual/httpd-php"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS=( "README.md" "doc/CHANGELOG" "doc/nginx.conf" )
+
+src_install() {
+ webapp_src_preinst
+
+ einstalldocs
+
+ # Since the docs are already installed, remove them from htdocs
+ # The file doc/CHANGELOG is needed, as CGP reads from there it's version
+ rm -r .gitignore doc/LICENSE doc/nginx.conf || die
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ einfo "The command shell_exec must not be disabled"
+ einfo "through the disable_functions php.ini directive."
+ einfo "It must allow execution of the rrdtool program."
+ einfo ""
+ einfo "An configuration file for www-servers/nginx"
+ einfo "has been installed as an example."
+}
diff --git a/www-apps/cgp/metadata.xml b/www-apps/cgp/metadata.xml
new file mode 100644
index 000000000000..10b010911e42
--- /dev/null
+++ b/www-apps/cgp/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Collectd Graph Panel (CGP) is a graphical web-based front-end
+ for visualizing RRD collected by collectd, written in the PHP language.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/pommi/CGP/issues</bugs-to>
+ <remote-id type="github">pommi/CGP</remote-id>
+ </upstream>
+</pkgmetadata>